CUIC 8 - Supervisor login

Unanswered Question
Jul 26th, 2010


I have installed CUIC 8 with premium license and integrated it with UCCE. The CUIC can see all supervisor agents from UCCE and from the user list i can see that the supervisor agents have permissions on their agents/teams only.

When I log in using any supervisor, a new user is created on CUIC 8 with the same login name of the supervisor, only small letters instead of capital. Now I have 2 users for the supervisor user, 1 in capital and 1 in small letters.

The new user does not have any permissions other than log in... all permissions created previously for the supervisor are not applied on this new user.

Is this normal? I dont think it should be. Is there a work around for it?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
boyd.lynn Wed, 11/10/2010 - 17:06

I have exactly the same problem. Does anybody know how to fix this?

karthikayyappan10 Tue, 04/05/2011 - 06:03

Hi all,

I have installed CUIC and i have synchronized this with ICM database. the supervisor users wre synched with cuic. but I cannot able to login with that supervisor user.

Is there any work around.



oabulaban Tue, 04/05/2011 - 06:06

Have you configured CUIC to integrate with the domain on which the supervisor users are created?

karthikayyappan10 Tue, 04/05/2011 - 06:19


Thanks for the response.

I have configured ADin CUIC. But still i am facing the issue.

Is there any thing i need to verify  Active Directory settings in CUIC.



oabulaban Tue, 04/05/2011 - 06:25

AD setting for CUIC are straightforward... and there is a validate button to check if the configuration made on CUIC was correct.

You then simply use the domain supervisor user created from the agent explorer tool and it should work

karthikayyappan10 Tue, 04/05/2011 - 06:35


The test connection with AD is successful. I can able to synch the supervisors like DOMAIN\supervisors in user list.

But still i cant able to log in to the CUIC. If i use that RUN AS option in CUIC it is working. But I cant able to login with that credentials.



boyd.lynn Tue, 04/05/2011 - 06:59

I possibly had a similar problem with CUIC.

From memory when the users are added automatically from AD they are inserted into CUIC as ALL upper case



However when you log on regardless of what case you type in the login you will login as


Obviously this is a bug but to get round it I just duplicated all the users as lower case with the appropriate permissions.

oabulaban Tue, 04/05/2011 - 07:04

body.lynn: True, this was a bug. It always created 2 users, 1 upper case and 1 lower case. This has been solved in 8.0(2) and later. The workaround was to give the same privileges to both created users.

oabulaban Tue, 04/05/2011 - 07:12

Karthik: Let's differentiate between 2 things:

1- logging in

2- seeing the users in the user list

When you integrate with ICM, CUIC gets the supervisor usernames (DOMAIN\supervisor) from ICM directly. Hence, you can see the users from CUIC and can assign them the privileges you want. You can also use the RUN AS functionality.

This all means you have proper integration with ICM.

Your problem is when you try to login using any of those users (DOMAIN\supervisor). When you try to log in, CUIC communicates with AD to do the authentication. I can see a couple of issues that might appear here:

1- CUIC cannot see AD  (you confirmed its correct, so that shouldnt be your case)

2- AD configuration does not point to the OU where the supervisor users are located

3- The domain user you are using to integrate with might not have the privilege to do authentication on AD

4- When logging in, you do not use the complete DOMAIN\supervisor in the username field. The DOMAIN has to be written, the user alone will not work

I usually do the following:

1- try using a domain admin account

2- in the user search base, make sure to add the complete cisco ipcc OUs (Cisco_ROOT, Facility, instance)

Chris.higginbottom Fri, 05/13/2011 - 06:22

Hi, Did anyone solve this? I seem to have the same issue and have worked over the last items in the last post but no luck.

Thanks Chris

Arpit Arora Wed, 03/14/2012 - 09:39

I have just installed 8.5.2 and also i am facing the problem that Users got synchronised from AD but unable to login with these users.

If i use that RUN AS option in CUIC it is working. But I cant able to login with that credentials.

Did anyone has any solution to this???



oabulaban Wed, 03/14/2012 - 09:43


What do you mean by Users got synchronized from AD?

Users get synchronized from UCCE, not AD.

AD configuration is only used for checking the password.

I would suggest trying a DOMAIN ADMIN account, maybe its a domain privileges issue

Arpit Arora Wed, 03/14/2012 - 10:00

Sorry, users got synchronised from UCCE.

Actually I have two CUIC with me : one is version 8.0(4)

and another is 8.5(2) which is newly installed.

All the synchronised users are able to login on version 8.0(4) but on 8.5(2) getting the error "Invalid username or password. Please try again".

oabulaban Wed, 03/14/2012 - 10:03

I face the same issue as you are, as the configuration i did with 8.0(x) is working fine while 8.5(x) is not.

Just to confirm, your configuration of AD is showing a successful AD connection, right? Because that's whats happening with me.

My approach as I said earlier will be to try the domain admin. unfortunatly, i wont be able to test that in the coming 2 weeks at least, so if you could do that, maybe it will work.

oabulaban Thu, 03/15/2012 - 01:01

There goes the test I was putting some hope one. Sorry, no clue

Arpit Arora Mon, 03/19/2012 - 04:21


My issue resolved after i changed the OU in user search base.

OU used earlier was OU=Cisco_ROOT\ Facility\instance

OU which is working fine is OU=Cisco_ROOT,OU= Facility,OU= instance


Arpit Arora


This Discussion