HSRP/STP Issue?

Unanswered Question
Jul 26th, 2010

I'm having an issue which I believe is either HSRP or STP. I have 2 - 6513s as my core switches with VLAN interfaces and spanning tree configured as in the example below:

Core 1

interface vlan 100

description XXX

ip address 10.123.100.2 255.255.255.192

ip helper-address 10.123.123.136

no ip redirects

no ip unreachables

ip pim sparse-dense-mode

standby 1 ip 10.123.100.1

standby 1 priority 95

spanning-tree vlan 100 priority 16384

Core 2

interface vlan 100

description XXX

ip address 10.123.100.3 255.255.255.192

ip helper-address 10.123.123.136

no ip redirects

no ip unreachables

ip pim sparse-dense-mode

standby 1 ip 10.123.100.1

standby 1 priority 105

standby 1 preempt

spanning-tree vlan 100 priority 12288

When I "show standby brief" the VLAN shows:

Core 1

95 - Standby - 10.123.100.3 - local - 10.123.100.1

Core 2

105 - Active - local - 10.123.100.2 - 10.123.100.1

The issue is the Virtual IP can only be pinged from .3 unless the .2 interface is shut. Any ideas??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CSCO11584685 Tue, 07/27/2010 - 03:22

Can you ping your Virtual IP from other switches, devices? can you ping your standby and active from other switches, devices? if yes, there should be no issue.

at least the "show standby brief" doesnt show anything strange. and your HSRP seems to be fully functioning.

dasmith58 Tue, 07/27/2010 - 05:29

When I ping from other switches and / or devices I can only ping the .2 & .3 not the VIP (.1). If I shut the .2 interface I can ping the .3 and the VIP (.1)

CSCO11584685 Tue, 07/27/2010 - 15:27

thats strange. your configurations posted seems valid, so the output of your hsrp instance. why dont you check your routing table, and spanning tree table. see which ports are forwarding which are not. do a drawing of how your network should look like and try to troubleshoot. traceroute will help as well. see if your arp is being distrubuted (for VIP).

Actions

This Discussion

Related Content