High CPU utilization: K5 L2 Hardware Addre 86%

Unanswered Question

We have a Catalyst 4510R which shows 99 - 100% CPU utilization most of the time.  We are running ENTSERVICESK9-M v 12.2(53) SG2.  Sho process cpu sort: Cat 4K Mgt LoPri is high @ 89%, Sho platform health: K5 L2 Hardware Addre is 86% and sho platform cpu packet stat: Event:Packets dropped in processing;  Sa Miss 5sec = 22455,Packets dropped by reason: Tx Mode Drop = 23400/hr

We have gone thru the Cisco docs and discussions and don't see any thing that matches up with what we show.  Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Matthew Blanshard Mon, 07/26/2010 - 22:24

SA Miss is populated when the source MAC is unknown for the packet so it is sent to the CPU for mac learning.  You can run the following commands to see the packets going to the CPU:

debug platform packet all receive buffer

Wait a minute and then run

show platform cpu packet buffered

Also it could be helpful turning on mac move notification to see if you are getting
continious mac flapping between dual nic servers or something like that. 

How many mac addresses are learned on the switch?

Any RSPAN or anything like that configured?




Thanks for the response.  The packets are in two vlans, one is the firewall interface the other is a data warehouse vlan.

Part of the solution to this issue is probably on a blade server in the data vlan that has multi-NIC's that are bound in an etherchannel for redundency.  I plan to break the etherchannel and trunk each NIC and see is the dropped packets and CPU utilization improve.  If it does we will research the blade config and re-config the blade NIC's/4510's etherchannel and monitor the dropped packets and CPU for changes.  If that is the issue I will post it here.



olvg-ait Wed, 06/24/2015 - 02:56

Thanks a lot your advice helped me locate the same problem.

using show platform cpu packet buffered i saw a lot of packets coming from certain ip adresses linking to a ESXI Server which had Teaming enabled and our side on the switch didnt had Etherchannel enabled on group mode on. After enabling it the CPU problem was resolved.





This Discussion

Related Content