cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
862
Views
0
Helpful
2
Replies

MTU on Cisco 7600 GRE

Antonio_1_2
Level 1
Level 1

Hello,

I have two routers Cisco 7600 and GRE tunnel configured between them:

R1---GRE---R2

R1 and R2 are interconnected via GigabitEthernet interfaces configured as layer 2 switchports.

Layer 3 conncetion is configured via interface VLAN 10.

Here are configurations of both routers:

--------------------------------------------------------

Router R1

interface Loopback1
description Source for GRE
ip address 10.0.0.1 255.255.255.255

interface Tunnel1
description GRE Tunel
ip address 10.20.0.1 255.255.255.252
tunnel source Loopback1
tunnel destination 10.0.0.2

interface GigabitEthernet1/1
description interface to R2
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10
mtu 9216

interface Vlan10
description Link to R2
ip address 10.10.10.1 255.255.255.252

ip route 0.0.0.0 0.0.0.0 tunnel 1
ip route 10.0.0.2 255.255.255.255 10.10.10.2

-----------------------------------------------------------------
Router R2

interface Loopback1
description Source for GRE
ip address 10.0.0.2 255.255.255.255

interface Tunnel1
description GRE Tunel
ip address 10.20.0.2 255.255.255.252
tunnel source Loopback1
tunnel destination 10.0.0.1

interface GigabitEthernet2/1
description interface to R1
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 10
switchport trunk allowed vlan 10
mtu 9216

interface Vlan10
description Link to R2
ip address 10.10.10.2 255.255.255.252

ip route 10.0.0.1 255.255.255.255 10.10.10.1

-------------------------------------------------------------------

I have problem with MTU over GRE tunnel and I thought that it is enough to enlarge MTU on physical

GigabitEthernet links on both routers. I set it on 9216.

But when I issue "show ip int tunnel 5" I see that MTU is 1476 Bytes.

I suppose that I have to set also int VLAN MTU to 9216. What is the limitation of interface VLAN MTU?

Does't it depend on physical interface that this VLAN is allowed on? Do I have to set also MTU on interface tunnel1?

I have to configure this on production network so, I is there a possibility that packet fragmentation will occur if I don't configure MTU well?

thanks in advance,A.

A.

2 Replies 2

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Antonio,

>> Do I have to set also MTU on interface tunnel1?

yes I would try so

>> s there a possibility that packet fragmentation will occur if I don't configure MTU well?

this is likely to happen without tuning

Note: be aware that in a recent thread an important limit of GRE on C6500 (and I suppose on C7600) has been pointed out: if multiple point to point GRE tunnels have to created, each needs to have a different local endpoint in order to take advantage of HW assisted GRE forwarding.

The initial poster of that thread had multiple tunnels sourced by a single loopback and he could see main cpu rising quickly for this limitation

Hope to help

Giuseppe

Hi Giuseppe,

MTU of GRE tunnel depends on MTU of interface VLAN, right?

And I can enlarge interface VLAN MTU to 9216 Bytes?

In which situation I can expect packet fragmentation to occur? is ti situation, i.e if I enlarge Tunnel MTU and interface VLAN MTU stays 1500?

regards,

A.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: