Upgrade candidates found in the patch directory are not allowed by the current version

Answered Question
Jul 27th, 2010

I am running CUCM 7.1.5.11901-1 and trying to upgrade to the new 7.1(5b)  "7.1.5.30000-1".

When trying to pull the upgrade from the SFTP I get the following message "Upgrade candidates found in the patch directory are not allowed by the current version".

Any ideas?

I have this problem too.
0 votes
Correct Answer by Phillip Ratliff about 6 years 4 months ago

7.1(5)SU1 is 7.1.5.11900-6 so you are basically one ES build past that.  You'll note that the compatibility matrix indicates you can only upgrade to 7.1(5b) from 7.1(5a) or 7.1(5) base.  Michael's blog entry will help you understand why 7.1.5.30000-1 is not actually a higher version than 7.1.5.11901-1.

Some helpful links:

CUCM compatibility matrix

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp43011

CUCM Upgrade Tool

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080b31514.shtml

-Ryan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Phillip Ratliff Tue, 07/27/2010 - 20:14

7.1(5)SU1 is 7.1.5.11900-6 so you are basically one ES build past that.  You'll note that the compatibility matrix indicates you can only upgrade to 7.1(5b) from 7.1(5a) or 7.1(5) base.  Michael's blog entry will help you understand why 7.1.5.30000-1 is not actually a higher version than 7.1.5.11901-1.

Some helpful links:

CUCM compatibility matrix

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp43011

CUCM Upgrade Tool

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a0080b31514.shtml

-Ryan

Zeek Ferraros Wed, 07/28/2010 - 07:48

Thank you, you guys gave me the right answer.

I just got confused yesterday when after opening a TAC I got the following response from a Cisco tech.

Of course the path he mentioned never worked.

"My apologies if I dint conveyed that we cannot upgrade directly from 7.1.5.11901-1 to 7.1.5.30000-1 as per the link below:

http://www.cisco.com/en/US/partner/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp201999

The path we have to follow is

7.1.5.11901-1>>7.1.5.20000-6 (restricted)>> 7.1.5.30000-1 (restricted)

Do let me know if you have any queries regarding the same."

Phillip Ratliff Wed, 07/28/2010 - 08:01

The path we have to follow is

#7.1.5.11901-1>>7.1.5.20000-6 (restricted)>># 7.1.5.30000-1 (restricted)

You can't go from your current version to 7.1(5a) either.

I think we should take a step back and find out why you are upgrading to begin with?  On your current version you have all of the fixes included in 7.1(5b) already, except for CSCth71003.  Unless you are installing an unrestricted CUCMBE server then you don't need 7.1(5b) at all.

You will gain nothing by going from your current version to 7.1(5b) and if you did manage to do it you would in fact lose all of the bug fixes that went in between 7.1.5.10000-12 (the main release of 7.1.5) and your current version.

The two bug fixes that resulted in 7.1(5a) and 7.1(5b) being released were due to support for unrestricted builds of CUCM.   If you aren't required to run the unrestricted CUCM then you don't need to be on either of those versions.

-Ryan

Actions

This Discussion