LMS 3.2: Software Distribution - Generic Error

Unanswered Question
Jul 28th, 2010
User Badges:

Hy.


I need to roll out an IOS on r.a. 250 devices. But when I try to distribute any software image via RME I always get the same error. I'm unable to start the job because in step one after selecting image and devices I get "failure" for all devices. When I click on "failure" a pop-up window opens telling me "generic error". Please have a look at the attached screenshot.

What does this mean and how can I fix this? This is really urgent!

All devices are completely managable (and managed) by the LMS.


Thank in advance!


Marc

Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nael Mohammad Wed, 07/28/2010 - 10:32
User Badges:
  • Silver, 250 points or more

Which IOS image are you trying to deploy and which device ?

Go to Common Services --> Software Center --> Software Update and provide screenshot.


Go to RME --> Admin --> Software Management ---> View/Edit Software Prefrences and check to see if "Include Cisco.com image "  for recommendation is selected.  If not, check them.


Try a different image that is higher that the current one and or use a GD image.

mwynen Thu, 07/29/2010 - 05:20
User Badges:

Hy.


We have to use c2960-lanbasek9-mz.122-44.SE3.bin with Catalyst 2960 switches. But we have the same effect with c3560-ipbasek9-mz.122-44.SE3.bin and Catalyst 3560 switches.

The IOS is a customers requirement!


I've checked the "Include Cisco.com image" box and tried it again. The result is the same as before.


You can find the screenshot of the software-center attached.


cheers

Marc

Martin Ermel Thu, 07/29/2010 - 06:02
User Badges:
  • Blue, 1500 points or more

enable SoftwareMgmt debugging in RME > Admin > System Preferences > Application Log Level Settings start the job and post the output of NMSROOT\log\swim_debug.log

mwynen Thu, 07/29/2010 - 06:17
User Badges:

I've activated debugging, but as I told you before I can't start the job. Nevertheless you can see inside of this log that I was trying to and got an error.

Needed to zip it because it was much too big.


cheers

Marc

Attachment: 
Martin Ermel Thu, 07/29/2010 - 06:31
User Badges:
  • Blue, 1500 points or more

please post a screenshot of RME --> Admin --> Software Management ---> View/Edit Software Prefrences

Martin Ermel Thu, 07/29/2010 - 07:08
User Badges:
  • Blue, 1500 points or more

so you have ssh enabled on the devices and DCR
has the credentials in its database?

Sorry, - but have you yet loaded the images into the SWIM repository of RME ?

mwynen Thu, 07/29/2010 - 07:23
User Badges:

Yes, the credentials are stored in the repository and the creden tials check is successfull for all devices.


See a screenshot of the repository. I've checked the two IOS images i was tralking about earlier.


cheers

Marc

Martin Ermel Fri, 07/30/2010 - 13:21
User Badges:
  • Blue, 1500 points or more

in one of the logs I see an error when the process trys to read the repository  but I do not see why - perhaps it is a device package problem or a bug with one of the dev.pkgs..-

I am sorry but I will be on vacation the next 3 weeks - so hopefully somebody else jumps in ...

Actions

This Discussion