Unable to install AnyConnect Client

Unanswered Question
Jul 28th, 2010

My IT department is requiring an upgrade of the Cisco AnyConnect Client.  I am not sure what version I had before, but I believe it was a 3.x version.  That version was working fine.  However, whenever I try to install the Cisco AnyConnect version 2.4.1012, it fails with the error:

Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.  Action VACon_Install, location: C:\Program Files\Cisco\Cisco AnyConnect VPN Client\VACon.exe, command: -install "C:\Program Files\Cisco\Cisco AnyConnect VPN Client\vpnva.inf" VPNVA

I am running Windows Vista for Business (32 bit).

I have been working on this problem for a few days with no solution. Some of the things that I have tried:

- Ensuring that my account has administrator access.

- Turning off all virus protection and firewalls.

- Manually removing all traces of all Cisco VPN Clients from the system (not sure if i was able to remove ALL traces)

- Shutting down all unnecessary services during install.

No matter what I do, I get the above error.  Any help would be appreciated.

I have attached the MSI install log below.  You can see the error occur at line 2151.

Thank You.

I have this problem too.
2 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Rahul Govindan Wed, 07/28/2010 - 07:50

Can you try installing the msi as follows:

MSIExec /i anyconnect-win-x.x.xxxx-pre-deploy-k9.msi NOINSTALLACTIVEX=1
kjhealey2726 Wed, 07/28/2010 - 08:04


Thank you for your help.  I tried that and received the same error.  Any other suggestions?

Thank You.

bravotom99 Thu, 07/29/2010 - 07:20

Check if you have this key in the registry.   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce.  If not, add it and then try the install again

kjhealey2726 Thu, 07/29/2010 - 08:31


Thank you for your response.  However, I have seen that suggestion on the web and already checked.  The registry key was already there.

Thank you,



This Discussion