Cisco Switch configuration help

Answered Question
Jul 28th, 2010
User Badges:

Hello,


I'm a new guy to Cisco, so I apologize if my question seems simplistic.  I currently have a port that looks like this:


interface FastEthernet5/1
no ip address
switchport
switchport access vlan 8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 8
switchport mode trunk
switchport nonegotiate


I try to run the command "switchport mode dynamic auto" but recieve the error message "Command rejected: Conflict between nonegotiate and dynamic status"  How would I go about turning off swichport nonegotiate on this interface so that I may enable dynamic auto mode?  Also, is there a way to remove configuration such as " switchport trunk allowed vlan 8" and "switchport access vlan 8"  We don't really need them active any longer.  Thanks for any help.  The version is 12.1(13) E5 and it is a module in a Calyst 6500.  Thanks.

Correct Answer by Jon Marshall about 6 years 9 months ago

Andrew


Can you post -


1) "sh ip int brief" from L3 switch

2)  "sh int trunk" from 3560

3) "sh vtp status" from both switches

4) "sh vlan" from both switches

5) "sh ip route" from 3560


Jon

Correct Answer by Leo Laohoo about 6 years 9 months ago

Since there are alot of "no" commands, we'll kill the entire interface with the command "default interface FastEthernet5/1".  Then you go to the interface level and add what you want.


interface FastEthernet5/1

switchport mode dynamic auto

Correct Answer by johuggin about 6 years 9 months ago

Edit:


What Jon said.


-Joe

Correct Answer by Jon Marshall about 6 years 9 months ago

D01041708 wrote:


Hello,


I'm a new guy to Cisco, so I apologize if my question seems simplistic.  I currently have a port that looks like this:


interface FastEthernet5/1
no ip address
switchport
switchport access vlan 8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 8
switchport mode trunk
switchport nonegotiate


I try to run the command "switchport mode dynamic auto" but recieve the error message "Command rejected: Conflict between nonegotiate and dynamic status"  How would I go about turning off swichport nonegotiate on this interface so that I may enable dynamic auto mode?  Also, is there a way to remove configuration such as " switchport trunk allowed vlan 8" and "switchport access vlan 8"  We don't really need them active any longer.  Thanks for any help.  The version is 12.1(13) E5 and it is a module in a Calyst 6500.  Thanks.


int fa5/1

no switchport nonegotiate

no switchport access vlan 8

no switchport trun allowed vlan 8

no switchport mode trunk

switchport mode dynamic auto


personally i would decide whether you want the port to be a trunk or an access port -


if trunk


int fa5/1

switchport trunk encapsulation dot1q

switchport mode trunk


or access


int fa5/1

switchport mode access

switchport access vlan 8

spanning-tree portfast <-- if this port connected to an end PC/printer/server/router but not another switch


Jon

Correct Answer by jimmysands73_2 about 6 years 9 months ago

Most commands can be negated by the no form of it.


no switchport trunk allowed vlan 8


and


no switchport access vlan 8


and


no swichport nonegotiate



On the selected interface.


Good luck!

Jimmy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Correct Answer
jimmysands73_2 Wed, 07/28/2010 - 17:22
User Badges:
  • Silver, 250 points or more

Most commands can be negated by the no form of it.


no switchport trunk allowed vlan 8


and


no switchport access vlan 8


and


no swichport nonegotiate



On the selected interface.


Good luck!

Jimmy

Correct Answer
Jon Marshall Wed, 07/28/2010 - 17:23
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

D01041708 wrote:


Hello,


I'm a new guy to Cisco, so I apologize if my question seems simplistic.  I currently have a port that looks like this:


interface FastEthernet5/1
no ip address
switchport
switchport access vlan 8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 8
switchport mode trunk
switchport nonegotiate


I try to run the command "switchport mode dynamic auto" but recieve the error message "Command rejected: Conflict between nonegotiate and dynamic status"  How would I go about turning off swichport nonegotiate on this interface so that I may enable dynamic auto mode?  Also, is there a way to remove configuration such as " switchport trunk allowed vlan 8" and "switchport access vlan 8"  We don't really need them active any longer.  Thanks for any help.  The version is 12.1(13) E5 and it is a module in a Calyst 6500.  Thanks.


int fa5/1

no switchport nonegotiate

no switchport access vlan 8

no switchport trun allowed vlan 8

no switchport mode trunk

switchport mode dynamic auto


personally i would decide whether you want the port to be a trunk or an access port -


if trunk


int fa5/1

switchport trunk encapsulation dot1q

switchport mode trunk


or access


int fa5/1

switchport mode access

switchport access vlan 8

spanning-tree portfast <-- if this port connected to an end PC/printer/server/router but not another switch


Jon

Correct Answer
Leo Laohoo Wed, 07/28/2010 - 17:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Since there are alot of "no" commands, we'll kill the entire interface with the command "default interface FastEthernet5/1".  Then you go to the interface level and add what you want.


interface FastEthernet5/1

switchport mode dynamic auto

Andrew Lutz Wed, 07/28/2010 - 18:11
User Badges:

I want to use it as a trunk port, I will use what you suggested here.  For whatever reason, I'm unable to ping the switch I am trunking to from my workstation.  If I do a sh cdp neighbor from my layer 3 switch (port fas 5/1 is on the layer 3 switch), It does show up.  The link status on the interface is up as well.  What I have done on the 3560 switch (the switch I am trucking to) is:


1. Configured interface Vlan1 with an IP address and subnet mask.


2. Made port 0/1 on the the 3560 switch a trunking port with these commands :

switchport trunk encapsulation dot1q

switchport mode trunk


3. Configured the default-gateway as the vlan interface on the layer 3 switch (all of the other switches that are trunked to this switch do this)


4. VTP domain name was set to the same as the layer 3 switch and is in client mode


Can you think of anything I am missing?  I'm not sure what it means that it shows up as a cdp neighbor but I can't reach it from a separate vlan.  VTP doesn't seem to be working as none of the VLANs from the layer 3 show up when I do a show vlan.  Could it be that I'm trying to trunk a fast ethernet port to a gigabit POE port?  Any ideas are appreciated.





Thanks to all of you for your help.  It's slightly embarressing I couldn't figure out those commands, glad I can hide behind the LCD screen!  I can't thank you all enough for your quick replies.

Correct Answer
Jon Marshall Thu, 07/29/2010 - 03:06
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Andrew


Can you post -


1) "sh ip int brief" from L3 switch

2)  "sh int trunk" from 3560

3) "sh vtp status" from both switches

4) "sh vlan" from both switches

5) "sh ip route" from 3560


Jon

Andrew Lutz Thu, 07/29/2010 - 08:27
User Badges:

Hey Jon, thanks for your reply.  After walking away from it I was able to figure out the issue....at least it is working.  Here is what

I did:


1) I didn't realize that the VTP domain name was case sensitive.  Once I fixed that, it worked fine.

2) I only had the trunking port connected from the 6500 to the 3560.  Once I connected another port via cat5e from one switch to the other with the ports configured in access mode, I can now telnet into it from my workstation.


Sound plausible?  Thanks again.

Actions

This Discussion