Different Enable Passwords

Answered Question
Jul 28th, 2010

We are running ASA, IOS 8.0(5) and ASDM version 6.2(3). I just changed the enable password.  When I login using SSH to use CLI, my enable password is the new password.  However, when I login using ASDM, the enable password was the old password.  Is there a way to make both passwords the same?

Thanks.

Diane

I have this problem too.
0 votes
Correct Answer by Rahul Govindan about 6 years 4 months ago

When you log in through ASDM you would be using your username and password present in either the local database or some aaa server(Radius, ldap). When accessing via CLI you should have to give the same credentials first and then will be prompted for enable password. Based on your aaa configuration, that could again be the password present on the ASA or the aaa server.

Are you failing ASDM login using the username password which you are using to login to the cli?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Rahul Govindan Thu, 07/29/2010 - 01:22

When you log in through ASDM you would be using your username and password present in either the local database or some aaa server(Radius, ldap). When accessing via CLI you should have to give the same credentials first and then will be prompted for enable password. Based on your aaa configuration, that could again be the password present on the ASA or the aaa server.

Are you failing ASDM login using the username password which you are using to login to the cli?

dianewalker Thu, 07/29/2010 - 06:53

Thanks for your prompt response, Rahgovin.  I am not able to login through ADSM using the new password.  I have to use the old password to login through ADSM.  When I tried to login to ADSM, it keeps prompting me for the password.  I am using the same credentials for both CLI and ADSM.  I am not sure what I am not doing correctly.  I will check my local database again.  If you don't hear from me, it means I am still having a problem.

Thanks.

Diane

Rahul Govindan Thu, 07/29/2010 - 07:30

post the show run all aaa from your ASA. So are u able to login into the CLI with new password?

dianewalker Thu, 07/29/2010 - 10:00

This is how I change the enable password by using CLI.  Now, I am able to login to both CLI and ASDM using the same enable password.

username diane password xxxxxx

Then, press ENTER

Is there more than one way to change the enable password?  I could not remember how I changed the enable password the first time.  I have a memory loss.

Thanks for your help.

KWillacey_2 Thu, 07/29/2010 - 14:49

Once in config mode on the cli type enable password and press enter.

From ASDM

Select Configuration and then Device Setup

Select Device Name/Password

In the right hand pane for the enable password select the check box to change the password.

But as mentioned by Rahgovin it depends on whether or not your enable password is stored on the ASA or your AAA server.

Actions

This Discussion