ACS 5.1 Can't connect to web interface

Unanswered Question
Jul 29th, 2010
User Badges:

Hello,


i have installed the the ACS 5.1 on our VMware Server 2. After the basic configuration, i should be able to connect to the web interface.

if i enter the correct address i get an 404 HTML status error code.


So I'm trying to solve the problem.


i call the "show application status acs" commandoan the console displays


ACS role: PRIMARY

Process ' database '                              running

Process ' management '                         initializing

Process ' runtime '                                running

Process ' view-database '                       running

Process ' view-jobmanager '                   running

Process ' view-alertmanager '                 running

Process ' view-collector '                        running

Process ' view-logprocessor '                  running


So the reason is, that i cant log in into the web interface because the management process is not running and the apache tomcat server is a component of this process.


I followed the instructions of the document "Installation and Upgrade Guide for the Cisco Secure Access Control System 5.1", so all processes should run.


I tried to increase the log level, to get more information, but this doesnt work, because there is no valid license, which has to be installed with the web interface.


so does anyone know, why the management process doesnt start to run?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ffischer Thu, 07/29/2010 - 03:00
User Badges:

Hello,


just 5 minutes ago I got a phone call from a customer reporting exactly the same issues.

He installed ACS with a Disk >=512 GB.


I would bet the web server / tomcat is not statrting because of a missing license file.


Is there a way to enter License information on the CLI ?


I already installed 5.1 as eval ( using a 80GB Harddisk so Auto-Installation of Evaluation License)

and did not have any problems.


Regards,

Frank Fischer

jrabinow Thu, 07/29/2010 - 03:40
User Badges:
  • Cisco Employee,

This is not a license issue. The application server will start without a license. This allows a user to login to the GUI and get reidrected to the license installation page to instal a valid license.


No solid ideas but you can issue the following command at the CLI to get the last 80 lines of output to the management debug log:

show acs-logs filename ACSManagement.log | last 80

ffischer Thu, 07/29/2010 - 08:50
User Badges:



/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

Hello,


turned out, its the same test installation ;-)


Well, here is the error message Rocco sees every minute:


Jul 29 2010 15:50:40

com.cisco.nm.acs.mgmt.configrecovery.ConfigStateDataHandler.handle(ConfigStateDataHandler.java:63)

FATAL pool-1-thread-1 Acs.MGMT.CONFIGRECOVERY configuration state reply failed to execute:null

java.lang.NullPointerException

        at

org.apache.catalina.loader.WebappClassLoader.findResources(WebappClassLoader.java:997)

        at java.lang.ClassLoader.getResources(Unknown Source)

        at

org.springframework.core.io.support.PropertiesLoaderUtils.loadAllProperties(PropertiesLoaderUtils.java:103)

        at

org.springframework.beans.factory.xml.PluggableSchemaResolver.(PluggableSchemaResolver.java:94)

        at

org.springframework.beans.factory.xml.PluggableSchemaResolver.(PluggableSchemaResolver.java:78)

        at

org.springframework.beans.factory.xml.DelegatingEntityResolver.(DelegatingEntityResolver.java:66)

        at

org.springframework.beans.factory.xml.ResourceEntityResolver.(ResourceEntityResolver.java:64)

        at

org.springframework.beans.factory.xml.XmlBeanDefinitionReader.(XmlBeanDefinitionReader.java:165)

        at

org.springframework.context.support.AbstractXmlApplicationContext.loadBeanDefinitions(AbstractXmlApplicationContext.java:69)

        at

org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:94)

        at

org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:294)

        at

org.springframework.context.support.ClassPathXmlApplicationContext.(ClassPathXmlApplicationContext.java:92)

        at

org.springframework.context.support.ClassPathXmlApplicationContext.(ClassPathXmlApplicationContext.java:77)

        at

org.springframework.context.support.ClassPathXmlApplicationContext.(ClassPathXmlApplicationContext.java:68)

        at

com.cisco.nm.acs.mgmt.bl.framework.impl.BaseDispatcher.getSpringApplicationContext(BaseDispatcher.java:150)

        at

com.cisco.nm.acs.mgmt.bl.framework.impl.BaseDispatcher.getIMHandler(BaseDispatcher.java:107)

        at

com.cisco.nm.acs.mgmt.bl.framework.impl.IMDispatcher.getObjects(IMDispatcher.java:134)

        at

com.cisco.nm.acs.mgmt.bl.framework.BaseManagementSession.getObjects(BaseManagementSession.java:495)

        at sun.reflect.GeneratedMethodAccessor181.invoke(Unknown Source)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

        at java.lang.reflect.Method.invoke(Unknown Source)

        at

com.cisco.nm.acs.mgmt.performancemonitoring.PerformanceProxy.invoke(PerformanceProxy.java:51)

        at $Proxy1.getObjects(Unknown Source)

        at

com.cisco.nm.acs.mgmt.configrecovery.ConfigStateDataHandler.getConfigurationState(ConfigStateDataHandler.java:85)

        at

com.cisco.nm.acs.mgmt.configrecovery.ConfigStateDataHandler.handle(ConfigStateDataHandler.java:55)

        at

com.cisco.nm.acs.mgmt.msgbus.runtime.RuntimeListener$HandlerExecutor.run(RuntimeListener.java:200)

        at

java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

        at java.lang.Thread.run(Unknown Source)

Mike Smith Fri, 07/30/2010 - 15:10
User Badges:

I've been running 5.1 since May 2010 and have noticed this issue each time I reboot the VM.


It's always the management process that's hung at initializing.


Both with the eval license and our permanent license.


VM is spec'd above the minimum requirements.


I haven't contacted the TAC on this yet, but it's always worked for me to 'application stop acs' and 'application start acs'.


Not an adequate solution, but since it rarely gets reboot now, it works.

Rocco_Prielipp Mon, 08/02/2010 - 06:09
User Badges:

thank you, but stop and start the ACS doesn't not work, the errors still exists.

Rocco_Prielipp Tue, 09/21/2010 - 03:13
User Badges:

sorry for the double post, but i finally fins out why the gui doesnt start.


it seems to be a rounding error.


because the virtual machine, i installed, has an capacity 500 GB


and when i'm checking the storage with the "show inventory" command via the CLI, there is a capacity of 536.8 GB.


So the real capacity of the HDD is over 512 GB and the evaluationslicense is not installed.

Vincent Fortrat Mon, 10/18/2010 - 05:41
User Badges:

Hi Rocco,


So how did you manage to make it work?


I have exactly the same issue in a VM environment. Like described in the installation guide, I configured a 500Go HDD. My first install worked perfectly but now it's been the third time in a row where this problem appears.


Best regards,


Vincent

Rocco_Prielipp Mon, 10/18/2010 - 10:43
User Badges:

i took a HDD capatizity of 450 GB, so i have a big store an the evaluation liscense works

Vincent Fortrat Wed, 10/20/2010 - 05:14
User Badges:

What about a real purchased licence for a production environment? Do you think it should work the same way? In the installation guide, it's clearly mentionned that the virtual machine must have the same specifications (processor, RAM, HDD) than the appliance. Is this behavior a bug or something?


Best regards,


Vincent

Gustavo Novais Mon, 11/01/2010 - 04:01
User Badges:

HI,

I've had the same problem on two different situations.

Found out that shut/no shut the ethernet interface on the ACS console would do the trick, via vSphere.(which will imply restarting acs service)


Obviously this not a satisfactory solution, because in case of rebooting a server the least you expect is to be able to re-access its management interface...


Haven't yet had the opportunity to open TAC case about it, mostly because the requirements for the VM's are so big, that I'm always running into an unsupported scenario... and I just don't what TAC to tell me - run the supported scenatio.


Actually I'm trying out ACS5.2 -- let us see if the problems persists...



Gustavo

Actions

This Discussion