Enabling Global CDP for AP's

Unanswered Question
Jul 29th, 2010

Recently I ran into an unexplainable issue when I turned on CDP on our 2 WiSM's. I wanted to set up the switchport tracing feature and from what I understand, cdp is necessary to use this feature. On the 2 WiSM's, I enabled CDP under wireless>access points>Global Configuration and I click the check box to enable CDP. Using WCS, I audited the AP's and verified that they all have CDP enabled. After a few days, I noticed AP's were dropping connection with the WiSM's, the alarms said "The Access Point is not able to draw enough power." I ssh'd into one of the problematic AP's and cleared the private config. After attempting a reset configuration, the device continued to be stuck in a boot loop (I had a continuous ping that would reply for 15 pings, then drop 15 over and over).

Ultimately, I ended up disabling CDP and these AP's started working again. It seems from what I noticed that this issue only happened on Cisco 1242 access points. I tried to research to see if anyone else has had this issue, but my efforts did not yield any resolution.

Has anyone run into this issue or can explain why CDP might cause this issue?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dancampb Thu, 07/29/2010 - 05:59

What is the model of the switch?  Is it 802.3af compliant?

PoE messages are carried inside of CDP so if the switch is not 802.3af you might have to make some changes to the AP config such as configuring it for pre-standard PoE.

vancamt76 Thu, 07/29/2010 - 06:54

These are the switches that we are using to power the AP's

WS-C3560-48PS

WS-C3550-24PWR-SMI

I checked the inline power for each port and the AP's seem to be pulling sufficient power.

Fa0/39    auto   on         15.0    Ieee PD             3     15.4
Fa0/40    auto   on         15.0    Ieee PD             3     15.4

One of the problematic AP's is plugged into a non-PoE 2960 and is using a power injector.

dancampb Thu, 07/29/2010 - 09:24

The 3550 switch is not 802.3af but can provide the 15.4W needed.  You have to configure any AP connected to this switch as using pre-standard PoE.

For the ones using power injectors you also have to configure the AP so that it knows it is being powered by an injector so it doesn't have to pay attention to any PoE info in the CDP packets.

jlhainy Tue, 10/26/2010 - 09:42

The other possibility is to just turn CDP off on the switch port, then no CDP info will be communicated and the switch will provide full power.

Actions

This Discussion