CME 8.0 Outbound Call Connect Slow

Answered Question
Jul 29th, 2010

I am having issues which present like interdigit timeout issues, however I have specific dial peers for both local and long distance dialing that should prevent interdigit timeout issues. The only dial-peer which should wait the interdigit timeout to accomodate varying international dialing and their short dials.  The local and long distance should not.  The translation profile translates the calling number from the 4 digit extension 6... to the 10 digit callback number 2762486... I would prefer to not have to change the interdigit timeout if possible as they do dial a lot of international and I don't want it to cause issues if they pause in dialing too much.  The delay I am seeing is about 5 seconds.  I am testing with a number which starts with 81813 which should only match the Long Distance dial peer.  Any ideas?

dial-peer voice 20 pots
description PSTN Local calls
translation-profile outgoing Outgoing
destination-pattern 8[2-9]......
port 0/0/0:23
forward-digits 7
!
dial-peer voice 30 pots
description PSTN Long Distance
translation-profile outgoing Outgoing
destination-pattern 81[2-9]..[2-9]......
port 0/0/0:23
forward-digits 11
!
dial-peer voice 40 pots
description PSTN International
translation-profile outgoing Outgoing
destination-pattern 8011T
port 0/0/0:23
prefix 011
!
dial-peer voice 50 pots
description Site Short Dials
translation-profile outgoing Site_Short_Dials
destination-pattern 2T
port 0/0/0:23

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 6 years 4 months ago

Hi


Are those all the dial-peers you have configured? Maybe post up an output of 'show dial-peer voice summary'?

The default interdigit timeout is 15 seconds (configured under telephony-service config mode with the 'timeouts interdigit' command), so if you haven't set that to 5 seconds already, it's possible that the delay you are seeing is not the interdigit timer.

I would probably try something like this:

Enable 'debug voip dialpeer inout' and 'debug isdn q931' - this will show what dial-peers are matched, and when the dialling starts on your T1. Hopefully you'll be able to see where the 5 second pause is...

Regards


Aaron

Please rate helpful posts..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Aaron Harrison Fri, 07/30/2010 - 03:03

Hi


Are those all the dial-peers you have configured? Maybe post up an output of 'show dial-peer voice summary'?

The default interdigit timeout is 15 seconds (configured under telephony-service config mode with the 'timeouts interdigit' command), so if you haven't set that to 5 seconds already, it's possible that the delay you are seeing is not the interdigit timer.

I would probably try something like this:

Enable 'debug voip dialpeer inout' and 'debug isdn q931' - this will show what dial-peers are matched, and when the dialling starts on your T1. Hopefully you'll be able to see where the 5 second pause is...

Regards


Aaron

Please rate helpful posts..

bradburyh Fri, 07/30/2010 - 05:03

Thanks Aaron!  The debugs actually gave me the answer.  Turns out the 5 seconds was the delay from

the carrier response.  They have an interesting set-up here where the circuit is coming into an XO Communications router at it serves up both a PRI to our gateway and an internet connection. So, the delay is somewhere from them. These are the debug results which show the 5 seconds delay between the set-up and when we get the alerting back.  No where else in the debugs is there any type of delay.  I show the last digit sent at 7:54:17.552 so definitely no delay there.  Obviously this won't bother this customer if that is what they are used to.  Just drove me nuts.

Jul 30 2010 07:54:17.560 EDT: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8  callref = 0x0099
        Bearer Capability i = 0x8090A2
                Standard = CCITT
                Transfer Capability = Speech 
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98397
                Exclusive, Channel 23
        Progress Ind i = 0x8183 - Origination address is non-ISDN 
        Display i = 0xB1, 'Conference Room'
        Calling Party Number i = 0x2180, '2482766441'
                Plan:ISDN, Type:National
        Called Party Number i = 0xA1, '18134044059'
                Plan:ISDN, Type:National
Jul 30 2010 07:54:17.600 EDT: ISDN Se0/0/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x8099
        Channel ID i = 0xA98397
                Exclusive, Channel 23
Jul 30 2010 07:54:23.300 EDT: ISDN Se0/0/0:23 Q931: RX <- ALERTING pd = 8  callref = 0x8099
        Progress Ind i = 0x8188 - In-band info or appropriate now available

Mukesh Kumar Sat, 03/05/2016 - 07:08

Hello Aaron,

We have voice gateway setup configured in which we are facing outgoing call delay issue.
There is a delay of 14-16 seconds in the outgoing calls.

We have outgoing dial-peer configured as matching pattern "incoming-called number ."

As we have checked the debugs it looks like this delay is due to interdigit timeout.

373827: Mar 3 2016 11:04:04.432 CST: //156863/C2B5AA12807C/CCAPI/cc_api_call_digit_end:
Call Entry(Handoff Depth=0)
373851: Mar 3 2016 11:04:14.432 CST: //156863/C2B5AA12807C/CCAPI/cc_handle_inter_digit_timer:
Generate inter-digit timeout CC_EV_CALL_DIGIT_END event

As you see there is a 10 second gap in the debugs from 11:04:04 to 11:04:14.

Is there a way we can decrease this delay?

We have some more setup running same as it is but we are not facing this delay issue over there. Can you please tell us why we are facing issue here?

Thanks,
Mukesh Kumar

Actions

This Discussion