pim sparse source register problem

Answered Question
Jul 30th, 2010

ive got a pair of routers with an OSPF and PIM adjacency between them and two workstations on either side.  I'm trying to push multicast video across them using vlc as a source on one workstation and a reciever on the other.  I cannot use anything other than PIM sparse ASM, and I choose to use a staticly configured RP on both routers. I can see the reciever 'igmp join', but the source never seems to register for the group. show ip mroute has the correct out going interfaces on both routers and the correct incoming int on the second router but the incoming interface on the first router is null. Is there something im missing?

I have this problem too.
0 votes
Correct Answer by Jayakrishna Mada about 6 years 4 months ago

Jon,

Did you check the TTL is 5 on the packet using wireshark because I had a problem where VLC was always sending packets with TTL=1 even after setting it to >1 in the software.

Just my 2 cents.

JayaKrisha

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Reza Sharifi Fri, 07/30/2010 - 05:57

Jon,

If your multicast config is correct then try to raise the TTL on the server side of the vlc to 2 or 3 and test again.

HTH

Reza

tacoramajon Fri, 07/30/2010 - 07:20

Reza, the TTL count is 5, im just a little unsure about my configs so ive attached them and a simple diagram of what im trying to do. I welcome any help you or anyone else could provide.

Correct Answer
Jayakrishna Mada Fri, 07/30/2010 - 08:48

Jon,

Did you check the TTL is 5 on the packet using wireshark because I had a problem where VLC was always sending packets with TTL=1 even after setting it to >1 in the software.

Just my 2 cents.

JayaKrisha

tacoramajon Sat, 07/31/2010 - 07:42

Thank you,

It seems that vlc user interface has been broken for some time now in regards to TTL - i correctly invoked it via command line and the TTL is correct, validating my test.

Thanks,

Jon

Actions

This Discussion