Cisco ACE 4710 FT Config

Answered Question
Jul 30th, 2010
User Badges:

Hi all,

I am having a weird problem with a failover pair of loadbalancers at the moment.  Here is some config and outputs.  I have tried changing the ft interface to G1/3 on both sides to rule out the port.  I have also swapped cables between both ACE's.  They are going direct to each other, no switch in between.  There have been no changes made to these previously so can't see how it could stop working other than a hardware problem.  I can ping between the two ACE's with the FT Interface IP.


From ACTIVE ACE
Peer Id                      : 1
State                        : FSM_PEER_STATE_DOWN
Maintenance mode             : MAINT_MODE_OFF
FT Vlan                      : 712
FT Vlan IF State             : UP
My IP Addr                   : 192.168.12.1
Peer IP Addr                 : 192.168.12.2
Query Vlan                   : 705
Query Vlan IF State          : UP
Peer Query IP Addr           : 10.110.4.134
Heartbeat Interval           : 300
Heartbeat Count              : 10
SRG Compatibility            : INIT
License Compatibility        : INIT
FT Groups                    : 1


ft interface vlan 712
  ip address 192.168.12.1 255.255.255.252
  peer ip address 192.168.12.2 255.255.255.252
  no shutdown

ft peer 1
  heartbeat interval 300
  heartbeat count 10
  ft-interface vlan 712
  query-interface vlan 705
ft group 1
  peer 1
  priority 200
  peer priority 120
  associate-context Admin
  inservice

ft track interface track_vlan705
  track-interface vlan 705
  peer track-interface vlan 705
  priority 100
  peer priority 50


HA Heartbeat Statistics
------------------------

Number of Heartbeats Sent                 : 0
Number of Heartbeats Received             : 0
Number of Heartbeats Missed               : 0
Number of Unidirectional HB's Received    : 10696
Number of HB Timeout Mismatches           : 0
Num of Peer Up Events Sent                : 0
Num of Peer Down Events Sent              : 0
Successive HB's miss Intervals counter    : 0
Successive Uni HB's recv counter          : 0


From Standby ACE

Peer Id                      : 1
State                        : FSM_PEER_STATE_DOWN
Maintenance mode             : MAINT_MODE_OFF
FT Vlan                      : 712
FT Vlan IF State             : UP
My IP Addr                   : 192.168.12.2
Peer IP Addr                 : 192.168.12.1
Query Vlan                   : 705
Query Vlan IF State          : UP
Peer Query IP Addr           : 10.110.4.133
Heartbeat Interval           : 300
Heartbeat Count              : 10
SRG Compatibility            : INIT
License Compatibility        : INIT
FT Groups                    : 1


ft interface vlan 712
  ip address 192.168.12.2 255.255.255.252
  peer ip address 192.168.12.1 255.255.255.252
  no shutdown

ft peer 1
  heartbeat interval 300
  heartbeat count 10
  ft-interface vlan 712
  query-interface vlan 705
ft group 1
  peer 1
  priority 120
  peer priority 200
  associate-context Admin
  inservice

ft track interface track_vlan705
  track-interface vlan 705
  peer track-interface vlan 705
  priority 50
  peer priority 100


HA Heartbeat Statistics
------------------------

Number of Heartbeats Sent                 : 10894
Number of Heartbeats Received             : 0
Number of Heartbeats Missed               : 10894
Number of Unidirectional HB's Received    : 0
Number of HB Timeout Mismatches           : 0
Num of Peer Up Events Sent                : 0
Num of Peer Down Events Sent              : 1
Successive HB's miss Intervals counter    : 4
Successive Uni HB's recv counter          : 0




Appreciate any help you can offer.

Cheers

Brian

Correct Answer by shbadve about 6 years 12 months ago

Brian,


From provided symptoms it's hard to tell, just yet, if it's a SW problem or HW.


Have you tried reloading these appliances? I would start with currently ACTIVE ACE appliance.


From provided stats it looks like the ACTIVE ACE is not sending any heartbeats over FT VLAN which should not be the case.


It might be worth while to capture the traffic from FT VLAN to confirm if ACTIVE ACE is sending any heartbeats or not.


You can also review FT logs from both appliances :


    show ft history cfg_cntlr
    show ft history ha_dp_mgr
    show ft history ha_mgr



Thank you. - Shubha

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
shbadve Fri, 07/30/2010 - 11:58
User Badges:
  • Cisco Employee,

Brian,


From provided symptoms it's hard to tell, just yet, if it's a SW problem or HW.


Have you tried reloading these appliances? I would start with currently ACTIVE ACE appliance.


From provided stats it looks like the ACTIVE ACE is not sending any heartbeats over FT VLAN which should not be the case.


It might be worth while to capture the traffic from FT VLAN to confirm if ACTIVE ACE is sending any heartbeats or not.


You can also review FT logs from both appliances :


    show ft history cfg_cntlr
    show ft history ha_dp_mgr
    show ft history ha_mgr



Thank you. - Shubha

Brian O'Flynn Tue, 08/03/2010 - 02:37
User Badges:

Hi Shuba,

     I had rebooted one of the ACE's on Friday and that did not resolve the problem.  I done the second one this morning though and it is all working again.  I am going to upgrade the code level at our next maintenance window, currently on A3(2.0).  Thanks for the reply.


Cheers

Brian

Actions

This Discussion