Cat 3750 and EEM

Unanswered Question
Jul 30th, 2010

HI,

I have a 3750 as below and it doesnt seem to have eem commands on it.

I thought EEM was supported for this platform,IOS version and Package level?

Any Ideas?

Cisco IOS Software, C3750 Software (C3750-IPBASEK9-M), Version 12.2(53)SE2, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.

System image file is "flash:c3750-ipbasek9-mz.122-53.SE2.bin"

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 07/30/2010 - 12:11

Yes, EEM should be supported on that image.  To confirm, does the switch support "show event manager version"?

jamesoneill579 Fri, 07/30/2010 - 12:53

Thanks Joe no 'show event manager version' is not available or any 'event' command

I did use the feature navigator before posting the question and it does look like it is supported

alright and in the base package aswell..

All I can think of is that the user does not have priv 15... customer is using tacacs aswell..

Is there anything else i could check to confirm...

Some output below

#e?
enable  eou  erase  exit

#show e?
eap        eigrp  energywise  env
eou        epm    errdisable  etherchannel
exception

#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
(config)#e?
eap   enable  end         energywise
eou   epm     errdisable  exception
exit

Joe Clarke Fri, 07/30/2010 - 13:06

It could be something to do with privilege.  I don't have a 3750 running that image, but EEM really should be there.  The source code seems to agree.

vragotha Sat, 07/31/2010 - 15:38

Hello,

     You need to be running a IP Services feature set for EEM. The IOS level is fine, just change the feature set.

- VR

Joe Clarke Sun, 08/01/2010 - 22:16

Actually, EEM is in IPBASE, but it is EEMLite.  EEMLite is a stripped down version of EEM designed for consumption only by the Auto Smart Ports feature.  While the subsystems and processes are there, the CLI to configure EEM has been omitted.  Instead, the ASP feature configures EEM via an internal API.  This was done on Cat2k switches in the LAN BASE images and Cat3k switches in IPBASE.

Admittedly, the Feature Navigator needs to be fixed as this is very confusing.  True user-consumable EEM is not available unless you are running IPSERVICES.

joe_quinn Fri, 08/06/2010 - 09:30

Is this definitely not a defect that the CLI commands are disabled?

I have the same issue and when i look at the processes i get this:

#show process | inc EEM

   9 Mwe  1CF14D8          49       971      50  7708/9000    0 EEM ED Syslog

  57 Mwe  1CD7DB0      286447   1855661     154  7700/9000    0 EEM ED ND

  58 Mwe  1CC7330           0       187       0  7676/9000    0 EEM ED Identity

  59 Mwe  1CC7330           0       333       0  7668/9000    0 EEM ED MAT

282 Mwe  1CDE97C           0         2       0  7852/9000    0 EEM ED Routing

288 Mwe  1C82058           9        53     169  4556/6000    0 EEM Server

289 Mwe  1CA2888           0         2       0  5100/6000    0 EEM Policy Direc

291 Mwe  1CC7330           0         2       0  7820/9000    0 EEM ED CLI

292 Mwe  1CC7330           0         3       0  7824/9000    0 EEM ED Counter

293 Mwe  1CC7330           0         3       0  7820/9000    0 EEM ED Interface

294 Mwe  1CC7330           0         3       0  7824/9000    0 EEM ED IOSWD

295 Mwe  1CC7330           0         3       0  7820/9000    0 EEM ED None

296 Mwe  1CC7330           0         3       0  7824/9000    0 EEM ED OIR

298 Mwe  1CC7330           0         3       0  7824/9000    0 EEM ED SNMP

299 Mwe  1CC7330           0         3       0  7824/9000    0 EEM ED SNMP Obje

300 Mwe  1CC7330           0         3       0  7824/9000    0 EEM ED Ipsla

301 Mwe  1CEE868           0         2       0  7856/9000    0 EEM ED SNMP Noti

302 Mwe  1CC7330       11653    150780      77  7624/9000    0 EEM ED Timer

Looks like all the event detector processes are running and getting invoked. The syslog one has been invoked 971 times for example.

Does the auto smart ports feature use all of these? Also the policies are for eem 3.2 not eem 2.4 which is what is in the feature navigator. Would be really nice to be able to have cli access to these processes seeing as they are running.

Joe Clarke Fri, 08/06/2010 - 09:50

No, this is not a platform defect.  This is by design.  IPBASE does not have the CLI hooks to configure EEM.  I am trying to get Feature Navigator fixed to relfect proper data.

The ED processes will be running, but will not invoke policies unless ASP macros are defined and enabled.  The EEMLite subsystem includes all of the EEM 3.2 EDs, but ASP typically uses neighbor discovery, MAC address notification, and identiy.

Actions

This Discussion