Anyconnect Client Profile & Scripts

Answered Question
Jul 30th, 2010
User Badges:

Hi


I have configured an anyconnect client profile which is being pushed out to end users. Within this I have enabled scripting and have uploaded two scripts to the ASA (scripts_OnConnect_logon.bat & scripts_OnDisconnect_disconnect.vbs).


If I connect to the client VPN and download the Anyconnect client (fresh install), everything works fine ie I receive the profile and both scripts.


If I then delete the profile and scripts from the end user and reconnect using the anyconnect client, I receive the profile, but not the scripts.


Can anyone help with this issue?


Kind Regards

Terry

Correct Answer by Rahul Govindan about 6 years 10 months ago

Right now this is how it works by design. In case you want to push the script again,

delete the VPNManifest.dat file from the Anyconnect folder and connect

with the client again. First time i believe the scripts wont be pushed. The second time you will see the script in the folder.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Rahul Govindan Fri, 07/30/2010 - 17:19
User Badges:
  • Silver, 250 points or more

Right now this is how it works by design. In case you want to push the script again,

delete the VPNManifest.dat file from the Anyconnect folder and connect

with the client again. First time i believe the scripts wont be pushed. The second time you will see the script in the folder.

Terry Mon, 08/02/2010 - 02:35
User Badges:

Thankyou for your help, I tried this a few times and the scripts were pushed first time on each occasion.


Kind Regards

Terry

Actions

This Discussion