anyconnect 2.5 issues in windows7

Unanswered Question
Jul 30th, 2010
User Badges:

I recently upgraded to anyconnect 2.5.  I now cannot connect with the Anyconnect.  I keep getting


"AnyConnect was not able to establish a connection to the specified secure gateway.  Please try connecting again."


It works fine if i go back to 2.4.  Any idea?


Thanks,


Jason

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rahul Govindan Fri, 07/30/2010 - 17:25
User Badges:
  • Silver, 250 points or more

Hi, do you have some anti virus or some firewall on your PC coz there are some known issues with Kaspersky and AC 2.5? And you facing the issue on all systems or just one?

jbeltrame Fri, 07/30/2010 - 23:10
User Badges:

I was testing one one machine.  Have Microsoft forefront running, asa firewall.  It will let me connect, but fails right after that.  I see everything show successful, then i see this in the debug:


WebVPN: session has been authenticated.
webvpn_auth.c:webvpn_auth[578]
WebVPN: no cookie present!!


Then it disconnects.  Only happens on 2.5.  On 2.4 on client and asa, and all is well.  Using self signed cert, not sure if i have to do anything different for that on 2.5. 

Rahul Govindan Sat, 07/31/2010 - 21:01
User Badges:
  • Silver, 250 points or more

You would probably have to check dart logs and event viewer for specific error messages. The error message usually occurs when you have third party applications disrupting the Anyconnect connection.

jbeltrame Sun, 08/01/2010 - 18:26
User Badges:

Its just strange that 2.4 works correctly, but 2.5 doesn't.  If i downgrade the client, everything works fine.  Is there a lot of underlying differences between 2.4 and 2.5?


Thanks,


Jason

Rahul Govindan Mon, 08/02/2010 - 07:37
User Badges:
  • Silver, 250 points or more

there are a few changes of course, but don't think anything that should break whatever was working in 2.4. Probably the dart logs will help us nail the issue.

jbeltrame Mon, 08/02/2010 - 08:41
User Badges:

Seems to be working.  I had to initially run 2.5 as administrator.  After that, I can run normally with my user.  Not sure why that was with 2.5 and not 2.4, but was something I had to do.  Noticed lots of error messages in event viewer that prompted me to test this action.

mulatif Thu, 12/16/2010 - 07:30
User Badges:
  • Cisco Employee,

Hi,

This could be due to Out-Dated ROOT Certificates on Windows7. The Certificate used for signing some DLLs in the AnyConnect package has changed from 2.4 to 2.5.

Please verify that the Windows PC is updated with the current Root Certificates . You can search google for Manual Cert update on Windows 7 , similar to below


http://dreamlayers.blogspot.com/2009/12/windows-7-cant-always-automatically.html


If above still doesn't fix the issue then


1. Clear the AnyConnect Event Log

2. Try to establish a connection.

3. Save and send the AnyConnect Log. We can then analyze for errors.


Thanks,

Naman

wavinitaliaspa Tue, 12/14/2010 - 06:20
User Badges:


Hello ,


did you solve the problem ? How ? We have the same error and we do not know how to solve it


Thank you

Rahul Govindan Tue, 12/14/2010 - 07:42
User Badges:
  • Silver, 250 points or more

Do you have any third party firewall or anti-virus that could be causing the issue? Also at what stage does the error occur? You can check the messages that come below the AnyConnect Gui to see when exactly it fails( for eg, when it tries to enable the VPN adapter)

wavinitaliaspa Tue, 12/14/2010 - 07:58
User Badges:

Yes , we have firewall and antivirus : the problem is that we have this error only on some laptop .



The same program , with the same user on the same model of laptop works fine ( with the same config of firewall and antivirus ) so I really understand where is the problem.
We tried several relases of the program : 2.2.2006 , 2.5.0217 and also 2.4.1012 , with the same result.
The error it occurs at the end of the process ,after we put the token user and number
wavinitaliaspa Thu, 12/16/2010 - 02:21
User Badges:

Hello ,


it fails when at the bottom of the VPN client is written "Establish VPN session...."


What does it mean ?

bkitsgmbh Sun, 08/07/2011 - 16:42
User Badges:

Hello jbeltrame,


i don't know whether your problem is solved, but it turned out, that the exact same problem your were describing could be solved by deactivating connection sharing in the control center of win7. Once i deactivated the share of one connection, anyconnect ran as it was supposed to.


HTH.


Regards


Kai Michael Poppe

b.k. it-services GmbH

mstrvoip5 Wed, 10/17/2012 - 10:10
User Badges:

It really worked!... when I deactivated the connection that was shared in Network Connections in Network Sharing Center>Change adapter settings.  And I had that setup as I was working with Virtualbox machines that get access to internet through that shared network adapter.... My 2 Cents

Hikmet_Y. Mon, 11/14/2011 - 21:44
User Badges:

Hi,


I have been experiencing the same problem. I a0m using a 64-Bit Windows 7 Home Premium system along with Symantec Antivirus software (fully registered by my institution). My other computer, 32-bit XP Home netbook with basic Microsoft antivirus protection, operates flawlessly. However, my main laptop does not connect to my school's servers while I am off the campus. I have tried almost everything: uninstalling both the vpn client and antivirus, and reinstalling them, swithing to a different antivirus software, cleaning the log file, turning off and on the wireless adapter, disconnecting and reconnecting to the various wireless networks, shutting down the wireless modem and restarting it, and giving a fresh restart to my computer. Occasionaly, restarting the computer works but this whole process is very annoying. Could you find a solution for this problem?

enigmatiq99 Tue, 05/01/2012 - 18:58
User Badges:

Hello


For some reason, whenever I try to log on to my site, as soon as I've entered my user ID and password, I'm back at the login prompt. Has anyone ever seen that ? I'm sure it's the Windows 7 PC I'm on- whether browser or Java related because when I try from another PC - I'm ok.


DK

Actions

This Discussion