IOS upgrade on 2960G switch

Answered Question
Jul 30th, 2010
User Badges:

Hello experts,


I have a basic trouble in setting up TFTP server. I need to upgrade the IOS on 2960G cat switch. First I have downloaded the tftp server on my laptop then I assigned an IP address manually in my laptop as 10.1.1.1 with subnet mask 255.255.255.0 leaving deafult gateway address as none. Then I moved to the 2960G switch and created a new interface vlan10 then assigned the IP address as 10.1.1.10 with subnet mask as 255.255.255.0. Next I used interface gig0/1 interface and said switchport access vlan 10, duplex and speed setting set as auto. I am able to ping from host towards the vlan ip address 10.1.1.10 but from switch i m unable to ping. I ran debug icmp and debug ip packet command but nothing was traced what the issue is. The interface status shows up up and vlan interface status shows up up, i checked the windows firwall settings, its in off state. I think there is something minor error I am doing. Can anyone help me out in finding the solution.


I followed the above procedure to upgrade the IOS from my laptop, please let me know if there is any other way that I can upload the IOS image.


Regards,

Mohammed

Correct Answer by Nagaraja Thanthry about 6 years 8 months ago

Hello,


Happens all the time :). We tend to overlook one of those software apps that

are running the background. Glad that issue is fixed.


Please mark the question as answered so others can use it in the future.


Regards,


NT

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
manish arora Fri, 07/30/2010 - 17:24
User Badges:
  • Silver, 250 points or more

Try giving an ip address to the switch with default gateway and vlan.

switch(config)#ip add x.x.x.x 255.255.255.0

switch(config)#ip default-gateway

switch(config)#ip add vlan x


I think , you need management interface on the switch in case of 2960, experts here can also comment.

thanks

Manish

Nagaraja Thanthry Fri, 07/30/2010 - 17:27
User Badges:
  • Cisco Employee,

Hello,


Most likely your laptop has firewall set. Please disable Windows/other

firewall on the laptop and try again. It should work.


Hope this helps.


Regards,


NT

mhabeeb_ahmed Fri, 07/30/2010 - 17:30
User Badges:

Hi Nag,


I already disable the windows firewall settings in my laptop as commented earlier.


Manish,


let me try with default gateway ip address

Nagaraja Thanthry Fri, 07/30/2010 - 17:33
User Badges:
  • Cisco Employee,

Hello,


Do you have any Anti-virus software installed on the laptop? Also, if you

have a second interface (like wireless) disable it and try.


Regards,


NT

jean.moncada Fri, 07/30/2010 - 21:26
User Badges:


strange that the 2960G can't ping the laptop but the laptop can ping the 2960G.


Are you sure you don't have that ip address 10.1.1.10 configured on the laptop as well by mistake either on the loopback or on another interface or as a secondary ip on your laptop int. ipconfig /all should tell you but you probably checked that out already.


can you post the ipconfig /all

and the output from the 2960 of

sh ip int brief


also the config of the 2960 shouldn't hurt. Makes no sense why you can't ping the laptop from the switch, from the post seems you did everything correct in regards to your layer 2 2960 switch.


mhabeeb_ahmed Mon, 08/02/2010 - 11:29
User Badges:

Hi Jean,


Well I don't have any other subnet configured in my laptop, even i tried to used the different subnet 192.168.10.10 with subnet mask 255.255.255.0 but the result is same. I am attaching the config file of the switch with ping statistics and sh ip int brief status. Also I am attaching my laptop statistics file in which you will find the ipconfig /all and ping statistics.


Awaiting for your response.


Regards

manish arora Mon, 08/02/2010 - 11:41
User Badges:
  • Silver, 250 points or more

Can you telnet into the switch at 192.168.10.10 from your laptop ?

manish

Nagaraja Thanthry Mon, 08/02/2010 - 12:05
User Badges:
  • Cisco Employee,

Hello,


Do you have any kind of antivirus/anti-spyware software installed? Can you try a different workstation?


Regards,


NT

mhabeeb_ahmed Mon, 08/02/2010 - 12:21
User Badges:

No I am not able to telnet into the switch.


Yes Symantec antivirus protection is enabled in my laptop. I cannot turned it off because its enterprise edition and centrally managed.


I am able to ping to the 3750 switch. I have uploaded the IOS from my laptop on 3750 switch without any issues. But when I am trying with 2950 I have this issue.

manish arora Mon, 08/02/2010 - 12:49
User Badges:
  • Silver, 250 points or more

Please try configuring an ip address to vlan 1 , have a default gateway configured on a global configuration mode. then assign a port to vlan 1.  also , mention default gateway on you laptop. I have read a few documents from cisco and for a 2960 each of them is suggesting to have  a management interface configured on the vlan 1.


http://web.nmsu.edu/~jbeasley/Cisco_Discovery_4-1/courses/en0500000000/en0505000000/en0505050000/en0505050400/en0505050405/cm8572509551/lab.pdf



thanks

Manish

jean.moncada Mon, 08/02/2010 - 13:30
User Badges:

Doesn't seem like there is anything wrong with the confis on your switch.

Also you don't need to have vlan1 configured with and ip address or no shutdown mode just to be able to setup this type of configuration, its not like you have a trunk configured and sending vtp updates etc... I recommend using the ping extended commands on your 2960, perhaps the 2960 is trying to use a different interface as the source (even though i only see one ip address configured on your 2960 but its worth a shot) So lets make sure ping is using the correct interface with ip 192.168.10.10 on the CLI of the 2960 just type "ping" and hit enter you will be prompted with a few questions and answer them as follows




Switch#ping

Protocol [ip]:

Target IP address: 192.168.10.11

Repeat count [5]:

Datagram size [100]:

Timeout in seconds [2]:

Extended commands [n]: y

Source address or interface: 192.168.10.10

Type of service [0]:

Set DF bit in IP header? [no]:

Validate reply data? [no]:

Data pattern [0xABCD]:

Loose, Strict, Record, Timestamp, Verbose[none]:

Sweep range of sizes [n]:



Hopefully you would get some replies...

if not I recommend

1) changing cables (straight through cable)

2) changing ports


since everything looks fine on the switch and laptop base on your attachments.

jean.moncada Mon, 08/02/2010 - 13:41
User Badges:

oh yeah one more thing,

if the laptop is really pinging the 2960 we should see the laptop mac address on the 2960 mac-address-table.


so you should from the laptop ping 192.168.10.10


then on the switch do a

sh mac-address-table


you should see the laptops's mac address coming from gi0/1


if its not there then your laptop is pinging something else ???


or you can also verify from the laptop

you can do a

arp -a

on your laptop and you should see the Mac address that was given to vlan99 a

sh int vlan99

should tell you the mac address assigned.

once again this is all based on the configuration files you provided as attachments.

vmiller Mon, 08/02/2010 - 15:31
User Badges:
  • Gold, 750 points or more

As one of the previous writers noted, you do not have a default gateway for the 2960

that needs to be first.

I'm assuming that it is connected to the 3750. If so you may need an IP helper address

for tftp to work,

see the atttached link.

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_53_se/configuration/guide/swipaddr.html

jean.moncada Mon, 08/02/2010 - 15:42
User Badges:

The 2960 doesn't need a default gateway. He is running a tftp service off his laptop wich is directly connected to the 2960 so that he could upgrade the ios. The 2960 and laptop are on the same subnet.

Leo Laohoo Mon, 08/02/2010 - 15:46
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

How about this:  Delete all config of the 2960G switch reboot and do this:


1.  PC IP address is 1.1.1.1, subnet mask 255.0.0.0

2.  Switch VLAN 1 IP address 1.1.1.32 (or any number other than 1), subnet mask 255.0.0.0.  "no shut".


Copy IOS from PC to switch.


This is the process I use every time (and all the time) when I upgrade the IOS before deployment. 

mhabeeb_ahmed Mon, 08/02/2010 - 16:34
User Badges:

Hello All,


Thank you so much for your valuable suggestions. I have figured it out the solution to the problem. I checked all your possibilities as suggested, it was really helpful to trace out the solution. My Checkpoint-VPN secure client was running behind in my laptop due to that reason I was unable to ping from switch to my laptop.


I have upgraded the IOS on the switch and deployed the config on all of them. Thank GOD it was on time and I have to put it into production by the end of the day. Now everything is ready.


Once again thanks to all for coperating.


More to come. !!!!!!!!


:-)


;-)


regards,

Mohammed

Correct Answer
Nagaraja Thanthry Mon, 08/02/2010 - 16:40
User Badges:
  • Cisco Employee,

Hello,


Happens all the time :). We tend to overlook one of those software apps that

are running the background. Glad that issue is fixed.


Please mark the question as answered so others can use it in the future.


Regards,


NT

Actions

This Discussion

Related Content