FAX Configuration with VG 202 issue

Unanswered Question
Jul 31st, 2010

HI All,

I configured the VG 202 analog station for FAX as SCCP device. WHen I am making the Voice calls there is no issue, but When try to send o rreceive the FAX I am getting FAx tone and receive tone but page not getting transfer. After few seconds call disconnect. Pls find below Voice gateway and VG 202 configuration file. I really not getting where I am missing.

Any help highly appreciate.

Voice Gateway


Current configuration : 4919 bytes
!
! Last configuration change at 18:55:15 UAE Thu Jul 22 2010 by netadmin
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Sajer-VG
!
boot-start-marker
boot system flash:c2900-universalk9-mz.SPA.151-1.T.bin
boot-end-marker
!
card type e1 0 0
logging buffered 51200 warnings
enable secret 5 $1$mpCr$b1RsMjTnHRQvPOSMgXXGI/
!
aaa new-model
!
!
--More--                           aaa authentication login default local
!
!
!
!
!
aaa session-id common
clock timezone GMT
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
no ip domain lookup
ip domain name yourdomain.com
multilink bundle-name authenticated
!
!
--More--                           !
!
isdn switch-type primary-net5
!
!
crypto pki trustpoint TP-self-signed-3734099945
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3734099945
revocation-check none
rsakeypair TP-self-signed-3734099945
!
!
crypto pki certificate chain TP-self-signed-3734099945
certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33373334 30393939 3435301E 170D3130 30363032 31303235
  34315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37333430
  39393934 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100ADEA 0D8FAB4C C0CB84B2 F5853594 E84A89BE 81DEAA82 2F7A96F9 8C70F5BF
  CF8E8936 D134F4F7 51EB8E45 3BC564DF 311DAEDC A6E93FB7 2CD38FAD 6A47D3D1
  8A18C476 260A8EA4 022A60A2 492E8086 2A1C37D7 D9BC1B6E 5FF4CFDF 4AC56EBC
--More--                             9736E272 FBB64AA9 92C4F02B EF3ABCEB 7661787A 59309774 5E3342C9 449772B2
  EA670203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 1753616A 65722D56 472E796F 7572646F 6D61696E 2E636F6D
  301F0603 551D2304 18301680 1432DD9F CDD84732 4F0D87B9 B2E49829 B3F71EF9
  19301D06 03551D0E 04160414 32DD9FCD D847324F 0D87B9B2 E49829B3 F71EF919
  300D0609 2A864886 F70D0101 04050003 8181007A F1F0E65A 753A2CA8 3AE1FA55
  C9C3EE38 B8C977EA 622928D5 631B5EF0 9E28BE72 03E746D7 AF11FCAB 6D8D60F8
  4DCDA668 9A6B224B 17FC5FFD 3BAC5130 D85E9D08 C92A678D 40FD24AB 81AFEDA1
  4F807C88 55FB7FE6 651AFFE6 CDD3C9D8 E958A8F3 4FD39A69 8B48AD7D 984573AF
  3EA39AF3 9B45C4CF EC2D803E DB6E5778 2CDFAF
      quit
voice-card 0
dsp services dspfarm
!
!
voice call send-alert
voice call convert-discpi-to-prog
voice rtp send-recv
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729br8
!
--More--                           voice class h323 1
  h225 timeout tcp establish 3
!
!
!
!
voice translation-rule 10
rule 1 /^\([0-9]\)/ /0\1/
!
voice translation-rule 20
rule 1 /^\(6...\)$/ /04382\1/
!
voice translation-rule 60
rule 1 /^\(...\)/ /6\1/
!
!
voice translation-profile addinPrefix
translate calling 10
!
voice translation-profile callingin
translate called 60
!
voice translation-profile callingpstn
--More--                            translate calling 20
!
!
license udi pid CISCO2921/K9 sn FCZ141870U5
hw-module pvdm 0/0
!
!
!
username netadmin privilege 15 password 0 netadmin
!
redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-31
!
!
!
!
!
interface GigabitEthernet0/0
description ***Connected to LAN***
ip address 192.168.1.14 255.255.255.0
--More--                            duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.1.4
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
no cdp enable
--More--                           !
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 192.68.1.1
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
translation-profile incoming callingin
!
!
!
--More--                           !
dial-peer voice 100 voip
tone ringback alert-no-PI
translation-profile outgoing addinPrefix
preference 1
destination-pattern 6...
session target ipv4:192.168.1.3
dtmf-relay h245-alphanumeric
codec g711alaw
no vad
!
dial-peer voice 101 voip
tone ringback alert-no-PI
translation-profile outgoing addinPrefix
preference 2
destination-pattern 6...
session target ipv4:192.168.1.2
dtmf-relay h245-alphanumeric
codec g711ulaw
fax-relay ecm disable
no vad
!
dial-peer voice 10 pots
--More--                            translation-profile outgoing callingpstn
destination-pattern 0T
incoming called-number .
fax rate disable
direct-inward-dial
port 0/0/0:15
!
!
num-exp 6000 6399
!
!
gatekeeper
shutdown
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
line vty 5 15
privilege level 15

transport input telnet ssh
--More--                           !
scheduler allocate 20000 1000
end



VG-202

Sajer_FAX_VG#sh run

Building configuration...

Current configuration : 1862 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Saipem_FAX_VG

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$o9gc$loxtKDyG0AJP.ZzX5M3x70

!

aaa new-model

!

!

aaa authentication login default local

!

!

aaa session-id common

ip source-route

!

!

!

!

ip cef

no ip domain lookup

no ipv6 cef

!

stcapp ccm-group 1

stcapp

!

stcapp feature access-code

!

stcapp feature speed-dial

!

!

!

stcapp call-control mode feature

!

!

!

!

voice service voip

fax protocol pass-through g711alaw

!

!

!

!

!

!

!

!

!

!

!

!

!

voice-card 0

!

username netadmin privilege 0 password 0 netadmin

archive

log config

  hidekeys

!

!

!

!

!

interface FastEthernet0/0

ip address 192.68.1.8 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.1.1

!

no ip http server

!

!

!

control-plane

!

!

!

voice-port 0/0

timeouts initial 60

timeouts interdigit 60

timeouts ringing infinity

caller-id enable

!

voice-port 0/1

timeouts initial 60

timeouts interdigit 60

timeouts ringing infinity

caller-id enable

!

no ccm-manager fax protocol cisco

ccm-manager config server 192.168.1.2 

ccm-manager sccp local FastEthernet0/0

ccm-manager sccp

!

!

sccp local FastEthernet0/0

sccp ccm 192.168.1.3 identifier 10 version 7.0

sccp ccm 192.168.1.2 identifier 12 version 7.0

sccp

!

sccp ccm group 1

associate ccm 10 priority 1

associate ccm 12 priority 2

registration timeout 3

keepalive retries 1

keepalive timeout 3

!

!

dial-peer voice 100 pots

service stcapp

port 0/0

!

dial-peer voice 101 pots

service stcapp

port 0/1

!

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

!

exception data-corruption buffer truncate

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (1 ratings)
Loading.
Steven Holl Mon, 08/02/2010 - 07:29

You have the VG202 configured for fax pass-through.  Your PSTN gateway has no fax configuration on it, though.  Both sides need to match for the switchover to work.

Since you're going straight between two Cisco gateways, I'd personally configure modem passthrough instead of fax pass-through.  MODEMPASS allows for high-speed faxing, whereas the latter does not.

Configure this on both devices:

fax protocol none

modem pass nse codec g711a

If you still have issues, collect the output of 'debug voip rtp sess name' from each side, and you can see if NSEs are being sent for the swithover.

-Steve Holl

Amit Sharma Wed, 10/13/2010 - 04:41

Hello All,

PLease help me to tell the process to register vg 202 and 204 with cucm 8.0 version

how can i use it iwth DHCP or without use of DHCP in network?

what i have to do also in cucm server for this vg registration?

as we do in mgcp, h.323 case, first add vg gateway in cucm and then configure with dhcp configuration in router vg 202 so that register vg gateway with cucm server for all end users.

please tell me if i am wring some where at this part?

i have to install 40 vg 202 and 20 vg 204 at my new project so please help me as soon as possible.

previously i did work on vg 224 a dn 248 for registrating with cucm and ccme but not have idea about this vg 202 and 204 yet.

Amit

Steven Holl Wed, 10/13/2010 - 05:59

VG202 and VG204 follow the same procedure as the VG224.  The only thing  different is the hardware and port layout.  Configuration will be  identical.

Whether you use DHCP or a static IP is mostly irrelevant as long as the device has L3 connectivity.  Since the device is essentially a gateway, if I was adminsitering the box, I'd want to give it a static IP.  I know with MGCP, it doesn't like sourcing from an interface with a DHCP IP address anyway (which I always found strange, since it in theory shouldn't matter).

What VoIP protocol are you using?  This supports SCCP, H323, SIP, and MGCP.  It sounds like you are going to use SCCP?  If so, follow this to get it to register; it's a procedure common to all SCCP FXS ports:

http://www.cisco.com/en/US/docs/ios/voice/fxs/configuration/guide/fxsbasic.html#wpxref30700

You can also use SCCP auto config (ccm-manager sccp) if you like, but I find most people just manually configure it.

Amit Sharma Fri, 10/15/2010 - 23:42

Hello Sir,

Thanks for it but cna you clear me few points as go for installation of vg202 and 204 with cucm 8.02 version:

first add vg in cucm as sccp gateway

then configure vg gateway as vg guide with dhcp option using these commands:

1.enable
2.configure terminal
3.interface type slot/port
4.ip address dhcp
5.sccp local interface-type interface-number port port-number
6.ccm-manager sccp local interface-type interface-number
7.ccm-manager sccp
8.voice service voip
9.fax protocol t38 [nse[force]]
10.exit

is it nayhting else that i have to do also incase of dhcp option with cucm ingateway sid eor in router side?

If i go for cucm with vg 202 without use of dhcp then sue these points:

1.enable
2.configure terminal
3.interface type slot/port
4.ip address static ip subnet mask
5.sccp local interface-type interface-number port port-number
6.voice service voip7.fax protocol t38 [nse[force]]
8.ccm-manager sccp local interface-type interface-number
9.ccm-manager config server tftp_ip_address
10.ccm-manager sccp
11.exit

this is haivng in guide as per cisco document:

Please tell me what is use of these commands that is also giving in document for configure voice interface1.enable
2.configure terminal
3.stcapp ccm-group group-id
4.stcapp
5.stcapp feature access-code
6.stcapp feature speed-dial
7.voice-port slot-number/port
8.timeouts initial seconds
9.timeouts interdigit seconds
10.timeouts ringing seconds infinity
11.voice-port slot-number/port
12.ccm-manager fax protocol [protocol cisco]
13.ccm-manager config [server] ip-address name seconds
14.ccm-manager sccp local interface-type interface-number
15.ccm-manager sccp
16.sccp local interface-type interface-number port port-type17.sccp
18.sccp ccm group group-number
19.associate ccm identifier-number priority priority-number
20.dial-peer voice tags pots
21.service stcapp
22.port port-number
23.exit

this is also requried for both cases that have toi configure aslo...

please help me so that go ahead for installation of vg gateways...

     :

Steven Holl Sun, 10/17/2010 - 05:35

Yes, you are correct that if you don't use option 150, then you need to configure a TFTP server like you specified.

The final set of commands enable SCCP registration on the gateway, and register a port as SCCP FXS, such that supplementary services can be used.  If you are curious about the function of a specific command, reference the voice command reference, or the SCCP FXS supplementry services guide for more details.

Amit Sharma Sun, 10/17/2010 - 05:39

Hello Sir,

Many thanks for updating me on this part.

Please tell me what stepls have to take when adding this gateway in cucm server?

what gateway type have to select in that page and it is not showing vg 202 and 204 in that page?

Amit Sharma Sun, 10/17/2010 - 05:42

Hello,

Can you provide the link for voice command or fxs port configuration guide so that easily register vg 202 with cucm for analog evices.

What have to do chnages in the vg configuration if use for fax devices in behalf of analog phones?

Steven Holl Sun, 10/17/2010 - 05:58

I'm running 8.0.2 and the options to add the gateway are in there.  See screnshot.

What type of faxing are you looking to do?  Note that SCCP ports only can do NSE-based switchovers (so you can't do a switchover to something like a fax server or a SIP ITSP).  You'll likely either want modem passthrough (recommended so that you can do high speed faxing):

voice service voip

modem pas nse codec g711ulaw

fax protocol none

I already linked you to the SCCP FXS guide previously in this thead.  Please review that.  You should be reading that whole guide if you have questions about this feature.

Did you even try looking for the voice command reference?  If you search cisco.com for 'voice command reference' it is the first hit:

http://tools.cisco.com/search/display?url=http%3A%2F%2Fwww.cisco.com%2Fen%2FUS%2Fpartner%2Fdocs%2Fios%2F12_3t%2Fvoice%2Fcommand%2Freference%2F123tvr.html&pos=1&strqueryid=1&websessionid=tpdtKAcqa9YxGegsPP97ztI

We're here to help, but you need to put a little bit of more effort inif you want to effectively learn this stuff.  The information and links in this thread should be enough for you to be able to get a VG20x registered as a SCCP FXS device.

Actions

This Discussion