Unable to trunk with LACP a Cisco 3750 and a SGE2000

Unanswered Question
Jul 31st, 2010

Dear all,

maybe I'm missing something but I really don't understand why my setup isn't working. I have a Cisco 3750 as core switch (two stacked units) which I'd like to connect throught a etherchannel (or LAG) to a new Linksys SGE2000 stack of two units so that they share the several VLANs present on our network. I think this setup would make sense, but correct me if I'm doing it wrong. What happens is that from the 3750, I always see the ports in "Independent" state, and obvsiously there are L2 loop errors such as:

*Mar  1 08:57:47.525: %SW_MATM-4-MACFLAP_NOTIF: Host c47d.4fa9.9880 in vlan 999 is flapping between port Gi2/0/19 and port Gi1/0/19

The SGE2000 is set up with the two ports being a member of the LAG number 1. The LAG 1 is then set to be in trunk mode, with alle the VLAN IDs tagged, there's really not much more to be setup here. What is strange however is that when I go under "Bridging, Port Management, LAG Management" on the SGE2000 and I edit the LAG1 properties, the "LACP" checkbox is grayed out and can't be checked!

I suspect the SGE2000 is not really starting the LACP protocol on that trunk, as the output of "show lacp neighbor" demostrates: just an empty output. This is the output of "show lacp summary":

Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
1      Po1(SD)         LACP      Gi1/0/19(I) Gi2/0/19(I)

while this is the config of the ports on the Cisco switch:

interface Port-channel1
description Exion Services Rack3 switches
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full

interface GigabitEthernet1/0/19
description Etherchannel Trunk link1
switchport trunk encapsulation dot1q
switchport mode trunk
speed 1000
duplex full
lacp port-priority 100
channel-protocol lacp
channel-group 1 mode active

interface GigabitEthernet2/0/19

description Etherchannel Trunk link2

switchport trunk encapsulation dot1q

switchport mode trunk

speed 1000

duplex full

lacp port-priority 100

channel-protocol lacp

channel-group 1 mode active

Don't know what else to try, did anyone have success in trying to setup a such scenario?

Thank you so much for your feedbacks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nagaraja Thanthry Sat, 07/31/2010 - 17:46


While it is not very clear from SGE2000 if it supports multi-chassis LAG,

the LAG configuration page talks about switch the LAG configuration is

applied to. If you are using ports from different switches for LAG

configuration, can you try ports on the same switch? Also, if it still did

not work, I would suggest starting with a pure L2 etherchannel

(channel-group mode on) and see if it works. Once that is established, then

you can move towards making the LAG LACP capable.

Hope this helps.



massawaregroup Sun, 08/01/2010 - 03:03

Hi Nagaraja,

thanks for pointing this out to me, I really didn't consider that the problem may be related on the SGE2000 not supporting multi-chassis LAG. I will now go in the datacenter to try this out, but correct me if I'm wrong: this way I have to put the two trunks on the same chassic of the SGE2000, and I won't have redundancy if that particular chassis should fail, is it?

What can I do to achieve the wanted high availability in this kind of scenario?

Will get back later will the results,

Thank you

Nagaraja Thanthry Sun, 08/01/2010 - 07:58


You can configure regular trunk between the 3750 and the other switch. STP will block one of the ports. In case the primary link fails, the secondary link can become active and start passing the traffic.

Hope this helps.



giorgiomassa Fri, 09/03/2010 - 15:11

After throughtful testing I can definitely say that the SGE2000 does NOT support LACP on a stacked switch configuration.

Since this is a needed feature for load balancing and failover of my nodes, can anybody from Cisco please tell me if they're planning to implement it in a future firmware version or not? If not I will have to return 8 switches because this is really a mandatory feature in my setup.



This Discussion

Related Content