Cisco Phone Registration Problem with CUCM

Answered Question
Aug 1st, 2010

Hi

I am having some problem for registrating IP phone with CUCM. My  CUCM is connect with Core Switch. My Core Switch is trunked with AccessSW1 and AccessSW1 is trunked with AccessSW2. All the IP phones  are connected with AccessSW2.

I think I am not properly getting Voice DHCP pool IP address. If I reset one Phone from CUCM web portal then The phones are not registering. What I have to do is shut the Ip helper-addess port (VLAN500 Interface at Core Switch) and no shut.

My Configurations are bellow.

Core SW:

ip dhcp excluded-address 10.10.05.193

ip dhcp pool VOICE

network 10.10.05.192 255.255.255.192

default-router 10.10.05.193

option 150 ip 10.10.05.61

interface Vlan500

description "Voice VLAN"

ip address 10.10.05.193 255.255.255.192

ip helper-address 10.10.05.192

AccessSW1.

Only Trunk with Core SW

AccessSW2:

"Only Trunk with AccessSW1"

interface FastEthernet0/2

switchport access vlan 501

switchport voice vlan 500

mls qos trust device cisco-phone

spanning-tree portfast

Two of my Access SWitches are layer 2 switches. My IP Commmunicators are not having any problem

Please help me regarding this. New phones are not getting registered with out shut and no shut of that Voice VLAN interface.

Best Regards

Sultan Al Arif

I have this problem too.
0 votes
Correct Answer by Adam Frankel about 6 years 4 months ago

Sounds like something already has a duplicate address as interface vlan 500.   Do you see any errors in the 'show log' output on either switch?  If not, get a packet capture of a phone which is able to boot and register fine, and one that cannot.

Packet capture from an IP Phone:

https://supportforums.cisco.com/docs/DOC-11735

Also, in the future it wouldn't hurt to post your phone model, firmware version, and CUCM/CUCME version.

HTH,

Adam

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Adam Frankel Sun, 08/01/2010 - 21:52

Sounds like something already has a duplicate address as interface vlan 500.   Do you see any errors in the 'show log' output on either switch?  If not, get a packet capture of a phone which is able to boot and register fine, and one that cannot.

Packet capture from an IP Phone:

https://supportforums.cisco.com/docs/DOC-11735

Also, in the future it wouldn't hurt to post your phone model, firmware version, and CUCM/CUCME version.

HTH,

Adam

Md. Sultan Al Arif Mon, 08/02/2010 - 04:20

Thanks

I have check with the customer side Network Administrator and found that there was a AccessSW which has the same VLAN Information. After Shutdowning that Switch problem is resolved.

BR//

Sultan Al Arif

+8801811459994

Actions

This Discussion