iPhone and Cisco 877 router/firewall

Unanswered Question
Aug 2nd, 2010

I am trying to get my boss' email set up on his iPhone - have been for teh last 5 months

We use an MS 2003 SP3 Excahgne server and having run the Activesync tests I know this is all working correctly.

The issue is his emails only come through once a day at 3 am and at no other time during the day.

Is there any settings on my Cisco 877 router that need to be changed or what should these be set at to enable real time push to the iphone and not once a day.

Our IT company who fitted the routers said they will change the settings to whatever I need them to be but will not look into it as they specifically do not deal with iPhones.

Any help would be appreciated as my boss just will not accept that it isn't possible to get our exchange email working on his phone.  I have tried everything I can find online and nothing has worked so the only conclusion left for me is our Cisco router and firewall which I have no access to.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mirober2 Mon, 08/02/2010 - 13:52

Hi Andrea,

I'm not too familiar with the iPhone's mail client. Do you know what ports/protocols it is using to check for new mail? Does the connection work fine for non-iPhone clients?

It's odd that the iPhone works at 3 AM but at no other times throughout the day. Is there anything configured in the network that this time corresponds to, such as a time-based ACL or a specific URL filtering policy?

Have you been able to confirm if the firewall is actually the issue (i.e. bypassing or disabling the firewall to see if the issue remains)? It may be difficult for you to troubleshoot this without assistance from the folks that manage the firewall as you would want to look at log messages and debug output to find out if/why the traffic is being affected.

-Mike

Nagaraja Thanthry Mon, 08/02/2010 - 16:23

Hello,

How is he accessing the mail (WiFi or 3G)? Would it be possible for you to bypass the router i.e. have your boss connect to your internal LAN via Wireless link where you have your Exchange Server and see if it still does the same? If the access works inside your network, then you can have your boss connect to an outside wireless network (may be a hotspot) and see if the email gets sync'd there. If both work, then the issue could be with the 3G carrier and you can have your boss communicate with the carrier on fixing the issue. If the communication does not work in the first case itself, i.e. even when connected behind your firewall, the emails do not sync, then the issue could be either with settings on the Exchange Server or on the iPhone. If the first scenario (iPhone behind the router) works but fails when the iPhone is connected to a public hotspot, then the issue could be with your router.

Hope this helps.

Regards,

NT

Actions

This Discussion