dot1q Trunk link : AtoM

Unanswered Question
Aug 2nd, 2010
User Badges:

Hi,


I have a MPLS enabled network with 76XX routers. Just wanted to know if I can provide QinQ type services to customer. I mean to say a Psuedowire carrying multiple vlans of a customer...Customer is giving me a dot1q trunk link to carry to other end. Any way out...


Thx

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 08/02/2010 - 13:07
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Gaurav,

yes with port based EoMPLS you can provide this service.


Hope to help

Giuseppe

gauravprakash Wed, 08/18/2010 - 11:05
User Badges:

Thx, just to clarify..


my setup is

CE1----PE1---mpls---PE2----CE2


PE1/2 are mpls PEs. CE1/2 are L2 swicthes.


CE1 has Dot1Q trunk link ,with all vlans allowed, and interfaces Xconnect port of PE1. So Port based Xconnect.

Similarly, switch trunk dot1q interfaces PE2 with port based xconnect.


PEs are 7606 with 6724 line card, no SIP/SPA in this IOS.


On PE side  hv folliwng config

int gig 1/2

xconnect 2.2.2.2 80 en mpls..



On CE side we have

Interface gig is made dot1q trunk with all vlans allowed. normal command


Do we needs a OSM, SIP.SPA?


I assume that stp BPDU's can safely be carried over this port base EoMPLS


Any comments..

Atif Awan Wed, 08/18/2010 - 11:17
User Badges:
  • Cisco Employee,

For port based EoMPLS PFC does the label imposition/disposition so you do not need an intelligent card core facing. Your customer PDUs will be transparently tunneled to the remote end. With existing hardware you can offer the service you are describing.

gauravprakash Wed, 08/18/2010 - 23:38
User Badges:

Thx,


I am facing one problem..


If I  have 6704 line  on PE1 on one side (customer facing) & 6724 on other side (customer facing ) on PE 2. As soon as I configure Xconnect on both side, the port goes down..

Although it gives error messgae "UDLD err disable". Even if I remove errdisable cmd for udls from config, the port is down with xconnect.


I dont get any issue with same customer facing line card on both side, ( 6704 on both side or 6724 on both side)..


I tried to configure mtu same on port of PE ( customer facing) , but no help with different line cards. IOS is SRB2


Somebody said we must have same linecard on both ends of Pwseudowire...on PEs.


Thx,

Gaurav

Atif Awan Wed, 08/18/2010 - 23:57
User Badges:
  • Cisco Employee,

I am not aware of any such restriction. I am not sure where UDLD is coming into the picture from? Also I do not understand the motivation to have a port mode pseudowire between a Gigabit Ethernet and a Tengig interface. Can you post the Attachment Circuit configs at both ends as well as relevant show mpls l2transport vc commands?

Actions

This Discussion