Outbound generic-SIP not working (immediate busy)

Unanswered Question
Aug 2nd, 2010

Hi,

first of all thank you for this community, it helped me a lot while configuring our UC540 to eliminate all sorts of errors, really appreciate it!

Now though I don't seem to be able to make the final step: While inbound calls are finally working, outbound calls fail with an immediate busy signal.

First my Setup:

   [10.1.1.x]               [192.168.10.1]          [192.168.22.254] LAN
   SPA525G ---(WiFi)---\    [80.x.x.x secondary]    [80.x.x.x] WAN
   SPA525G ---(WiFi)---| ---------- UC540 ---------- GW/ROUTER ------------- ( WAN )
   SPA525G ---(WiFi)---/

Sip-Registration works, incoming calls work.
SIP-ALG/NAT is enabled on router (Draytek Vigor 2820)

Outbound Calls do not work though, I receive an immediate busy signal.

I noticed that the dial-peer 1039 is correctly recognized, the next hop should be the sip-server but it seems it never goes there.

Also: When I test the dialed number in teh CCA Dialplan Test it correctly matches it to SIP Server.

I am afraid it's something to do with the router?

Attached is the config (pardon the mess, it is the config I am playing with for a while now, some transaltion rules are oboslete by now) plus the ccsip and dialpeer debug.

Any help is greatly apprciated, thank you

Mike

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
webmasterware Mon, 08/02/2010 - 14:37

Well, as i suspected, it is something with the configuration behind the router. When I plug the UC directly into the ADSL modem and use PPPoE dialin both inbound and outbound calls a working fine.

It seems the UC can't get out to the SIP trunk when behind a router, actually it doesn't seem to even try (the router having no firewall enabled).

Still it would be nice to know what one can do to to make this kind of config to work, any ideas someone?

Mike

Actions

This Discussion