BGP Redundant Connection/Failover

Unanswered Question
Aug 2nd, 2010

Hello CSC,

I have a routing problem that has been plaguing me for several months now.

About 5-6 months ago we upgraded our remote sites to MPLS. After the upgrade we decided to keep the point to point T1’s circuits in place to provide redundancy incase of MPLS failure. 

We are running BGP over the links. Our network is configured as follows.

Remote Office Router - T1 - Headquarters Router

Remote Office Router – ISP Premise Router – MPLS – ISP Premise Router – Headquarters Router

The Remote Office Router is configured as follows:

router bgp XXX12

bgp log-neighbor-changes

neighbor 10.49.0.213 remote-as XXX41

neighbor 10.49.0.254 remote-as XXX10

neighbor 10.49.0.254 ebgp-multihop 2

neighbor 10.49.0.254 update-source Loopback0

!

address-family ipv4

redistribute connected

  redistribute static

  neighbor 10.49.0.213 activate

  neighbor 10.49.0.213 weight 100

  neighbor 10.49.0.213 soft-reconfiguration inbound

  neighbor 10.49.0.254 activate

  neighbor 10.49.0.254 soft-reconfiguration inbound

  no auto-summary

  no synchronization

exit-address-family

ip route 10.49.0.254 255.255.255.255 10.49.0.69 254

The Headquarters router is configured as follows:

router bgp XXX10

bgp log-neighbor-changes

neighbor 10.49.0.205 remote-as XXX41

neighbor 10.49.1.244 remote-as XXX12

neighbor 10.49.1.244 ebgp-multihop 2

neighbor 10.49.1.244 update-source Loopback0

!

address-family ipv4

  redistribute connected

  redistribute static

  redistribute eigrp 5

  neighbor 10.49.0.205 activate

  neighbor 10.49.1.244 activate

  default-information originate

  no auto-summary

  no synchronization

  bgp redistribute-internal

  network 10.49.0.0 mask 255.255.0.0

exit-address-family

ip route 10.49.1.244 255.255.255.255 10.49.0.70 254

The only way that I could utilize both links was to create the static routes and using the 254 metric.  I created a static route with the loopback IP address of the remote router and point it to its serial T1 interface. When the MPLS link goes down the 254 metric route would load into the routing table.

The issue I am now experiencing is that when the MPLS network goes down, the static route is loaded into the routing table and routing occurs over the T1 link. When the MPLS network comes up the routing entry stays in the routing table and routing stays on the T1 link unless I manually remove the routing statement.

Is there an automated way of configuring this setup using BGP? It seems as though BGP prefers the T1’s point to point connection instead of the MPLS high bandwidth link?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gatlin007 Mon, 08/02/2010 - 14:11

Can you post the output of a 'show ip bgp' on the remote router?



Thanks,


Chris

jean.moncada Mon, 08/02/2010 - 18:17

There are a couple of ways that you can provide Dynamic Failover connections on your Cisco router, One of my favorites is to use track and ip sla, (I personally prefer to use metric thresholds but I don't want to complicate things for you) basically IP SLA will  allow a static route to failover if pings to a specified router at the MPLS side should fail.

ip sla 1 < The number 1 here is arbitrary, used only to  identify this sla. It is otherwise knows as the operation number>

icmp-echo x.x.x.x < ip address of remote mpls edge router >

timeout 500 < This is how long to wait for a response  from the ping>

frequency 3 < This is the repeat rate for the SLA>

ip sla schedule 1 start-time now life forever < This  command says "start SLA 1 now and keep it running forever>

track 1 rtr 1 reachability < This comand creates the  track object "1" and monitors the SLA 1>

now for the routing, we need to change the route and associate it  with the tracker  ( i put default routes here but you can use what ever routes you want to failover)

ip route 0.0.0.0 0.0.0.0 1.1.1.1 track 1

Then we need to add our secondary failover route which has a higher metric

ip route 0.0.0.0  0.0.0.0 1.1.1.2 10

Now when the ping to the remote mpls router fails the primary route is removed and the  secondary route with the higher metric becomes the default. The route will be  reinstated when the connectivity is restored.

Hope that helps to reinstate the route to the mpls when it comes back up.

Jean Paul Moncada

junior.corrica Tue, 08/10/2010 - 12:54

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

I understand what the IP SLA commands are doing. However I don’t think it is doing what I want.

What I want to do is have our site router look at its routing table to see if it is leaning the default route from out ISP Premise Router.

If it sees that the default route is not present, I want it to peer with our Headquarters Router using the T1 circuit.

I want it to add “ip route 10.49.1.244 255.255.255.255 10.49.0.70” to the routing table.

Our default route is leaned by BGP from our ISP Premise Router. We have no static routes other than 10.49.1.244 255.255.255.255 10.49.0.70 254.

Chetan Kumar Ress Tue, 08/10/2010 - 14:45

Hi

I won't see any issue in your senario. If you are having T1 link as a backup link then you can use weight to elect primary & secondary link.

Also it is know as backdoor link.

What you can do you can set the weight for incomming route.

Please refer the below link for your senario.

http://wiki.mplsvpn.info/mplsvpn-w/home/bgp-as-pe-ce-with-backdoor-link---part-2

http://showipbgp.com/bgp-configurations/cisco.html

Regards

Chetan kumar

http://chetanress.blogspot.com

njangale Tue, 08/03/2010 - 03:55

Hi ,

I am not able to make out which neighbor is for T1 and MPLS. You just need se a weight for both nieghbors. I see it set for only one neighbor.The route with Highest weight is prefered.

HTH

Nishant

u1kumar2002 Wed, 08/11/2010 - 00:12

Hi ,

    Plz configure weight on both neighbors...

bgp log-neighbor-changes

neighbor 10.49.0.213 remote-as XXX41

neighbor 10.49.0.254 remote-as XXX10

neighbor 10.49.0.213 weight 200

neighbor 10.49.0.254 weight 100

neighbor 10.49.0.254 ebgp-multihop 2

neighbor 10.49.0.254 update-source Loopback0

!

neighbor 10.49.0.213 activate

  neighbor 10.49.0.213 weight 200

  neighbor 10.49.0.213 soft-reconfiguration inbound

  neighbor 10.49.0.254 activate 100

  neighbor 10.49.0.254 soft-reconfiguration inbound

and check show ip bgp at the time of failure... Then you will only(T1link) 10.49.0.254 neighbor with weight 100. When link restores you will see 10.40.0.213 (MPLS link)with weight 200.The fail over will work.

Plz update...

Do rate for helpful post....

Best Regards,

Uttam

http://www.startnetworks.blogspot.com/

Actions

This Discussion

Related Content