NOSServer is not Running on DFM 3.2

Unanswered Question
Aug 2nd, 2010

Hi all,

We have a CiscoWorks LMS 3.2 with DFM 3.2 on a Windows Server 2008 ServicePack 2. We reregister the NOSServer for another problem but after that process didnt start. Can you help me to reregister de NOSServer properly

Thanks for your help

Rafael Turriago

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
rafael.turriago Mon, 08/02/2010 - 18:46

Hi Joseph thanks for your help...This is the pdreg command output:

C:\>pdreg -l NOSServer
        Process      = NOSServer
        Path         = C:\PROGRA~1\CSCOpx\bin\cwjava.exe
        Flags        = -server -cp:p MDC\tomcat\webapps\triveni\WEB-INF\lib\log4
j.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\nos.jar,MDC\tomcat\webapps\triveni\
WEB-INF\lib\ctm.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-client.jar,MDC\to
mcat\webapps\triveni\WEB-INF\lib\cogs.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib
\ogs-kc1.0.jar,MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-kilnervirtualasa1.0.ja
r,MDC\tomcat\common\lib\activation.jar,MDC\tomcat\common\lib\mail.jar,MDC\tomcat
\webapps\triveni\WEB-INF\lib\tis-client.ja,MDC\tomcat\webapps\triveni\WEB-INF\li
b\pm.jar,lib\classpath\jconn2.jar,lib\classpath\epm-v0-5-0.jar,lib\classpath\ces
ar-v0-5-0b.jar,MDC\tomcat\shared\lib\NATIVE.jar,MDC\tomcat\shared\lib\MICE.jar,M
DC\bin,objects\nos\config,MDC\tomcat\webapps\triveni\WEB-INF\classes,-cw:jre C:\
PROGRA~1\CSCOpx\lib\jre -cw:xrs -Djava.compiler=NONE com.cisco.nm.trx.nos.server
.NOSServer
        Startup      = Started automatically at boot.
        Dependencies = EPMDbEngine EPMServer INVDbEngine PMServer DFMOGSServer

regards


Rafael Turriago

Joe Clarke Mon, 08/02/2010 - 21:07

All of the commas here should be semi-colons.  How did you re-register this daemon?

rafael.turriago Tue, 08/03/2010 - 07:21

This is the command that I excecuted

C:\PROGRA~1\CSCOpx\bin\pdreg.cmd -r NOSServer -d "EPMDbEngine,EPMServer,INVDbEngine,PMServer,DFMOGSServer" -e C:\PROGRA~1\CSCOpx\bin\cwjava.exe -f "-server -cp:p MDC\tomcat\webapps\triveni\WEB-INF\lib\log4j.jar;MDC\tomcat\webapps\triveni\WEB-NF\lib\nos.jar;MDC\tomcat\webapps\triveni\WEB-INF\lib\ctm.jar;MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-client.jar;MDC\to
mcat\webapps\triveni\WEB-INF\lib\cogs.jar;MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-kc1.0.jar;MDC\tomcat\webapps\triveni\WEB-INF\lib\ogs-kilnervirtualasa1.0.jar;MDC\tomcat\common\lib\activation.jar;MDC\tomcat\common\lib\mail.jar;MDC\tomcat\webapps\triveni\WEB-INF\lib\tis-client.jar;MDC\tomcat\webapps\triveni\WEB-INF\lib\pm.jar;lib\classpath\jconn2.jar;lib\classpath\epm-v0-5-0.jar;lib\classpath\cesar-v0-5-0b.jar;MDC\tomcat\shared\lib\NATIVE.jar;MDC\tomcat\shared\lib\MICE.jar;MDC\bin,objects\nos\config;MDC\tomcat\webapps\triveni\WEB-INF\classes;-cw:jre^C:\PROGRA~1\CSCOpx\lib\jre^-cw:xrs^-Djava.compiler=NONE com.cisco.nm.trx.nos.server.NOSServer"

Regards

Rafael Turriago

Joe Clarke Tue, 08/03/2010 - 09:02

This looks right provided this was executed on one line, and there are no stange breaks.  Post the NOSServer.log and the syslog.log.

rafael.turriago Tue, 08/03/2010 - 12:02

Hi Joseph

I checked the command excecuted before and I made a mistake. The NOSServer is working now 

Thanks four your Help

Regards


Rafael Turriago

Actions

This Discussion