CUPS 8 - unable able to search directory for users via CUPC

Unanswered Question
Aug 2nd, 2010


We're running CUPS 8 w/ CUCM 7, the integration with CUPS and CUCM  is working. I can see the users that are in CUCM(using LDAP(Active Directory) sync).

I've created the "Application > CUPC > LDAP Profile Configuration" and I can see the correct users there, along with users here "User Management > End User"' in CUPS.

People can login fine via CUPC, however searching the directory for "users" are not showing anything, however I can search for my own username and that works---if I search using the username vs. a first or last name.

What could be a possible issue?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Shaun Bender Tue, 09/28/2010 - 07:51

No, not yet. I think it *might* be related to the CUPS version, I thought about changing out to the "latest".  However, everything that I've read shows that it should work with the current config/setup.

Let me know if you come across anything.


ANDREW BERESFORD Wed, 09/29/2010 - 00:51

Simple fix.

I needed to put a search context into the LDAP profile.

However the documentation for CUPS 8 states that this is optional. Clearly NOT!

Shaun Bender Fri, 10/01/2010 - 15:18

Hhmm .. interesting .. I have a "Search Content" ... and I see users in the "Users in Profile" section.

Still not able to search users from CUPC.

And this resolved your issue? Maybe you could send me a screen cap of your settings?


craig.pollitt Wed, 07/20/2011 - 06:50

Was this issue ever resolved?  I'm experiencing the same thing here.  Please let me know.



Shaun Bender Wed, 07/20/2011 - 15:50

Hey Craig,

I never got my issue resolved, however didn't spend too much time with it once I hit that road-block. BUT---I'll be looking into it more in about/roughly 20 days.

If you do find something out between then, let me know.


Shaun Bender Thu, 10/06/2011 - 19:32


I'm running:


Jabber for Mac 8.6.1 (18300)

and having weird issues with the LDAP search context.

If I do:




it works fine, but if I do this...


It doesn't work.

Any thoughts, or suggestions?



yeopaul Thu, 04/26/2012 - 04:11


I am not using LDAP on cups 8.6.2, cupc 8.1.

I am having may be similar problem that I can't search the company directory to add user. however, I can add them manually and text them.

Is it a must for me to use LDAP for cups 8.6.2?



shabbarbabrawala Wed, 09/26/2012 - 07:45


Anyone find a solution to this problem, am facing the same problem,

we use cupc 8.5 cucm 7.15 integratred with AD, cannot search user , we can chat with with them if i add from the user page page but cannot call



f.dilalla Thu, 03/28/2013 - 08:32


I have the same issue on some users, I have added the user in the LDAP profiles , see "Users in Profile" area.

Now it works fine



This Discussion

Related Content