2960 stack and macflap errors

Unanswered Question
Aug 3rd, 2010
User Badges:

hi

i have a 2960s configured in a stack (2x 960s)

i have configured 2 vlans

vlan103 which is a iscsi vlan with a westek SAN connected, the Westek San has 4 nics bonded with 1 ip and mac address

it is connected to ports 1/0/23, 1/0/24, 2/0/23 and 2/0/24

i noticed the following macflap errors

Aug  3 14:43:15.441: %SW_MATM-4-MACFLAP_NOTIF: Host 024e.8f46.cf32 in vlan 103 i

s flapping between port Gi2/0/24 and port Gi2/0/23

Aug  3 14:43:30.005: %SW_MATM-4-MACFLAP_NOTIF: Host 024e.8f46.cf32 in vlan 103 i

s flapping between port Gi1/0/24 and port Gi1/0/23

Aug  3 14:43:44.151: %SW_MATM-4-MACFLAP_NOTIF: Host 024e.8f46.cf32 in vlan 103 i

s flapping between port Gi2/0/23 and port Gi1/0/24

Aug  3 14:43:59.512: %SW_MATM-4-MACFLAP_NOTIF: Host 024e.8f46.cf32 in vlan 103 i

s flapping between port Gi1/0/24 and port Gi1/0/23

on the sam vlan in port 1/0/21 and 2/0/21 i have a server which also has a bonded nic but no such issues, i have an identical server on port 1/0/22 and 2/0/22 which is also working fine

so it is something to do with the Westek SAN and its nic bonding

below is the config from the switch

should i setup an etherchannel on those ports in vlan103 which have the macflap errors as per this link http://www.sadikhov.com/forum/index.php?showtopic=151540

anyway here is my config

Building configuration...

Current configuration : 6388 bytes
!
! Last configuration change at 15:42:21 UTC Tue Aug 3 2010
! NVRAM config last updated at 13:04:00 UTC Tue Aug 3 2010
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 2960stack
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret level 5 5
enable secret 5
!
!
!
macro global description cisco-global
no aaa new-model
clock summer-time UTC recurring last Sun Mar 1:00 last Sun Oct 2:00
switch 1 provision ws-c2960s-24ts-l
switch 2 provision ws-c2960s-24ts-l
authentication mac-move permit
ip subnet-zero
!
!
udld aggressive

!
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7
mls qos srr-queue output cos-map queue 3 threshold 3 2 4
mls qos srr-queue output cos-map queue 4 threshold 2 1
mls qos srr-queue output cos-map queue 4 threshold 3 0
mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47
mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31
mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55
mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63
mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39
mls qos srr-queue output dscp-map queue 4 threshold 1 8
mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos queue-set output 1 threshold 1 138 138 92 138
mls qos queue-set output 1 threshold 2 138 138 92 400
mls qos queue-set output 1 threshold 3 36 77 100 318
mls qos queue-set output 1 threshold 4 20 50 67 400
mls qos queue-set output 2 threshold 1 149 149 100 149
mls qos queue-set output 2 threshold 2 118 118 100 235
mls qos queue-set output 2 threshold 3 41 68 100 272
mls qos queue-set output 2 threshold 4 42 72 100 242
mls qos queue-set output 1 buffers 10 10 26 54
mls qos queue-set output 2 buffers 16 6 17 61
mls qos
!
!
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
!
!
errdisable recovery cause link-flap
errdisable recovery interval 60
!
vlan internal allocation policy ascending
!
!
!
interface Port-channel1
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0
ip address 172.16.3.3 255.255.255.0
!
interface GigabitEthernet1/0/1
description switch_3750-1/0/1
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
!
interface GigabitEthernet1/0/2
description switch_3750-2/0/2
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
switchport access vlan 3
switchport mode access
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
description vmco 1 nic 1
switchport access vlan 103
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet1/0/22
description vmco 2 nic 1
switchport access vlan 103
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet1/0/23
description westek nic 1
switchport access vlan 103
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet1/0/24
description westek nic 3
switchport access vlan 103
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet2/0/1
description switch_3750-2/0/1
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
!
interface GigabitEthernet2/0/2
description switch_3750-1/0/2
switchport access vlan 3
switchport mode access
speed 1000
duplex full
channel-group 1 mode on
!
interface GigabitEthernet2/0/3
!
interface GigabitEthernet2/0/4
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface GigabitEthernet2/0/13
!
interface GigabitEthernet2/0/14
!
interface GigabitEthernet2/0/15
!
interface GigabitEthernet2/0/16
!
interface GigabitEthernet2/0/17
!
interface GigabitEthernet2/0/18
!
interface GigabitEthernet2/0/19
!
interface GigabitEthernet2/0/20
!
interface GigabitEthernet2/0/21
description vmco 1 nic 2
switchport access vlan 103
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet2/0/22
description vmco 2 nic 2
switchport access vlan 103
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet2/0/23
description westek nic 2
switchport access vlan 103
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet2/0/24
description westek nic 4
switchport access vlan 103
switchport mode access
speed 1000
duplex full
!
interface GigabitEthernet2/0/25
!
interface GigabitEthernet2/0/26
!
interface GigabitEthernet2/0/27
!
interface GigabitEthernet2/0/28
!
interface Vlan1
no ip address
shutdown
!
interface Vlan3
ip address 10.3.1.4 255.255.0.0
!
ip default-gateway 10.3.1.2
ip http server
ip http secure-server
ip sla enable reaction-alerts

!
!

!
end

what should i do to get rid of the macflap errors?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jayakrishna Mada Tue, 08/03/2010 - 08:39
User Badges:
  • Cisco Employee,

HI,


Yes you are right the issue seems to be with  Westek SAN and its nic bonding. Based on your topology all the 4 switch interfaces could be in forwarding state and its upto the Westek server to forward only on one port and block the other ports.


how is the nic boding configured on the Westek, is it active/passive or is it a port-channel.


I am assuming its active/passive since I dont see any port-channel configuration on the switch interfaces. if that is the case then the issue is with Westek.


One other option that you have is to configure port-channel on both sides.


Hope this helps.


JayaKrishna

rogierboeken Tue, 08/03/2010 - 08:52
User Badges:

the westek nics are bonded using this method

balance-rr

Transmissions are received and sent out sequentially on each bonded slave interface. This mode provides fault tolerance and load balancing.


I am not sure how this translates to the cisco terminology


they basically have the following bonding possibilities


balance-rr

Transmissions are received and sent out sequentially on each bonded slave interface. This mode provides fault tolerance and load balancing.

active-backup

Only one slave in the bond is active. Another bonded slave interface is only used if the active bonded slave interface fails. This mode provides fault tolerance.

balance-xor

Transmission is based on the following equation: [(the source MAC address XOR'd with the destination MAC address) modulo (slave count)]. This selects the same slave for each destination MAC address. This mode provides fault tolerance and load balancing.

broadcast

Transmits everything on all slave interfaces. This mode provides fault tolerance.

802.3ad

IEEE 802.3ad Dynamic link aggregation. Creates aggregation groups that share the same speed and duplex settings. Utilizes all slaves in the active aggregator according to the 802.3ad specification. Requires a switch that supports IEEE 802.3ad Dynamic link aggregation.

balance-tlb

Channel bonding that does not require any special switch support. The outgoing traffic is distributed according to the current load (computed relative to speed) on each slave. Incoming traffic is received by the current slave. If the receiving slave fails, another slave takes over the MAC address of the failed receiving slave. This mode provides fault tolerance and load balancing.



the consultant who helped me setting this up suggested i change the bonding to  balance-tlb and otherwise balance-xor


I will have a play with this and let you know how i get on

Jayakrishna Mada Tue, 08/03/2010 - 09:48
User Badges:
  • Cisco Employee,

I would suggest to change it to "802.3ad" and configure the same on the cisco side.


JayaKrishna

rogierboeken Wed, 08/04/2010 - 03:50
User Badges:

since changing the westek bonding the macflap errors have disappeared


i did have an issue where the SAN/iscsi read and write throughput went down drastically but after re-inserting the nics this seems to have resolved itself and i am now getting much better results (110MB/ps write and 80MB/ps read)


i have done testing with shutting down 1 member of the stack and randomly unplugging nics and the througput remains the same and without macflap errors

Actions

This Discussion