Upgrade CCX5 EHA to CCX802 EHA failed

Unanswered Question
Aug 3rd, 2010


  I am experiencing a problem while upgrading CCX 5 enhanced HA to CCX 802.

We got the backup from CCX5 using the Upgrade tool from windows to linux. The installation process has been completed successfully.

  Now, one the new installation server we select Upgrade from Previous version, enter the SFTP and backup location and use the new license.

  While on Upgrade Setup site we got the error attached “Status: Phase 1 of Windows to Linux Upgrade failed


FAILED : Pre-check for Windows to Linux Upgrade operation failed.
FAILED : Phase 0 (Windows to Linux Upgrade pre-check) of Windows to Linux Upgrade
Phase0 and Phase1 Upgrade logs are collected under the /opt/cisco/uccx/log/W1Upgrade folder. Save the zipped logs for future troubleshooting.

Does anyone knows how we can obtain the logs in order to locate the problem?

If I try to use the “Fresh Install” method then we proceed up to the point where we are able to configure the RM and CTI user.

But when I click on NEXT, I go this on the address bar // and the screen goes blank and nothing happens.

Anything about that?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Jonathan Schulenberg Wed, 08/04/2010 - 05:42

You will need to SSH in and use the file list and file get commands. The syntax is not very intuitive. I do not have a CCX 8 box in front of me to get you exact syntax, sorry. What you want is to find the log file(s) using file list and then download them to an SFTP server using file get.

econstantinou Thu, 08/05/2010 - 00:32


  I tried to do that unsuccessful.

  Using "file list activelog uccx/log/W1Upgrade" I can locate the file "W1Log-Phase0n1-05-Aug-10#09-50.zip"

  However when I use "file get" on my sftp server I got an empty folder.

  Is there other way to download zipped?



tbertchume Fri, 08/20/2010 - 21:59

I used the compress option with the file get command and it worked.

file get activelog /uccx/log/W1Upgrade/W1Log-Phase2-20-Aug-10#23-25.zip compress

Aaron Harrison Sat, 08/21/2010 - 01:17


What SFTP program are you using? I've seen problems with a few with this command, freeFTPd worked for me.

Are you using / as the destination dir? not \ or something else more Windows style?


econstantinou Tue, 08/31/2010 - 05:17


  I am always using FreeFTPd for all UC servers and customers.

I logged into the system using a bootable Linux disk and then get the file from the root.

  The problem was a missing file (even if the upgrade tool completed successfully).


  I proceeded with a fresh install. As I said the installation process stuck after CUCM (CTI, RMCM) site with a blank page.

  What I did as a work around is:

  Use a temporary file from the DVD – that passes the CTI and RMCM page and logged in successfully.

  (I had the same exact problem with UCCX v5 with the same flavor-High Availability Enhanced)

  Then I upload the license from CCX8 HA

  Now all are back to normal.

  Of course I reconfigure everything else lost on upgrade…

thanks for you reply.


SAN J Wed, 10/20/2010 - 13:28

Having the same issue with fresh install (but using the old and new licenses zipped up) with the blank page coming up after the rm and cti input. What temporary file did you use to bypass this page?

tbertchume Wed, 10/20/2010 - 13:39

there are demo licenses for each flavor of UCCX 8.X on the installation DVD

SAN J Wed, 10/20/2010 - 13:54

unfortunately I'm trying to upgrade to 7X (from 4X) and I don't think there's demo licenses for this version...none that I could find at least.

SAN J Mon, 10/25/2010 - 11:53

Yeah, I ended up opening a TAC case  last week and found out there was a problem with the original license issued and looks like the new one works now and it did let me finish the initial configs. Thx.


This Discussion