PAP2T Version 1 -- Can't downgrade firmware to 3.1.23(LS)

Answered Question
Aug 3rd, 2010

Hello:

I recently purchased a PAP2T-NA VOIP adapter.  I believe the firmware that was on the device when i purchased it was 3.1.xx (can't remember the exact firmware level, but i suspect it could have been 3.1.23(LS)).

I did not know there was a version 1 and version 2 of the PAP2T-NA.  Obviously, my PAP2T is the version 1 unfortunately, because there is no reset button at the back.

Not knowing my PAP2T was the old version, i upgraded the firmware to 5.1.6(LS).  After i upgraded, the ring on the phone started getting very erratic (sometimes it would ring twice, sometimes three or four times, and at erratic intervals).  I was also told that the voice quality of people hearing me on the other side was very bad.  I did not have these problems with the original firmware that came with the unit.  I suspect that firmware 5.1.6(LS) was for version 2 of the PAP2T.

The hardware version is:   0.3.5, by the way.  If i try to downgrade the firmware to 3.1.23(LS), i get the error message:  Upgrade Failed: Version not matching

I also tried to downgrade the firmware via TFTP.  It transfered the bin, but the unit "didn't do anything" (no rapidly flashing lights or anything like that).

Here's the log for the TFTP attempted firmware downgrade (which confirmed that the TFTP procedure was correct):

Connection received from 10.0.0.115 on port 6287 [02/08 11:56:57.455]
Read request for file </pap2-3-1-23-LS.bin>. Mode octet [02/08 11:56:57.455]
OACK: <timeout=5,tsize=762452,> [02/08 11:56:57.455]
Using local port 1433 [02/08 11:56:57.455]
<\pap2-3-1-23-LS.bin>: sent 1490 blks, 762452 bytes in 3 s. 0 blk resent [02/08 11:57:00.589]

I also tried the recovery .exe file for firmware 3.1.22(LS) (rec-pap2-3-1-22-LS.exe), but this did not work.  When i entered the correct serial number (and i confirmed many times), it claimed that it "did not find the device" (or something like that).

Is there anyone who could perhaps help me to figure out a way how to "force" a firmware downgrade ?  (or help me to restore the firmware to what it was originally ?).

I would call Cisco Tech Support, but there doesn't seem to be a phone number for them, unless i'm missing something.

thanks,

Pat

I have this problem too.
0 votes
Correct Answer by nseto about 3 years 8 months ago

From the image, it looks fine.  Let the RMA process run through.  Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
nseto Thu, 08/05/2010 - 10:38

Please send a screenshot of the PAP2's Info page.  I want to verify the product information.  Thanks.

sunnysidedown Thu, 08/05/2010 - 11:42

hi nseto:

Here is a screenshot of the info page.  Like i said, the original firmware was version 3.1.xx (can't remember which exactly).  I managed to call Tech Support, and the person i talked to confirmed that there is only one version of the PAP2T (there are two versions however of the PAP2, or the older unit), and he did say that i did the right thing by upgrading to firmware 5.1.6(LS) -- the only available firmware available for download, for the PAP2T.

Tech Support did say that the unit is defective, but i'm not 100% convinced that firmware 5.1.6(LS) was proper.  In any case, the RMA procedure has been initially setup (there was a problem with the RMA ordering process, so i have yet to work that out with Linksys), but still, it would be nice nseto, if you could tell me that everything looks the way it's supposed to, on that screenshot.

On the box the unit came with, it says "PAP2T-NA", and it even says "PAP2T" on the underside of the unit.

thanks

Pat

Correct Answer
nseto Thu, 08/05/2010 - 13:08

From the image, it looks fine.  Let the RMA process run through.  Thanks.

Actions

Login or Register to take actions

This Discussion

Posted August 3, 2010 at 9:51 AM
Stats:
Replies:4 Avg. Rating:5
Views:2353 Votes:0
Shares:0
Tags: pap2t
+

Related Content

Discussions Leaderboard