Moving dual MetroE Connection from 7200 to 4503, now only one can be brought up at a time.

Unanswered Question
Aug 3rd, 2010
User Badges:

I'll apologize in advance as I'm more of a voice guy, but I’ve got a customer who I moved from a 7206 for their dual ME connections to a 4503.  What they were doing was (only pertinent info incl):



Host 7206


interface GigabitEthernet0/1
description BST Private MetroE 900M - Primary
no ip address
ip route-cache flow
duplex full
speed 1000
media-type gbic
no negotiation auto
no cdp enable
!
interface GigabitEthernet0/1.287
encapsulation dot1Q 287
ip address 172.16.0.3 255.255.255.128
no snmp trap link-status
no cdp enable
!
interface GigabitEthernet0/2
description BST Private MetroE 900M - Secondary
no ip address
duplex full
speed 1000
media-type gbic
no negotiation auto
no cdp enable
!
interface GigabitEthernet0/2.287
encapsulation dot1Q 287
ip address 172.16.0.129 255.255.255.128
no snmp trap link-status
no cdp enable




router bgp 64806

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

neighbor PEER peer-group

neighbor PEER remote-as 64806

neighbor PEER route-reflector-client

neighbor PEER next-hop-self

neighbor PEER route-map CUST_PRIME_LINK out

neighbor PEERBACK peer-group

neighbor PEERBACK remote-as 64806

neighbor PEERBACK route-reflector-client

neighbor PEERBACK next-hop-self

  *snip*

neighbor 172.16.0.36 peer-group PEER

neighbor 172.16.0.162 peer-group PEERBACK


route-map CUST_PRIME_LINK permit 10
set local-preference 120




Remote Example:


interface GigabitEthernet1/0/1

description BST Private MetroE 100M

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 287

switchport mode trunk

speed nonegotiate

!

interface Vlan287

ip address 172.16.0.162 255.255.255.128 secondary

ip address 172.16.0.36 255.255.255.128

load-interval 30

!

router bgp 64806

no synchronization

bgp log-neighbor-changes

redistribute connected

redistribute static

neighbor 172.16.0.3 remote-as 64806

neighbor 172.16.0.3 next-hop-self

neighbor 172.16.0.3 route-map CUST_PRIME_LINK out

neighbor 172.16.0.129 remote-as 64806

neighbor 172.16.0.129 next-hop-self

no auto-summary

!

!

!

Works like a champ

!

!

After moving to the 4503 the only way I can bring up all the remotes is to have one of the int shut: !

!

interface GigabitEthernet3/2

description **** BST Private MetroE 900M - Primary ****

switchport trunk allowed vlan 287

switchport mode trunk

speed nonegotiate

no cdp enable

!

interface GigabitEthernet3/3

description **** BST Private MetroE 900M - Secondary ****

switchport trunk allowed vlan 287

switchport mode trunk

shutdown

speed nonegotiate

no cdp enable

!

interface Vlan287

ip address 172.16.0.129 255.255.255.128 secondary  ! Only like this to temp. provide secondary int to remotes

ip address 172.16.0.3 255.255.255.128

!


Bringing up that second interface makes the neighbors drop like flies one by one.  Otherwise it works great.  I realize that having two subnets on one VLAN on two interfaces isn't going to work as currently configured.



All traffic entering cloud must be tagged VLAN 278.  No other VLAN is allowed, although I'm told it can be ordered for additional charge that the customer isn't interested in paying.  Both circuits go to the same edge switch in the cloud,  LACP is not offered at the edge.  Per the example above, while there are two connections at the host, there is only one at the remotes.


How can I have both circuits active and routing at the same time, or is it even possible with the current setup?  The BGP config is legacy from when they were a managed customer, but now there is no reason that they have to remain with BGP, so one option I've been given from another engineer is to remove secondary interfaces and move to another routing protocol such as EIGRP and let it load balance between the two interfaces on the 4503, but if there's another option available that doesn't involve redesigning and reconfiguring every remote, that would be the preferable route to take.


Thanks in advance for any assistance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion