VG204 (MGCP) sending double DTMF digits

Answered Question
Aug 3rd, 2010
User Badges:

I have a VG204 running MGCP that seems to be sending double-digits through DTMF.  When an analog phone is attached, the call completes, but when entering DTMF, double-digits are sent - for example if we press "1" the VG204 will send "11".


This sounds a lot of like bug /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;} CSCso87127, so I upgraded the VG204's IOS to vg20x-ipvoice-mz.151-2.T.bin, and the VG204 was previously running vg20x-ipvoice-mz.124-22.T4.bin.


After upgrading the IOS, the issue still persists.


Any ideas?

Correct Answer by Steven Holl about 6 years 11 months ago

You're likely not hitting CSCso87127.


You can get a packet capture to verify, but I bet you're seeing MGCP NTFY for DTMF, along with DTMF in the RTP stream.


Chances are, assuming you are registering to CUCM, this is a config issue.  I'm willing to bet you are missing this line:

mgcp dtmf-relay voip codec all mode out-of-band


Try adding that, bounding MGCP, and seeing if your problem still exists.  BTW, that command is automatically added if you have ccm config server enabled.  You should enable that at least in the initial config, so that you make sure you have all the packaged CUCM wants configured on the gateway--it's common for people to miss some lines here and there.


CUCM behaves in a way that it stills sends a RQNT for DTMF even if OOB DTMF isn't configured.  As a result, even though with that command absent, although it should only have in-band DTMF, CUCM still forces the gateway to notify the CA when a digit is detected.  Hence, duplicate digits result.  There isn't a way.  Therefore, as it currently stands (it's been this way forever, BTW), anytime you do MGCP to CUCM, you *need* to configure an out of band DTMF relay so that the in-band audio is stripped (unless of course the downstream device isn't looking at the RTP payload for DTMF audio, but IOS or anything with a DSP always will).


Ideally, there should be a way for CUCM to not send the RQNT for DTMF notification if there is no 'mgcp dtmf-relay voip codec all mode out-of-band' line specified, so that DTMF is *only* in band.  Although the title is slightly misleading, this behavior and feature enhancement request is documented with:

CSCsg63981
Request to Support MGCP Packages Event Parameter - DTMF Tone Duration




-Steve Holl

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Steven Holl Wed, 08/04/2010 - 10:49
User Badges:
  • Cisco Employee,

You're likely not hitting CSCso87127.


You can get a packet capture to verify, but I bet you're seeing MGCP NTFY for DTMF, along with DTMF in the RTP stream.


Chances are, assuming you are registering to CUCM, this is a config issue.  I'm willing to bet you are missing this line:

mgcp dtmf-relay voip codec all mode out-of-band


Try adding that, bounding MGCP, and seeing if your problem still exists.  BTW, that command is automatically added if you have ccm config server enabled.  You should enable that at least in the initial config, so that you make sure you have all the packaged CUCM wants configured on the gateway--it's common for people to miss some lines here and there.


CUCM behaves in a way that it stills sends a RQNT for DTMF even if OOB DTMF isn't configured.  As a result, even though with that command absent, although it should only have in-band DTMF, CUCM still forces the gateway to notify the CA when a digit is detected.  Hence, duplicate digits result.  There isn't a way.  Therefore, as it currently stands (it's been this way forever, BTW), anytime you do MGCP to CUCM, you *need* to configure an out of band DTMF relay so that the in-band audio is stripped (unless of course the downstream device isn't looking at the RTP payload for DTMF audio, but IOS or anything with a DSP always will).


Ideally, there should be a way for CUCM to not send the RQNT for DTMF notification if there is no 'mgcp dtmf-relay voip codec all mode out-of-band' line specified, so that DTMF is *only* in band.  Although the title is slightly misleading, this behavior and feature enhancement request is documented with:

CSCsg63981
Request to Support MGCP Packages Event Parameter - DTMF Tone Duration




-Steve Holl

Brian Carlson Thu, 08/05/2010 - 12:11
User Badges:

Steve,

Thanks for your help, that fixed the issue with double DTMF.

Actions

This Discussion