Howto upgrade IOS of internal AP (Router 881w)

Answered Question
Aug 4th, 2010

Hi experts,

when I try to access the web interface of the internal AP of our new Cisco 881w router, I only get a small "Enter" button, nothing more. When I click on this button, nothing happens. According to this thread ( it seems I should update IOS of the internal AP of this router.

My question now is: How can I update the IOS of the internal AP?

Are there any guides available?

Thanks in advance for your help!

Kind regards, Matthias

I have this problem too.
0 votes
Correct Answer by Surendra BG about 6 years 2 months ago

sorry... the exact command is

AP#archive download-sw/force-reload/overwrite tftp://

there is no forward slash after overwrite..

Let me know how this works out for you!!



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Surendra BG Wed, 08/04/2010 - 04:49


yes you are hitting a software bug, where in the WEB GUI is breaked. To overcome this we need to upgrade the IOS.. Plz follow the below steps..

From the router console isse the command..

service-module wlan-ap0 session (u will go into the AP module)

Download the latest image from the for the 881W. Download the TFTPD32.EXE from google and point the image which u downloaded in the tftpd32

Connect the ethernat cable between the Router and the PC along with the Console access. now test the connectivity, if we have the connectiviy then isssue the below command on the AP cli.

archive download-sw/force-reload/overwrite/tftp:////

Thats is..

archive download-sw/force-reload/overwrite/tftp://

you will be done.. if you face any issues, then i request you to open up a new case with us.. i mean with Cisco TAC.



MatthiasGTW Thu, 08/05/2010 - 00:04

Hello Surendra,

thanks for your quick reply. Unfortunately we have no TAC contract, so I am not able to access the firmware update (your link). But as you say, the product (881w router) is - buggy, so I can't use it by now. Do I need a TAC contract in order to get a working and functional Cisco product?

Kind regards, Matthias

Surendra BG Thu, 08/05/2010 - 05:15

yes TAC contract will help you in fututre as weel if you face any issues.. n 881W is not buggy. Just the software running on it



MatthiasGTW Thu, 08/05/2010 - 05:35

sorry, but that's only part of the truth. Yes, the device itself may not be buggy, but the software is in fact part of the product. Therefore, one - essential - part of your product does not work. I have paid for it. Now I want to apply the already existing patch, in order to make the device I have paid for fully functional.

Do you want to say that I have to pay again, only to get the device working? Does it mean that the first amount I have paid (the price of the router) was only for the hardware, but when I want the software also working and functional then I have to pay again?!

Regards, Matthias

Surendra BG Thu, 08/05/2010 - 05:55

if ur device is under warranty.. then plz contact the TAC frontline number. they may help you in opening a tac ticket.



MatthiasGTW Thu, 08/05/2010 - 06:21

Thanks, I will do that then, as the device is only few days old.

Kind regards, Matthias

Surendra BG Thu, 08/05/2010 - 06:39

Great!!! Hope i pick ur case and help you out in resolving but i work for APAC time zone

MatthiasGTW Mon, 08/16/2010 - 07:32

Hello Surendra,

now that I got the update I tried as you said, first connecting to the internal AP via "service-module wlan-ap0 session". Then I tried to load the new firmware from the TFTP server on my local machine. Unfortunately, when I issue the following command:

"archive download-sw/force-reload/overwrite/tftp://"

then I only get this error: "% Invalid input detected at '^' marker" (the marker is within the filename ...-tar.124 ^-21a.JY.tar".

Ok, so I thought the filename may be a bit too long, so I renamed it to "ap801.tar" and tried the same command, but again with the same error:

"% Invalid input detected at '^' marker" (the marker is now in the command itself, under the "r" of "archive").

What can I do?

MatthiasGTW Tue, 08/17/2010 - 01:47

Hi Surendra,

the archive command now looks good, I could identify all options via the "?" help command.

Unfortunately I can't access any host from the AP module. After opening the session to the AP and using the "enable" command (via console), I can't reach any host/IP except the BVI1 interface. I can't even ping the interfaces on the router itself. But:

  • NAT to the Internet works from both subnets (LAN and WLAN)
  • pinging works from clients in WLAN to clients in LAN
  • pinging works from clients in LAN to clients in WLAN
  • pinging works from clients in WLAN to any interrace on router
  • pinging works from clients in LAN to any interface on router

So routing and NAT seems to be set fine for the router and the clients, but only for the WLAN AP module itself it does not work. Why can't I reach any other host from the WLAN module, even those on the private networks?

Kind regards, Matthias

PS: I have attached both config files (router and AP module) to this posting

cfawcett82 Tue, 01/11/2011 - 14:09

i am having this same bit of trouble, i cant access any hosts from ap#

but i can access them from router#

any help for this?


This Discussion