Video Call: cucimoc 8 to h323 Client (Tandberg T1000)

Unanswered Question
Aug 4th, 2010
User Badges:

Hi all,


in my lab i've CUCM 7.1(3a), PC with cucimoc 8.0(2), PC with IPC and CUVA and one Tandberg T1000 registered on a Gatekeeper and configured on the CUCM as a H323 Client Gatekeeper controlled. I'm not able to have video call working between cucimoc and Tandberg, only audio are negotiated.
This is what happen:


Video Call from IPC+CUVA to CUCIMOC = ok
Video Call from CUCIMOC to IPC+CUVA = ok
Video Call from IPC+CUVA to Tandberg = ok
Video Call from Tandberg to IPC+CUVA = ok
Video Call from CUCIMOC to Tandberg = No video - only audio
Video Call from Tandberg to CUCIMOC= No video - only audio


Any idea? There is not so much to change about settings on CUCIMOC client, the problem is the same even if the cucimoc is set to deskphone or softphone.


Thx,
Christian

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Markus Schneider Wed, 08/04/2010 - 06:57
User Badges:
  • Cisco Employee,

Sounds a lot like an issue I encountered here as well (with a Tandberg1700 registered to a gatekeeper). 


In my case, during call setup the CUCIMOC client would send a SIP/OK message with media format type 106, however in the connection statistics (in CUCIMOC), it would show that it was set up to receive RTP payload type 97.  It should have been 106 in both directions, according to the SIP call setup information.

The result would be that effectively it wasn't decoding the video information with the correct payload type, so you would see nothing. 

This was reported in a defect, CSCth43523, which was fixed in an engineering special (also maintenence release 2; i.e. MR2) that should be available from TAC (I think 8.0.3 will have the fix as well).

cbrasolin Wed, 08/04/2010 - 07:10
User Badges:

Thank you Markus, i tried also another Tandberg model (i don't remember the code) with the same result, so i'm waiting for the next cucimoc release.

At the moment i can't read the bug details since is currently under review for publishing on Bug Toolkit.



Bye,

Christian

Markus Schneider Wed, 08/04/2010 - 07:18
User Badges:
  • Cisco Employee,

If you run wireshark on the CUCIMOC client, start a capture and place a call.  While the call is up, go into the connection statistics and look at the receiving RTP payload type on the video statistics).  Then stop the capture and filter on sip messages.  The OK message sent by the CUCIMOC client should have the same payload type.  If it's not, then this likely is the defect.

The only strange thing here is that in my case, it was one-way video; i.e. the Tandberg could see the video from CUCIMOC, but not the other way around.

cbrasolin Wed, 08/04/2010 - 07:47
User Badges:

When the call is up in the connection statistics i don't see details about video packets, furthermore using wireshark the only rtp packets i see are g.711. It seems that nobody are sending video packets.

The ok message is received by the cucimoc and is specified the payload type 97, the only ok message sent by cucimoc does not contain this information.


Hope that the jpeg file in the attachment can be shown


Christian

cbrasolin Wed, 08/04/2010 - 07:56
User Badges:

It's possible to disable the codec h.264 from the negotiation in the cucimoc?

cbrasolin Tue, 08/24/2010 - 00:24
User Badges:

I saw that the bug CSCth43523 became public, the CUCIMOC release with the fix is 8.0(722.14153). I suppose that this release is not yet available, right?

Actions

This Discussion

Related Content