1760 IOS Issue

Unanswered Question
Aug 4th, 2010


I have a router 1760 and i was trying to upgrade the IOS, the router has 32MB of flash, but when i copy the IOS i got this error Error : memory requirements exceed available memory
Memory required     : 0x043EF71C

*** System received a Software forced crash ***
signal= 0x17, code= 0x4, context= 0x8000c530
PC = 0x0, Vector = 0x0, SP = 0x0

I made the steps for install new IOS with less space

  1. rommon>IP_ADDRESS= 
  2. rommon>IP_SUBNET_MASK= 
  3. rommon>DEFAULT_GATEWAY= 
  4. rommon>TFTP_SERVER= 
  5. rommon>TFTP_FILE=c1700-k9o3sy7-mz.124-5a.bin 


But i kept getting the same issue now the router is re-booting, I'm also used smaller IOS the last one that I install has 16mb.

Any help


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
krahmani323 Wed, 08/04/2010 - 08:24

Hello Yancy,

I think that with the new IOS you are exceeding here your DRAM requirments (flash ok).

I see you are trying to boot with c1700-k9o3sy7-mz.124-5a.bin (no more downloadable on Cisco.com / 124-5c is downloadable) for which minimum memory requirment is 96Mb.

Minimum Memory:                                                                   DRAM:96                                                                  MB Flash:32                                                                  MB

If you are OK with the management of your flash spance, could you please indicate :

- What is theDRAM memory size on your 1760 ?

- What previous IOS running on your router ?

Thanks !


INFOTEP_OFN Wed, 08/04/2010 - 10:27


Thanks for your answer I don't the have the previous version of the IOS because wasn't me how make the upgrade I'm fixing this.

the amount of DRAM is 65536, I'm looking and IOS for run a Wic ENET card, because with the oldest IOS the routers sometimes freeze.


krahmani323 Wed, 08/04/2010 - 12:10

Hello Yancy,

As your DRAM is 64M size you could unfortunately not run the c1700-k9o3sy7-mz.124-5a.bin IOS which requires 96M of DRAM..

Either you would have to choose another IOS which requires 64M (for ex. c1700-advsecurityk9-mz.124-5c.bin ;  c1700-entbasek9-mz.124-5c.bin....) by browsing the cisco.com software download with your CCO Id.

You can also use software advisor for this :

=> http://www.cisco.com/en/US/products/hw/routers/ps221/products_tech_note09186a008009483a.shtml#hw_compat_memory

Or either you will have to physically upgrade the DRAM for your 1760 according to procedure described here =>


*Note these upgrade memories (to 96M and 128M) are EoS (http://www.cisco.com/en/US/partner/prod/collateral/routers/ps221/eol_c51_487838.html).


Regarding the WIC-1ENET issue as longer as the requirments for the module are OK (http://www.cisco.com/en/US/docs/routers/access/interfaces/ic/hardware/installation/guide/esw_wic.html#wp1023482), it should be fine.

The WIC-1ENET card requires Cisco IOS Release 12.2(2)XJ or later if the  card is installed in any WIC slot other than slot 0 or if more than one  card is installed.

The card can be used with Cisco IOS Release 12.2(4)T, but the card must  be installed in slot 0 and only one WIC-1ENET card can be installed in  the router.

Furthermore the following link http://cisco.biz/en/US/docs/routers/access/1700/1760/hardware/installation/guide/intro.html#wp1021873

states WIC-1ENET are supported in slot 0 and slot 1. Is your WIC-1ENET module freezing sometimes used in slot 0?

If I was facing the issue I would indeed try to upgrade IOS. If it doesn't fix I would try to take all the traces when the issue occurs (if there is any) and even test with another module.

Hope to help.




This Discussion