Basic Rate ISDN problems

Answered Question
Aug 4th, 2010

Hi All, Wondering if someone can spot any issue swith the config below. Basically it's a 2821 with 4 BRI ports controlled via MGCP from callmanger 7.X. I am sure I am right but I need to make sur ethat the TEI negotiation would occur whatever the callmanager config - the ports themselves have registered with CCM.

no aaa new-model
network-clock-participate wic 2
network-clock-participate wic 3
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.114.16.245 10.114.16.254
!
ip dhcp pool IPT-Phones
   network 10.114.16.0 255.255.255.0
   default-router 10.114.16.251
   option 150 ip 10.112.14.1 10.112.14.2
!
!
multilink bundle-name authenticated
!
isdn switch-type basic-net3
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
interface GigabitEthernet0/0
description Link to switch fa 1/0/7
backup interface GigabitEthernet0/1
ip address 10.114.16.251 255.255.255.0
duplex full
speed 100
!
interface GigabitEthernet0/1
description backup Link to switch fa 5/0/1
ip address 10.114.16.251 255.255.255.0
duplex full
speed 100
standby 0 mac-address 2893.fef8.7100
!
interface BRI0/2/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn bind-l3 ccm-manager service mgcp
!
interface BRI0/2/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn bind-l3 ccm-manager service mgcp
!
interface BRI0/3/0
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn bind-l3 ccm-manager service mgcp
!
interface BRI0/3/1
no ip address
isdn switch-type basic-net3
isdn point-to-point-setup
isdn incoming-voice voice
isdn bind-l3 ccm-manager service mgcp
!
ip default-gateway 10.114.16.254
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.114.16.254
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/2/0
compand-type a-law
cptone GB
!
voice-port 0/2/1
compand-type a-law
cptone GB
!
voice-port 0/3/0
compand-type a-law
cptone GB
!
voice-port 0/3/1
compand-type a-law
cptone GB
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 10.112.14.1
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.112.14.1 
ccm-manager config
!
mgcp
mgcp call-agent 10.112.14.2 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode cisco
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
!
mgcp profile default

errors from debig ISDN Q921

*Aug  4 14:30:18.015: ISDN BR0/2/0 Q921: User TX -> IDREQ ri=22580 ai=127
*Aug  4 14:30:23.527: ISDN BR0/3/1 Q921: User TX -> IDREQ ri=56181 ai=127
*Aug  4 14:30:23.551: ISDN BR0/3/0 Q921: User TX -> IDREQ ri=37574 ai=127
*Aug  4 14:30:23.551: ISDN BR0/2/1 Q921: User TX -> IDREQ ri=48935 ai=127
*Aug  4 14:30:24.031: ISDN BR0/2/0 Q921: User TX -> IDREQ ri=45464 ai=127
*Aug  4 14:30:25.527: ISDN BR0/3/1 Q921: User TX -> IDREQ ri=51993 ai=127
*Aug  4 14:30:25.551: ISDN BR0/3/0 Q921: User TX -> IDREQ ri=31914 ai=127
*Aug  4 14:30:25.551: ISDN BR0/2/1 Q921: User TX -> IDREQ ri=18251 ai=127
*Aug  4 14:30:26.031: ISDN BR0/2/0 Q921: User TX -> IDREQ ri=48124 ai=127
*Aug  4 14:30:27.527: ISDN BR0/3/1 Q921: User TX -> IDREQ ri=31677 ai=127
*Aug  4 14:30:27.551: ISDN BR0/3/0 Q921: User TX -> IDREQ ri=14222 ai=127
*Aug  4 14:30:27.551: ISDN BR0/2/1 Q921: User TX -> IDREQ ri=45167 ai=127
*Aug  4 14:30:28.031: ISDN BR0/2/0 Q921: User TX -> IDREQ

Correct Answer by Steven Holl about 6 years 6 months ago

I'm assuming that 'sh isdn st' shows L2 not up, right?

Do you know how your provider is provisioned as far as the TEI goes?  Are they doing a dynamic or static TEI?  Half the time, you usually need to add this:

isdn static-tei 0

-Steve

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Steven Holl Wed, 08/04/2010 - 11:09

I'm assuming that 'sh isdn st' shows L2 not up, right?

Do you know how your provider is provisioned as far as the TEI goes?  Are they doing a dynamic or static TEI?  Half the time, you usually need to add this:

isdn static-tei 0

-Steve

Paul Austin Wed, 08/04/2010 - 11:31

They would normally be dynamic but I'l give it a go.

Thanks very much

Paul Austin Thu, 08/05/2010 - 11:08

Hi Steve, Yep that was the fix - thanks very much. Afterwards I

remembered I had to do something similar about 10 years ago but forgot about it as we don't do much of that stuff nowadays.

Thanks

Actions

This Discussion