OSPF Configuration Issue

Answered Question
Aug 4th, 2010

I'm trying to setup OSPF routing over Frame Relay and I'm having a problem getting into config-router mode on 2610 router. I'm at global config and I enter

R3#router ospf 1 and it accepts it, but stays in config so I'm not able to enter in any network statements.


R3(config)#router ospf 1
R3(config)#

Clearly the router is capable of running OSPF. I really appreciate any feedback or insight into the problem!

Thanks

Here's my config on the router:


version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
memory-size iomem 10
no aaa new-model
ip subnet-zero
ip cef
no ip domain lookup
!
!
!
!
!
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.31 point-to-point
ip address 172.12.123.3 255.255.255.0
frame-relay interface-dlci 321
!
interface Serial0/1
no ip address
shutdown
!
no ip http server
ip classless
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login
line vty 5 181
exec-timeout 0 0
logging synchronous
login
!
!
end

I have this problem too.
0 votes
Correct Answer by Ramprasad Pr about 6 years 4 months ago

Upgrade IOS.

Raam

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Nagendra Kumar ... Wed, 08/04/2010 - 19:42

Hi,

I rememeber faching this issue when there is no IP interface in UP/UP state. Try configuring a loopback interface with some address and then try "router ospf". Else try bringing the frame-relay intf up and then try "router ospf"

HTH,

Nagendra

vishwancc Wed, 08/04/2010 - 22:12

Hi,

I dont see the mode changing to (config-router)

R3(config)#router ospf 1
R3(config)#

Could you check in show process CPU if the ospf process is running ?

Chao

Vishwa

Sguillen34 Wed, 08/04/2010 - 22:22

I checked the processes and I don't see OSPF running. My other routers don't have any loopback interfaces set, but they can still get into router config mode without an issue.

Sguillen34 Thu, 08/05/2010 - 07:24

I've thought that maybe it's related to the physical interface or the fact that I'm using a point-to-point interface.

So I physically removed and reseated the serial interface. I've also tried using another physical interface and finally I've tried setting up frame relay over just the physical interface without point-to-point or multipoint and I still can't get into router config mode. I tested it with the other protocols and it works.

Is it possible that there could be a physical defect?

Sguillen34 Thu, 08/05/2010 - 11:15

Thanks so much for your help on this issue. I found the solution! It was the IOS version all along,but I didn't think it was since it displayed OSPF as an option.

I had the REMOTE ACCESS SERVER c2600-c-mz.123-26.bin version which doesn't support it so I had to get the Enterprise Basic version that supports it. Man that was frustrating!

Thanks again!

Actions

This Discussion