Problem accessing the PerfmonPort SOAP service

Unanswered Question
Aug 5th, 2010

Hi,

I am trying to access the PerfmonPort Serviceability API, using a script.

I am trying the single transaction operation perfmonListInstance and I get the '500 Internal Server Error'

My XML request is the same as shown the XML developer guide

<?xml version="1.0" encoding="utf-8"?>
            <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <soapenv:Body>
            <ns1:PerfmonListInstance soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns1="http://schemas.cisco.com/ast/soap/">
            <Host xsi:type="xsd:string">10.136.11.21</Host>
            <Object xsi:type="ns1:ObjectNameType">Process</Object>
            </ns1:PerfmonListInstance>
            </soapenv:Body>
            </soapenv:Envelope>'

My HTTP header has the SOAP action

'SOAPAction' => "http://schemas.cisco.com/ast/soap/action/#PerfmonPort#PerfmonListInstance"

And I am posting my request to

"https://$o_host:$o_port/perfmonservice/services/PerfmonPort/"

Please let me know if I am going wrong somewhere.

I tried enabling the SOAP service trace logs on the Cisco Serviceability Page. However, I dont find this service in the RTMT tool, when I try to view the trace files. Is there some logs, where I can see what happened to this request.

The other thing is the SOAP Monitor. Not sure how this thing works. How do the SOAP requests come in?

Thanks

Roycey

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion

Related Content