RV120W doesn't allow browsing

Unanswered Question
Aug 5th, 2010
User Badges:

Just setup a brand new RV120W at my house.  I have the wireless working, LAN clients connected, even got an IPSec tunnel to the office up and running.    One of the PCs behind the router is setup as a logmein client and tech guys from the office can access my home PC using logmein.


One problem though, I can't browse any web sites!!  I can ping public IPs by name and IP address but no browsing.  Very weird.  Is there some setting that has http turned off?  If so, I can't seem to find it.  Please help.


BTW, one more thing I noticed is that although I can ping out, the router seems to drop quite a few packets.  I would say about 70-80%. Could this be related to the browsing?  Router is using PPPoe connection and has the latest firmware of 1.0.0.12.


Thanks,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
streaves Fri, 08/13/2010 - 15:52
User Badges:
  • Cisco Employee,

Hello Diego --Thanks for posting in the Support Community.


The RV 120W Engineering Team is reviewing your issue. Would you be kind enough to share your configuration file? This will help us troubleshoot.


Thanks,

Stephanie Reaves

Small Business Technology Group

DIEGO ALONSO Sun, 08/15/2010 - 05:59
User Badges:

Thanks for the reply but I already returned the router.  Just so you know, the problem seems to happen when the router is using PPPoE on the WAN port.  I tried it at three different sites and any time you have the WAN port in PPPoE mode the browsing would not work.  Then I took it to work and put the WAN port in DHCP mode and it worked like a champ.


Thanks,

Diego 

herr_yoonka Sun, 08/15/2010 - 08:25
User Badges:

Hi Guys, Good news, I've got the same problem so we can continue this thread. While I share the inability to connect to the internet it only happens with certain machines. Specifically OS X Tiger Servers. We have 3 PPC/G5 servers we use for misc math work and they are behaving as the first poster described. We have a RV042 that is connected to Speakeasy 3MB Business Ethernet and 12/1MB Business ADSL doing load sharing. If I turn the load sharing off the Tiger Servers work correctly. I've attached the configuration file just in case.


Shared symptoms:


1) Can't connect to internet to download any type of content

2) Can ping external domains but with ~80% packet loss



Different:


1) This only affects certain machines. Specifically OS X Tiger servers.

2) The snow leopard and windows 7 machines on our network seem to work fine.


Let me know how I can help you help me further.


J

Attachment: 
herr_yoonka Tue, 08/17/2010 - 08:18
User Badges:

As an update, I'm seeing better performance after replacing the ADSL modem. The issue still appears but seems less frequent.

jason.mack Tue, 08/17/2010 - 08:33
User Badges:

I had my ISP replace the WIC card on my CISCO 1841 T1 Modem, and then I did a factory reset on the RV120W.

Saw much better performance after.


I still get "hiccups" with high bandwidth on network.


Every so often DNS is either blocked or times out...


My file corruption seems to be limited also now.  Joe, did you see any file corruption on files downloaded greater then 100k?

jason.mack Wed, 08/18/2010 - 06:08
User Badges:

THIS THREAD WAS STARTED IN JUNE.

DOES CISCO HAVE ANY ANSWERS YET?


THIS IS MORE THE A PPPoe ISSUE.


IT OCCURS ON STATIC IPs ALSO.

mmears111 Thu, 08/19/2010 - 20:16
User Badges:

I wouldn't bet on it. There are obviously some serious design issues with this router.

Either they don't have a clue how to fix it or they seriously just do not care, must not be enough profit margin with these for them to worry about it.

2 months of replies saying Engineering is looking into it doesn't quite help

jason.mack Mon, 08/23/2010 - 06:31
User Badges:

Finally, a cisco response via email...



8/20/2010

Jason,

A recent issue has come to light with some RV120W’s, where the CPU utilization will spike and router performance will suffer.  I believe this may be the issue we are seeing in your case.  Please let me know if you are seeing any processor spikes (90-100%) when your network issues are ongoing, and we can escalate your case if needed.

Thank you

John Tishey
SBSC Engineer
CCNA

mmears111 Mon, 08/23/2010 - 06:48
User Badges:

When I had mine connected I saw processor spikes and high memory utilization pretty much all the time.

herr_yoonka Mon, 08/23/2010 - 06:49
User Badges:

That's great Jason. Please share your resolution When you find it.


I have a smaller unit with no CPU monitor but maybe I'll get some clues.


J

jason.mack Mon, 08/23/2010 - 07:38
User Badges:

Joe:


Do you have a RV120W?

Do you see occassional IE "page cannot be displayed" errors or have any corrupt downloads?


I don't know why I am speading time figuring out this unit.  I should have returned it immediately.

My office staff was ready to lynch me when I first placed it online.


Let me know about your issues.  I have finally gotten the case escolated with CISCO and I might actually talk to a true engineer this afternoon.



Jason

herr_yoonka Mon, 08/23/2010 - 09:30
User Badges:

Hi Jason,


I have a Linksys RV042 as a temporary replacement to our Cisco 2811 that is being re-configured. The reason I'm on this thread is because of the symptoms you are describing. On *certain* machines while I'm using load sharing through the router, I experience the same thing you do. If I turn off load sharing, the problem goes away. Give that a shot.


Most of my machines behave perfectly, I suspect this is a problem with the configuration of the machines that are giving me a problem but it is being aggravated by the Linksys / Cisco device.


Luckily, these machines aren't very important and when I need access stability, I know how to hobble them to get it. Please share what you find!


J

jason.mack Tue, 08/24/2010 - 05:32
User Badges:

Cisco Engineering asked me to changed a firewall setting.. .UDP FLOOD


"under Firewall-Basic Setting, there is an option for Block UDP Flood, if  the box is checked please un-check"


I made the change last night, and VPN tunnels seemed to have somewhat better performance last night.

This AM, I have seen no error messages on my machines as of yet.  Load is increasing, but so far I am stable

(fingers crossed)


Give it a try and let me know...

jason.mack Tue, 08/24/2010 - 07:20
User Badges:

FYI


EmployeeDavid Hornstein
460 posts since Sep 19, 2008
Currently Being Moderated
25. Aug 24, 2010 7:38 AM in response to: Jason Mack
Re: RV120W ROUTER/FIREWALL "cannot display the webpage"

Hi Jason et al..


i believe the technician are now aware of a UDP issue on the Rv120W.


The internal discussions on the issue from R&D and development  seems to be;




1.       By default on RV120W there is a UDP Flood attack check which limits 25 UDP Connections Per Client in one instance, i.e at a particular time instance a PC behind this router can establish only 25 UDP Transactions, if we exceed router drops UDP Packets.


2.       We have a script that sends dns lookup queries at a very high rate than the router clears the UDP entries, this way we build up the UDP entry table in the router(i.e 25 entries)


3.       Once 25 limit is reached we are unable to resolve further DNS queries, using the script or using the browser.


4.       In the real world scenarios there might be one PC behind the router and open a website where all the items on the webpage are linked to different website, if you open this kind of website it may have links to more that 25 different website and clog the routers UDP table for that particular PC and user might not be able to resolve further DNS queries and unable to browse any new websites. This unability to browse happens until the UDP entries on the router time outs  and are cleared.


5.       This limit of 25 is because of the feature called Block UDP flood on the router which is enabled by default.


6.       Once we disable the block UDP Flood, router does not check for 25 UDP Connections limit and dns resolution is continuous without a break.


This is what a customers in the field might be seeing interruptions in DNS resolutions and website browse failed.

Some customers explicitly talked about DNS failures.




Jason I can see you have placed a service call, so hopefully CCORAL who posted on the 15 August should be helping you.


So Folks, If the Technician  deem the problem not a hardware issue requiring RMA, the technician will escalate the call to our Level 2 folks in Irvine, probably CCORAL.  You will get assistance to resolve this issue.


The Small Business Support center, should be aware of the problem. Please feel free to show them this posting, i am willing to chat with them to get the ball rolling.



So again, if you have not done so already,  please contact the SBSC  and place a service request and keep a copy of that number they give you as a reference (you may need it). My appologies for the inconvenience you have all had.


regards


Dave Hornstein

Small Business, Channel Systems Engineer

Cisco  - Research Triangle Park.  USA

mmears111 Tue, 09/28/2010 - 13:53
User Badges:

How did you make out with this? Did this setting take care of your problems?

DIEGO ALONSO Tue, 09/28/2010 - 18:31
User Badges:

I switched to a RV042 and WAP-54G combo.  Didn't make any sense to keep messing with it.


Diego

QuimaxWoods Wed, 09/29/2010 - 04:20
User Badges:

The UDP setting helped my case anyways. There is also rumor of a 'beta' firmware from Cisco that solves several issues with these routers, but you'll have to call Cisco support to get it. I havn't called so I don't have it and thus cannot comment on that.

Actions

This Discussion