outbound Auto Attendant not responding to dialed numbers

Unanswered Question
Aug 5th, 2010
User Badges:

hey everyone...our setup is CUCM 7.x, H.323 gateway. When placeng calls to a company with an auto attendant, we get no response from their auto attendant when pressing the appropriate digits in their menu. When digits are pressed, the menu keeps playing as if nothing is happening. So, I would assume the tone signal is not coming through properly from our end. Any ideas? Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
brandonabrown Thu, 08/05/2010 - 07:23
User Badges:

my dial-peer is referencing a PRI...


dial-peer voice 6 pots
description ===== LONG DISTANCE CALLS ===== ===== LONG DISTANCE CALLS =====
preference 2
destination-pattern 91[2-9]..[2-9]......
clid override rdnis
port 0/1/0:23
prefix 1

Jaime Valencia Thu, 08/05/2010 - 07:31
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

Nevermind, I understood it was your AA that was not responding.

Have you tested from other phones to confirm their AA recognizes the DTMFs? your mobile, your home phone?

This problem is usually on the other end so it's not something you can fix.

Do a simple test, dial 1-800-GOCISCO and try to use the options. If they work, you're sending the DTMFs.


HTH


java


If this helps, please rate


www.cisco.com/go/pdihelpdesk

Steven Holl Thu, 08/05/2010 - 07:32
User Badges:
  • Cisco Employee,

Brandon.


You are missing the concept that Cisco gateways always match TWO dial-peers for every call that traverses the gateway:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a008010fed1.shtml


In your scenario for this call direction, you will match an inbound voip peer, and outbound POTS.


Try adding this:

dial-peer voice 555 voip

incoming called-number 91[2-9]..[2-9]......

  dtmf-relay h245-alpha

  codec

  no vad



Verify once the call is up that you match pid:555 on the top leg with 'sh call active voice br'.


What is likely currently happening, is you have no inbound peer defined, so we match pid 0 inbound, which doesn't have DTMF-relay capabilities.  You'd see that in the oubound TCS if you looked at the H245 messaging.


-Steve

brandonabrown Thu, 08/05/2010 - 08:00
User Badges:

hi Steve...here's my default dial-peer for incoming...


dial-peer voice 15 voip
description DEFAULT INCOMING DIAL-PEER
translation-profile incoming INCOMING
incoming called-number .
dtmf-relay rtp-nte
codec g711ulaw
no vad

Steven Holl Thu, 08/05/2010 - 08:26
User Badges:
  • Cisco Employee,

Brandon,


That's your problem.  CM doesn't support rtp-nte on H323 trunks.  This will fix it.



dial-peer voice 15 voip
 description DEFAULT INCOMING DIAL-PEER
 translation-profile incoming INCOMING
 incoming called-number .
 dtmf-relay h245-alpha
 codec g711ulaw
 no vad



-Steve

Actions

This Discussion

Related Content