Enable LLDP-MED on 3560-E PoE

Unanswered Question
Aug 5th, 2010
User Badges:

All,


I'm working with LLDP for the first time and currently unable to get a 7945 ip phone to register with a Cisco 3560-E series switch.  So far, I've enabled LLDP globally on the switch, turned on transmit/receive, and initialized "lldp med-tlv-select inventory-management" on the interface the phone is connected to.  I also have LLDP for the phone configured at the device level in UCCM (ver 7.1).  There is no network-policy configured at this point.


When I run a show lldp neighbor, I'm only seeing the connected IDF switch, no media endpoint device(s).  Right now, only one IP phone is plugged into this switch.


--> show lldp interface output:


GigabitEthernet0/12

     Tx: enabled

     Rx: enabled

     Tx state: IDLE

     Rx state: WAIT FOR FRAME


Is configuring an lldp based network policy required and if so, do I need to apply it to the vlan or the interface?


Any insight would be greatly appreciated.


ck

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Lamar Demby Thu, 08/05/2010 - 12:59
User Badges:

Just found this note in a doc...


Note: By default Cisco switches do not send out what Cisco term as LLDP-MED

LLDPDU which includes the Network Policy TLV until an LLDP-MED packet is

received by the switch port. The Network Policy TLV is used to advertise to any

attached device what VLAN to use for sending traffic. Once the Cisco switch port

receives a LLDP-MED packet from the attached device, the switch will then send only

LLDP-MED LLDPDU going forward.


The part that I'm not fully understanding is whether or not the phone will send out an LLDP-MED LLDPDU packet by default on it's own or do I need a Network-Policy applied to the interface to initialize this feature?

ckltd7401 Mon, 08/09/2010 - 06:07
User Badges:

I found that I was able to get the LLDP-MED packets flowing by performing the following steps:


When building a new config:

1) Enable LLDP from the Global Config CLI:  lldp run

2) Create a network-policy profile for the voice vlan (in my example, the voice vlan is 123):


     network-policy profile 123
      voice vlan 123
      voice-signaling vlan 123


3) Apply the voice vlan to the applicable switchport interface(s)


When adding to an existing config:

1) Enable LLDP from the Global Config CLI:  lldp run

2) Create a network-policy profile for the voice vlan (in my example, the voice vlan is 123):


network-policy profile 123
voice vlan 123
voice-signaling vlan 123


3) Apply the network-policy to the switchport interface(s)


     int g0/10

     network-policy 123

     lldp med-tlv-select network-policy


     Note:  This will remove any pre-existing voice vlan from the interface(s).


At this point, the LLDP-MED packets should start flowing between the IP phone and switch.  However, in my case this didn't happen.  I had to remove the network-policy that I had just applied to the interface and re-apply the voice vlan.  For some reason (at least in my setup), the LLDP process did not trigger with the applying of the network-policy.  It would only work after I applied the network-policy to the interface, removed the network-policy from the interface, then re-applied the voice vlan to the interface.  I have a TAC case open regarding this at the moment and will post my findings if applicable.


Hope this helps any other newbies who may have experienced anything similar to this.


ck

whenusayloveme Mon, 04/14/2014 - 09:30
User Badges:

Hi CK,

I know that it is 4 years passed, but what is the root cause after you open the TAC case? I'm interested with this one because I'm going to deploy LLDP with my customer next week.

BR.

Winai

Actions

This Discussion

Related Content