Is it possible to bleed ipv6 routes in 12.2(33)SXI?

Unanswered Question
Aug 5th, 2010


I am getting ready for a prototype IPv6 test and had a chance to setup a quick lab to test the configuration. On a core router, I have two VRF's (VRF-lite). An ADMIN and a PRODUCTION VRF,  and no usable global VRF (all interfaces are either in ADMIN or PRODUCTION).

Some interfaces are dual-stacked, others are native. The IPv4 route bleeding works fine. I am using the BGP address-familys and route-target import/exports to exchange the routes.

For IPv6, I added address families to the vrf definitions and placed the appropriate import/export commands. Under BGP, I added the address-family for IPv6 for both VRF's, then added the appropriate /64 networks for each VRF's interfaces.

Debug on bgp vpvn6 and ipv6 routing shows the tables being checked and populated with the different routes. The show ipv6 route vrf ADMIN or vrf PRODUCTION shows the correct BGP routes for the imported VRF's. show ip bgp vpnv6 unicast all shows the correct entries for each VRF.

When I attempt a ping (example):

ping vrf ADMIN ipv6

Target: <ADMIN host>



Extended: yes

Source Interface <PRODUCTION address>

specifying the source and destination, I get 0 responses. Debug on IPv6 packets show the FIB lookup succeeds and the correct src/dest packet is sent on the correct VLAN of the destination host. No response.

I did a capture in the IOS on the destination VLAN and did not see any ICMP packets arriving. I may have to source the capture off the rp/sp to see those packets perhaps?

Anyway - I am trying to do something that isn't supported? Everything seems to be in place, but it just doesn't work. I'd post the config, but the lab is in a closed system with no export capability..

I tried moving a native v6 VLAN interface (2000) to the global vrf and put in static routes, where vlan 3000 is in the ADMIN vrf:

ipv6 route 2600::/64 vlan 3000

ipv6 route vrf ADMIN 2700::/64 vlan 2000

which the IOS accepts, but do not show up in the routing table. The <next-hop-vrf> option isn't available like in the router code. So VRF to global static routes don't work either... I think I may be trying to do something that the IOS can't satisfy.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
jspenceCCSI_2 Wed, 08/11/2010 - 13:03

Hi Chad.  I had this exact same issue today.  A really good SE gave me the answer.  You need the forms:

ipv6 route nexthop-vrf

ipv6 route vrf nexthop-vrf Default

Try those.

csbowser Mon, 08/16/2010 - 04:31

Oddly enough, it just won't work. It will take the commands and put them in the routing table, but no packets succeed.

I am successfully bleeding v4 routes using bgp (vpnv4). Tried this with v6 and
the route tables are populated correctly, and debug of IPv6 ICMP/packet shows the fib lookup succeeding and the packets being sent to the correct vlan interface... but no response. Capture on the destination vlan shows no packets arriving. That's why I'm wondering if this just isn't possible on the Catalyst 6500 platform.

I'm attempting the same thing on a Nexus 7000 now to see if I can get it to succeed and maybe take the lessons learned back to the catalyst.

jspenceCCSI_2 Mon, 08/16/2010 - 20:57

Huh.  Let me know how it turns out.  Originally, I had left off the nexthop vrf, and had "default" instead of "Default" (which is a known bug) and *boom* - it started working just right.

patrick.dice Wed, 08/03/2011 - 07:48

I am working on the same problem as you have outlined here last year.  Did you ever sort out how to bleed ipv6 routes with vrf-lite oor did you have to use another solution like MPLS?


This Discussion