FAX issue with FXS port CME 7.1

Answered Question
Aug 5th, 2010
User Badges:

Hi,


I have a problem for receiving fax wich is connected to FXS port. I can make and received call but for fax something happen, the fax´s

display shows receiving and then stop, the calling received a busy message; also the port remains some seconds seized even though the call finished.


I have reviewied many post about FXS for fax but many differences between them.


My config  is the next



network-clock-participate wic 0

!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol pass-through g711ulaw
h323
modem passthrough nse codec g711ulaw

!
controller E1 0/0/0
framing NO-CRC4
ds0-group 1 timeslots 1-15 type r2-digital r2-compelled ani
cas-custom 1
  country telmex
  category 2
  answer-signal group-b 1
  caller-digits 4


voice-port 0/2/1
cptone MX
description FXS FAX 1190


dial-peer voice 112 pots
description FAX 1190
destination-pattern 1190
port 0/2/1


ROuter 2921, CME 7.1 , FXS card VIC3-2FXS/DID
c2900-universalk9-mz.SPA.150-1.M2.bin


there is something left , or should I change something??



regards

Correct Answer by Christopher Graham about 6 years 8 months ago

This looks like a bug: CSCtc98074


Try configuring the following:


voice service pots

fax rate disable


voice service voip

fax protocol none


This will prevent Cisco Fax Relay from being invoked (enabled by default), and will force modem passthrough.  Give this a whirl.


Out of curiosity, is the disconnect cause value of the failed faxes 172?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Michael Hanes Fri, 08/06/2010 - 06:54
User Badges:
  • Cisco Employee,

Without knowing the full topology and call flow, it is hard to know what the exact problem is. From your initial description it seems that the problem is receiving faxes on a FXS port. Where is the call being originated from and what is the configuration of that other voice gateway? Or is the call coming in from a SIP trunk? Can you fill in the gap in the topology?


Originating Fax----------????????---------------2921-----------------Fax machine

                                                      IP          FXS


If another voice gateway is involved, what is its configuration?


In your 2921 configuration, you have both modem passthrough and fax pass-through configured under voice service voip. Which one do you want to use? Both transport fax calls using the G.711 codec but fax pass-through performs the switchover using the H.323 or SIP call control while modem passthrough uses NSE messages. The first step I would take in resolving this issue would be to decide on either fax pass-through or modem passthrough as your fax transport and then make sure the originating side is configured the same.


Regards,

David

filiberto.aguirre Fri, 08/06/2010 - 08:42
User Badges:

Hi David,


thanks for your comments.


the call is from PSTN, there is no another gateway.


thanks for your time


regards

Michael Hanes Fri, 08/06/2010 - 12:25
User Badges:
  • Cisco Employee,

OK, so this is your topology then -


Fax Machine------------PSTN------------2921------------------Fax Machine

                                            E1     FXS 0/2/1


Does this look correct? Is the E1 port on the 2921 your PSTN connection? This type of configuration is sometimes referred to as a "hairpin call" as you are simply connecting two POTS ports together. Depending on the configuration and how your clock domains are configured, this can cause problems for fax calls as clock slips could be present. These clock slips are usually not noticeable on voice calls. Can you provide a "show network-clocks" from this voice gateway? Ideally, you would want your E1 and FXS port to be part of the same clocking domain with the E1 clocking your TDM backplane.


-David

filiberto.aguirre Fri, 08/06/2010 - 12:59
User Badges:

hi David,


I send the file with the main config of CME.  I set a debug and I received the following error when I try to send fax


CME#
Aug  6 19:35:02.799: %FLEXDSPRM-5-OUT_OF_RESOURCES: No dsps found either locally
or globally.


I reduce the conference and transcoding to minimun but still same error. I have a PVDM3-64 it should be enough  I guess.  I have IOS c2900-universalk9-mz.SPA.150-1.M2.bin and  I thinking to upgrade to c2900-universalk9-mz.SPA.150-1.M3.bin.


I do not what else to do


regards for you time once

Attachment: 
paolo bevilacqua Sat, 08/07/2010 - 05:21
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Configure:


network-clock-select 1 e1 0/0/0

paolo bevilacqua Sat, 08/07/2010 - 08:00
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Lower fax speed.

Correct Answer
Christopher Graham Sat, 08/07/2010 - 07:11
User Badges:
  • Cisco Employee,

This looks like a bug: CSCtc98074


Try configuring the following:


voice service pots

fax rate disable


voice service voip

fax protocol none


This will prevent Cisco Fax Relay from being invoked (enabled by default), and will force modem passthrough.  Give this a whirl.


Out of curiosity, is the disconnect cause value of the failed faxes 172?

filiberto.aguirre Sat, 08/07/2010 - 08:35
User Badges:

Hi,


I read the other post about change version in fact the orginal version  was c2900-universalk9-mz.SPA.150-1.M2.bin, then I changed to M3, but the problems remains.


i will check the disconnect value.


I will try the commands you recommend

thanks


filiberto.aguirre Mon, 08/09/2010 - 10:09
User Badges:

Hi,



after applying the commands you recommended the problem was cleared.


thanks a lot for your help


ragards

etmarcof Sat, 03/12/2011 - 17:31
User Badges:

Hi,


I think i'm having same problem. (I'm seeing in dialpeer disconnect cause :" dsp error (172)")

Did you solve problem with following commands? :


voice service voip

fax rate disable

fax protocol none

modem passthrough nse codec g711alaw



Thanks

MC

filiberto.aguirre Sat, 03/12/2011 - 18:21
User Badges:

Hi etmarcof


If you are having the same issue you should try those commands as Christoper recommended


voice service pots
fax rate disable
!
voice service voip
fax protocol none
!
!

In my case they solved my problem.


regards

etmarcof Sun, 03/13/2011 - 14:39
User Badges:

Hi Filiberto,

Thanks for your quick answer.


Did you also configured following?


voice-card 0

no local-bypass


Best Regards

MC

filiberto.aguirre Sun, 03/13/2011 - 20:16
User Badges:

Hi etmarcof


In my case I did not configure the commands;


voice-card 0

no local-bypass



my config for voice-card 0 is



voice-card 0
dspfarm
dsp services dspfarm



regards,

meeiling.tan Sun, 02/19/2012 - 01:11
User Badges:

Hi Filiberto,


From your attached configuration file, I found out you didn't configure voice port in your dial-peer


dial-peer voice 112 pots

description FAX 1190

destination-pattern 1190  --------------->faX NUMBER


If follow your description in your configuration you should configure a voice port in this dial-peer as below:


dial-peer voice 112 pots

description FAX 1190

destination-pattern 1190

port 0/2/1



Regards

Actions

This Discussion