Upgrade Frameware

Answered Question
Aug 6th, 2010
User Badges:

I am a new user for LMS 3.2

i have to issue to do but i don't know how


1 - I want to Upgrade the Frameware of my switch from the LMS, there are any configurations needed on the Switch?? and how i can Upgraded them?

2 - I want to Backup the Swtich configurations to my Hard disk, how i can do this?

Correct Answer by Joe Clarke about 6 years 8 months ago

Uncheck all of the boxes except "Include Cisco.com images for image recommendation" and you should be set.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Sat, 08/07/2010 - 10:48
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

For performing software upgrades using the Software Image Management feature of RME, see http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_resource_manager_essentials/4.3/user/guide/swmgt.html .  To make sure your devices have the proper configuration for doing software upgrades, see http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_resource_manager_essentials/4.3/user/guide/swmgt.html#wp1313744 .


RME will automatically archive the configurations from your devices as soon as it manages them.  To make sure this happens, you need to have correct credentials for the devices in the Device Credential Repository.  You must have at least an SNMP read-write credential configured or telnet/SSH usernames and passwords.  More details on configuration archive management can be found at http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_resource_manager_essentials/4.3/user/guide/config.html .

alouchi933 Mon, 08/09/2010 - 04:25
User Badges:

ok, i try to create step by step


first i setup the user name and password in cisco.com user Account Setup in picture 1

second i try to upgrade knowledge base, i get the message in pictures 2 and 3

i can't go to the step 2

then i add a Software Repository Management for one off my switch, i downloaded all is fine in picture 4

then i configure my switch, i create rcp and i configure all traps and community, and i modify the system preferences with cwuser created in rcp

finally wen i go to software distribution i select the device, i get this result in picture 8



i have some miss configurations?? what is the problem??

Attachment: 
alouchi933 Mon, 08/09/2010 - 07:20
User Badges:


Another problem bring up i have an error when i communicate with my switch,

i check the configuration of SNMP, it's Read and Wright (RW)


i can view the configurations changed in RME, it's updated normally,

i can get all syslog


but the devices are Unreachable in picture 1

and i can't open ciscoview i picture 2

i don't understand, the problem is with the communications!!!

NB: i can connect via telnet

Attachment: 
Joe Clarke Sat, 08/14/2010 - 12:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Start a new thread for this issue.

Joe Clarke Sat, 08/14/2010 - 12:22
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Post a screenshot of RME > Admin > Software Mgmt > View/Edit Preferences and the swim_debug.log.

Correct Answer
Joe Clarke Sun, 08/15/2010 - 23:52
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Uncheck all of the boxes except "Include Cisco.com images for image recommendation" and you should be set.

Actions

This Discussion