7942 not registering

Unanswered Question
Aug 8th, 2010

Hi,

I have 7942 ipphone, which keep shows upgrading after factory reset, but unable to download the firmware load from cucm tftp. could any body knows how to fix it. My cucm is 7.0.2.below is my load info for 7942

Cisco 7942SCCP

Any clues for the fix??????????? tftp is reachable, otherwise many phones will behave the same way!!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kusatija Sun, 08/08/2010 - 03:07

hello!

Are there any other 7942 in the network which registered fine?

Did u try to factory reset the phone? (plug out the phone, plug it back in, hold the # key, wait for line button lines to go amber, unhold the # key, hit 123456789*0# )

The phone gets an IP right? so browse the IP address in ie, and see what is the boat load id and the application load id on the phones.

might need a step upgrade, if the application load id is 8-3-3 or lower, try to upgrade to 8-5-2 and then the 8-5-2SR1.

If this does not help:

provide the following:

1. sniffer from the phone while trying to upgrade.

2. Screen shot of the device page of the phone which you browsed from ie.

HTH

kunal

sohaildxbfze Sun, 08/08/2010 - 21:57

Hi Kunal, thx for reply

I have 149 nos. of 7942 ipphones. One of them was registered earlier & taken off. When I plugged it again it went to endless "term42.default" load upgrade.

then i resetted it to factory default but same outcome popped-up.

I am unable to reach beyond that upgrade, rest of the phones are working fine with factory reset (like 7940,7941,7961,7960,7945,7985).

the load i have for 7942 is "SCCP42.8-5-2SR1S.loads". I cant tell you app/boot load id as phones doesn go beyond upgrade. keeps showing "dot inside a circle" on bottom left corner of screen. So as sniffer & snapshot is not possible.

Can you please tell me the steps where to start from. which load iamge should i download.

One more thing i havent checked resetting another 7942 to factory defaults in order to check the behavior.

kusatija Mon, 08/09/2010 - 01:33

hey Sohail.

I dint understand why a sniffer is not possible! coz, all you need to do is put a laptop or PC on the PC port while its trying to upgrade, and  run wire shark on it, so what i would suggest is to put a laptop on the PC port of the phone, run wireshark, plug out the phone, and plug it back in, this way the phone would go through its boot up sequence, and we would be able to see in the sniffers, wats goin on with the phone.

To go for an step upgrade please put cmterm-7942_7962-sccp.8-5-2.cop.sgn file on the call manager (all servers), heres the link to download the firmware:

http://tools.cisco.com/support/downloads/go/ImageList.x?relVer=8.5%282%29&mdfid=281346593&sftType=Skinny+Client+Control+Protocol+%28SCCP%29+Software&optPlat=&nodecount=14&edesignator=null&modelName=Cisco+Unified+IP+Phone+7942G&treeMdfId=278875240&modifmdfid=&imname=&treeName=Voice+and+Unified+Communications&hybrid=Y&imst=N

ones the firmware is on the call manager, and you can see it in the device defaults for the phone, restart the tftp services, and then try registering it agian.

Regarding the application load, i did not understand, if the phone gets an IP or not? is there no way to check, may be on the switch?

If you get the IP, please put the IP in a browser as https:// and you should be able to see the load.

the step upgrade to 8-5-2 should help, If upgrading to the 8-5-2 load does not help, n we are unable to get a sniffer, i would suggest you to open a TAC case, it will be much easier to troubleshoot if we have access to the system.

Cheers!

Kunal

sohaildxbfze Mon, 08/09/2010 - 03:23

hi kunal,

7942 phone gets ip, & i tried to put it in browser ,, but phone restarts too quickly. for wireshark i got the capture.

also from cucm>admin os>tftp file mgmt>........... i can find below loads for 42

SCCP42.8-4-3S.loads/
SCCP42.8-5-2SR1S.loads

&

term42.default.loads

I took another 7942 phone which was also registered earlier & taken off after that. when i plugged it , it showed @ time of registration AUTH fail,, but got registered with cucm & got same old dn.

the firmware u r suggesting , will it help to overcome this poblem or is it already uloaded on the server as i mentioned above.

also m not getting any tftp record in wireshark for faulty 7942 , but for the one that is working with AUTH fail,, m getting two records for TFTP.

511    43.546410    10.251.3.97    255.255.255.255    TFTP    Read Request, File: English_United_States/mk-sccp.jar\000, Transfer type: octet\000

517    44.355810    10.251.3.97    255.255.255.255    TFTP    Read Request, File: United_States/g3-tones.xml\000, Transfer type: octet\000

sohaildxbfze Mon, 08/09/2010 - 03:28

also wanted to add the app load as below for the 7942 that works with AUTH FAIL

App Load IDjar42sccp.8-3-1-22.sbn
Boot Load IDtnp42.8-3-1-21a.bin

Actions

This Discussion