After router copy flash: ftp:// ;Byte size of .bin file in flash: differs from byte size on ftp server, but no errors?

Unanswered Question
Aug 8th, 2010
User Badges:

Doing router maintenance upgrades.  Before downloading the new bin file images on the router I copy up the existing image to the ftp server just to make sure the connection is good and transmission is solid.  Today after doing a sh flash:, I copied up an image from the router with the following commands:


OCEA01SANFVR1#sh flash:
-#- --length-- -----date/time------ path
1     34191888 May 31 2008 14:27:40 -04:00 c2800nm-spservicesk9-mz.124-13f.bin

29818880 bytes available (34193408 bytes used)


OCEA01SANFVR1#copy flash:c2800nm-spservicesk9-mz.124-13f.bin ftp://10.151.190.7
Address or name of remote host [10.151.190.7]?
Destination filename [c2800nm-spservicesk9-mz.124-13f.bin]?
Writing c2800nm-spservicesk9-mz.124-13f.bin !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
34191888 bytes copied in 198.364 secs (172369 bytes/sec)


Image copies up to ftp server (3CDaemon) without any errors, but when I check the byte size of the .bin on the server it differs from the byte size in the router's flash:.  Properties on the server file shows 34,164,736 bytes ??  No errors on any interface in the transfer path?  The copy from the router is being done over a frame relay.  This is when I get the file size difference.  Tried ftp copy from other remote routers with different .bin files and got same result.

        Copying and image from a router on the LAN to the same ftp server on the LAN and files sizes match up??  Removed QOS and frame-relay map class from both ends and still there is a difference in file size, but no errors and no invalid checksum.  The diference in the files on either end seems to be about 27,000 bytes but never the same exact byte difference.  Anyone ever see this behavior before??


Thanks in advance,

Tonyc

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vragotha Sun, 08/08/2010 - 11:05
User Badges:
  • Silver, 250 points or more

Hi,

   Are you seeing the same issue if you use TFTP over the WAN link?

tcekada Sun, 08/08/2010 - 13:26
User Badges:

Vijay,

Good question.  Just tried tftpd32 which allows you to copy images larger than the 32Mb via tftp and the file sizes matched up perfectly.  So it seems it occurs when I use 3cdaemon ftp.   Any idea why?


Thanks,

manju.cisco Thu, 07/21/2011 - 04:25
User Badges:
  • Bronze, 100 points or more

Hi Tcekada,


I have found similar issues during past. I did notice size differences like you did.

Even then i used the file and upgraded the IOS and upgrade was successful.


Even when the file size are different, you can make sure the file is proper by verifying the md5 value. If the value matches then there is nothing wrong.




Thanks.

Actions

This Discussion

Related Content