CUE Dutch language on UC560 v8.0

Unanswered Question
Aug 9th, 2010

Hello is there someone who can tell me on how to install the Dutch language on the CUE.

- Placing all localization files on right place before running Telephony Wizard does not work

- Software upgrade doesnt work also (no Dutch language listed although I have the lang file in the same directory as the main file, btw when is someone changing the helpfile on this topic, it refers to an -ise- instead of the main file ???)

- Voicemail upgrade doesnt work either.

- FTP install on the CUE, nana... wrong package error....

Why does the CUE install have to be so hard. Every UC box costs me an extra day to configure just because the CUE localization is way below standards. Cisco fix this please !!!!!!!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Alberto Montilla Mon, 08/09/2010 - 10:24

Dear Sir;

Which CCA version are you using? CUE localization should go ok with CCA 2.2(4), provided you have the right files. Link below. UC 560 CUE Localization Software


Marcel Tempelman Mon, 08/09/2010 - 10:47

Thx for the reply

I use these files (i will include every file):


- CME-locale-nl_NL-Dutch-

- cue-vm-nl_NL-langpack.uc560.7.1.3.prt1

I extracted from the UC zipfile.

I am using CCA 2.2.4 now. Did the initial install with 2.2.2.

Is it possible that someone can give me a step by step explanation how to go from a virgin UC to a localized one with a config using the wizard (dont need tweaks, this is good enough). Most of the documentation is CME-based and will not in every situation work for the UC and not all the documentation is always properly updated for the newer versions.

antyeung Mon, 08/09/2010 - 11:03


To change the CUE language locale you need to place the CUE langpack in  the same directory as the cue-main.uc500.x.x.x.pkg, which requires you  to unzip the SWP and also the file In CCA you  would go to Maintenance > Software Upgrade > Upgrade Settings and  select the CUE radio button along w/ the language you want to change to.  The image file that you need to browse to is the  cue-main.uc500.x.x.x.pkg file and not the cue langpack file. The error  message is misleading and our engineering team is working on changing it  in future CCA versions.


Can you try the above?

Anthony Yeung
Technical Marketing Engineer
Small Business Technolog Group

antyeung Mon, 08/09/2010 - 11:40

The 560 files are the right ones to use. Were you still not able to localize CUE with the posted directions?

Anthony Yeung
Technical Marketing Engineer
Small Business Technolog Group

Marcel Tempelman Mon, 08/09/2010 - 11:47

Sorry it will not work. When I follow the last steps, the Dutch language disappears from the drop down

list after selecting the cue-main file.

antyeung Mon, 08/09/2010 - 11:55

I just noticed that I have the same problem in the lab. Let me investigate this issue and I'll get back to you.

Anthony Yeung
Technical Marketing Engineer
Small Business Technolog Group

Marcel Tempelman Mon, 08/09/2010 - 11:59

Thx for the effort ! Nothing personal but battling these CUE localization issues becomes very frustrating. I hope that there will be an end-all language package which you kinda plugin in CCA (menu option !)  before installation of the UC. This will save loads of time and lots of frustrations.

Hope to hear from you soon !

antyeung Mon, 08/09/2010 - 12:43

NP. Since you mentioned it there are plans to improve the localization process in future CCA releases. At the moment when you localize CUE you go through the upgrade process to change the language. Instead we plan to optimize this task by only changing the CUE language without going through the upgrade process. Also, we will slowly start bundling the individual locale files w/ the SWP so that you won't have to do any file management like unzipping files to change the locale.

Anthony Yeung
Technical Marketing Engineer
Small Business Technolog Group

Marcel Tempelman Wed, 08/11/2010 - 13:27

In the meantime I have upgraded the box to 8.02 because the B-ACD scripts crashed the machine. After the upgrade B-ACD worked as intended.

No effect on the CUE locale installtion though.

antyeung Thu, 08/12/2010 - 21:34

Hang in there. Just wanted to let you know we are still investigating this issue and we did not forget about you. :-)


Marcel Tempelman Fri, 08/13/2010 - 00:46

Still there and waiting :-) In the meantime the client is up and running now (with US VM).

antyeung Fri, 08/13/2010 - 11:20

We identified that this is a problem in CCA. We'll see what we can do to get this fixed in CCA 3.0.

In the mean time you'll have to use OOB methods to switch the CUE locale.



Marcel Tempelman Sat, 08/14/2010 - 13:38

Hi Anthony,

In the mean time you'll have to use OOB methods to switch the CUE locale.

Could you be more specific on this ? Currently I don't see any option to get the Dutch language loaded on the CUE.

Hopefully it will be fixed earlier than v3.0 because localization is very important when selling an UC solution, otherwise we have to keep on selling UC520s because they can run v7.x which can have a localized CUE.

antyeung Sun, 08/15/2010 - 18:59

We're doing our best to see if we can fix this sooner. I'll keep this thread posted.

Do you have the same problem in CCA for the UC520? If not, what SWP and CCA version are you using?

I tested in my lab and I have the same problem w/ the UC520 as well.

Thanks for your patience with this.


Marcel Tempelman Mon, 08/16/2010 - 02:42

Hello Anthony,

it's been a while since I've configed a 520 but when I tried then I didn't get the Dutch option also. Must say that I didn't pay much attention to it at that time. I had been fighting the CUE localization problems (v7.04) and this was a test to see if v8.0 would solve things. In the end I got everything running with v7.03.

There's one questing nagging me and don't know if you can answer this but who tests these packages ? I think it's strange that we run into this problem almost a half year after the launch of the new UC range. With the UC 520 I had to manually change a textfile in the CUE package because it refered to the wrong files.

We don't sell UCs in high volumes (we do UC, CME and CUCM) and it's a great product when it's up and running but we've encountered so many problems getting it there. I'd rather drop half the features just to get a decent painless initial configuration.

Nonetheless Anthony thanks for the effort for so far. You've been very helpful and plz keep me updated.

antyeung Mon, 08/16/2010 - 23:33

I was testing this in the lab more to understand the scope of this problem and I was able to get the Dutch language option when I use any Software Pack that's bundled with CUE 7.0.3 and CUE 7.1.3.

Can you specify the SWP and CUE version you are using when you don't get the Dutch language?

"I had been fighting the CUE localization problems (v7.04) and this was a  test to see if v8.0 would solve things. In the end I got everything  running with v7.03."

Are you refering to the CUE version when you mention v.7.0.4?

When I said I was able to reproduce this before I was using a pre-release of SWP 8.0.4 which is not yet made available for general distribution. Our development is working hard to fix this for the next release. But I'm curious now what SWP version and CUE version you are using when you don't get the Dutch language option since I'm not able to reproduce your issue w/ CUE 7.0.3 or CUE 7.1.3.



Marcel Tempelman Tue, 08/17/2010 - 00:58

Hello Anthony,

What I remember is the following:


7.04 UC + 7.03 CUE didn't work or at least I didn't get it installed

8.0 UC + 7.1.3 CUE didn't give me the Dutch option (like we see now)

7.03 UC + 7.03 CUE gave me a working combo.

Must say that i spent 1,5 day to discover the right combination and  didn't have time to investigate why things were failing.

The UC560 which i installed last week is running 8.0.2 with 7.1.3 CUE, installed with CCA 2.2.2 and 2.2.4 (8.0.2 update).

Thanks for the effort for so far.


antyeung Tue, 08/17/2010 - 01:15

Hi Marcel,

Not a problem. Whatever it takes to get you up and running. :-)

When you refer to  7.04/8.0/7.0.3 UC version do you mean Software Pack Version?

The languages that are available in the drop down is dependent on the CUE version not so much on the Software Pack version. To be even more specific the languages that get populated in the drop down depend on the version in the filename of cue-main.uc500.X.X.X.pkg where X.X.X is the CUE version. When you go to Maintenance > Software Upgrade  and select the CUE radio button you select the file cue-main.uc500.X.X.X.pkg. At this point CCA reads the version information from this file. I did a quick test (not recommended) by renaming the cue-main file to  cue-main.uc500.7.1.3.pkg had CCA browse this file and open it and Dutch was an available language in the drop down box. Then I renamed cue-main.uc500.7.1.3.pkg to cue-main.uc500.7.0.3.pkg and did the same exercise browsing to this file and opening it up in CCA and Dutch again was an available option.

On your UC520 can you take CUE version 7.0.3 or 7.1.3 and go to Maintenance > Software Upgrade, select the CUE radio button, then browse and open cue-main.uc500.7.0.3.pkg or cue-main.uc500.7.1.3.pkg and check to see if the Dutch is an available language option?

I just want to make sure that I'm trying to reproduce the same problem that you have.



Marcel Tempelman Tue, 08/17/2010 - 06:11

Hi Anthony,

here's an attachment with CCA screenshots. The UC520 is located at the client site but VPN will get you there :-)

In both cases 7.03/7.1.3 CUE-main the Dutch option was available.

When I had installed UC package 7.0.4 I had troubles with uploading the CUE localization package. This could also be an CCA-bug (I believe I was using 2.2.1).

The machine has a more recent IOS because I had to test something and had to be sure it was not an IOS bug.

This machine works fine at the moment. My main problem is currently the UC560.

Here's also a directory listing of the flash:

Directory of flash:/

    1  -rw-       58001  Apr 20 2010 08:28:44 +02:00  7921-dictionary.xml
    2  -rw-      137616  Apr 20 2010 08:28:46 +02:00  7921-font.dat
    3  -rw-        1902  Apr 20 2010 08:28:46 +02:00  7921-kate.utf-8.xml
    4  -rw-        1828  Apr 20 2010 08:28:46 +02:00  7921-kate.xml
    5  drw-           0  Apr 20 2010 08:28:46 +02:00  autoattendant
    9  drw-           0  Apr 20 2010 08:28:48 +02:00  bacdprompts
   22  -rw-       61645  Apr 20 2010 08:28:56 +02:00  be-sccp.jar
   23  drw-           0  Apr 20 2010 08:28:56 +02:00  cca
   27  -rw-         224  Apr 20 2010 08:28:58 +02:00  CME-locale-nl_NL-Dutch-
   28  -rw-       48885  Apr 20 2010 08:28:58 +02:00  config-prefirewall-9-4-2010.conf
   29  drw-           0  Apr 20 2010 08:28:58 +02:00  Desktops
   48  -rw-        1182  Apr 20 2010 08:29:06 +02:00  g3-tones.xml
   49  -rw-       74676  Apr 20 2010 08:29:06 +02:00  gp-sccp.jar
   50  drw-           0  Apr 20 2010 08:29:06 +02:00  gui
   72  -rw-       61706  Apr 20 2010 08:29:20 +02:00  ipc-sccp.jar
   73  drw-           0  Apr 20 2010 08:29:20 +02:00  its
  214  drw-           0  Apr 20 2010 08:30:00 +02:00  media
  217  -rw-       61472  Apr 20 2010 08:30:06 +02:00  mk-sccp.jar
  218  drw-           0  Apr 20 2010 08:30:06 +02:00  phones
  314  drw-           0  Apr 20 2010 08:36:14 +02:00  ringtones
  348  drw-           0  Apr 20 2010 08:36:24 +02:00  sn
  351  -rw-       71518  Apr 20 2010 08:36:26 +02:00  tc-sccp.jar
  352  -rw-       61706  Apr 20 2010 08:36:26 +02:00  td-sccp.jar
  353  -rw-    28064464  Apr 20 2010 08:38:06 +02:00  uc500-advipservicesk9-mz.124-20.T2
  354  -rw-       23043  Apr 20 2010 08:38:06 +02:00  UC520-24U-4BRI-K9-factory-7.0.3.cfg
  355  -rw-         720  Apr 20 2010 08:41:22 +02:00  vlan.dat
  356  -rw-         200  Apr 28 2010 14:30:04 +02:00  speeddial.xml
  357  -rw-    30109824  Apr 28 2010 17:03:16 +02:00  uc500-advipservicesk9-mz.124-22.YB5.bin
  358  -rw-       51046  Apr 28 2010 21:20:02 +02:00  28-4-2010-2119.conf

2048491520 bytes total (1883144192 bytes free)

antyeung Tue, 08/17/2010 - 13:22

Thanks for the screenshot. If you use the UC package (Software Pack) 7.0.4 you should still be able to get the Dutch language option since it has CUE 7.1.3. The problem should be independent of the platform (UC520/540/560).

Are you still able to reproduce this issue for any existing SWP other than 8.0.3 and 8.0.4?

I just received an update from our BU and they were squeeze the fix in the next CCA release 2.2.5, which should be released this week. Thanks for bringing this to our attention.



Marcel Tempelman Wed, 08/18/2010 - 23:07

Hi Anthony,

Do you want to me to test it with an UC520 or with the UC560 which started this. We have UC520 in our lab but time is lacking at the moment to do some decent testing. If the fix is there and I'm at the clientsite to install the Dutch voice files I'll do some tests. Great to hear that a fix is coming !


antyeung Fri, 08/20/2010 - 16:09

Hi Marcel,

Any platform is fine - UC520/40/60. The fix is in the CCA 2.2.5 release. If you run into any problems I would be glad to look at it.



Marcel Tempelman Fri, 08/20/2010 - 23:39

Hi Anthony,

I'm glad to report that CCA 2.2.5, UC804 and the 802 Dutch vm-files are a working combo ! I have a UC520W-16 for testing purposes at home and I have tried the installation last night and except for 2 minor glitches every thing worked fine !

The 2 minor glitches were:

- CCA hangs on the licence agreement first time after installing

Kill CCA process and restart

- CCA doesn't find B-ACD files on the flashcard

Drag and drop cme-bacd- on the UC and all is fine again

Thanks for helping to fix this !

antyeung Sat, 08/21/2010 - 08:54

Hi Marcel, I'm glad to hear everything works out for you.

For the other issues may I ask you to start a separate forum post so we can keep the issue separate? I would like to get more information about your other problems to see if it's something we need to fix.

Thank you for your feedback and patience on this issue.


Marcel Tempelman Tue, 08/24/2010 - 05:51

Just to confirm:

- UC520

- CCA 2.2.5

- SWP 8.02

- CUE 7.1.3 lang package NL

Dutch langauge is currently being installed :-). Ik will make another thread for the installation glitches.



antyeung Tue, 08/24/2010 - 08:18


One minor thing - SWP 8.0.4 is packaged w/ CUE 8.0.2. When you upgraded to SWP 8.0.4 did you opt-out for upgrading CUE to 8.0.2?



Marcel Tempelman Sun, 08/29/2010 - 09:32


in my tests I haven't skipped the CUE upgrade more because I was interested in seeing the new version. Will come on my path soon and then I'll let you know.



antyeung Mon, 08/30/2010 - 00:03

Can you verify the CUE version that's on your UC500 then? It should have CUE 8.0.2 and not CUE 7.1.3.


Marcel Tempelman Wed, 09/15/2010 - 02:50

Hmmmm back to square one. The bug still persists when trying to install 7.13 NL CUE - files on a 560 box. Gonna try 8.04.


8.04 isn't giving me Dutch as an option also.......

All tests on UC 520s went fine and now i'm at the client site (don't have a 560 at our office) and discovered it does not work.....

Marcel Tempelman Wed, 09/15/2010 - 08:54

Hi Anthony,

I used cue-main.uc560.7.1.3.pkg. See the screenshots. I've used the same laptop and same CCA (2.2.5) with which I tested the installations on the UC 520s. If I select the UC520 packages the Dutch language appears. It seems it's still a problem in the packages for the UC560.


antyeung Sun, 09/19/2010 - 21:35

Let me check up on this with our BU and get back to you.

Marcel Tempelman Wed, 09/29/2010 - 03:41

Hi Anthony,

I've made this issue "official" (the supportcontract registration of the customer was ready) and made a call to Small Business Support. They gave me the "go to CLI option"although I had encountered problems with that before I gave it another try.... and it worked:-)

se-10-1-10-1# software install add url ftp://{ip-address}/cue-vm-langpack.uc560.7.1.3.pkg username cisco pass cisco

This one got the Dutch language working. Don't know why I got "wrong package error"in earlier tries.

Anyway the pressure is gone now, customer happy with a Dutch localized CUE and I know what to do in the meantime till CCA 3.0 hits the streets. Thanks for your effort !




This Discussion