FXO is not disconnect

Unanswered Question
Aug 10th, 2010

Hi,

actually I have 2 Question.

1 - I have cisco cme with 6FXO lines when some one call the extension and no body answer I hang up the line but the fxo port keep on busy status for 55 sec after that it will release.

here is the configuration file.

no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp pool vlan1
   network 10.150.153.0 255.255.255.0
   default-router 10.150.153.100
!
ip dhcp pool vlan2
   network 10.150.154.0 255.255.255.0
   default-router 10.150.154.100
   option 150 ip 10.150.153.100
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
!
license udi pid CISCO2921/K9 sn FHK1423F08P
hw-module ism 0
!
hw-module pvdm 0/0
!
hw-module sm 1
!
!
!
!
redundancy
!
!
!
track 1 ip sla 1 reachability
!
!
!
!
!
!
!
interface Tunnel23
description grd tunnel to customer's main site
ip address 192.168.168.90 255.255.255.252
ip mtu 1492
tunnel source 172.31.2.214
tunnel destination 172.31.155.86
!
!
interface GigabitEthernet0/0
description lan interface to customer site network
no ip address
duplex auto
speed auto
!
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
ip address 10.150.153.100 255.255.255.0
!
interface GigabitEthernet0/0.2
encapsulation dot1Q 2
ip address 10.150.154.100 255.255.255.0
!
interface ISM0/0
ip unnumbered GigabitEthernet0/0.1
service-module ip address 10.150.153.101 255.255.255.0
!Application: CUE Running on ISM
service-module ip default-gateway 10.150.153.100
!
!
interface ISM0/1
no ip address
!
!
interface GigabitEthernet0/1
description wan interface to mpls network circuit id jeda05-00-427-jeda05-00-427 ip3
ip address 172.31.2.214 255.255.255.252
duplex auto
speed auto
!
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
!
interface Serial0/0/0
no ip address
shutdown
clock rate 2000000
!
!
interface Integrated-Service-Engine1/0
no ip address
shutdown
!Application: Restarted at Fri May  5 01:33:58 2006
no keepalive
!
!
router bgp 64519
no synchronization
bgp log-neighbor-changes
neighbor 172.31.2.213 remote-as 65000
neighbor 172.31.2.213 description MPLS PE
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Tunnel23 track 1
ip route 10.150.153.101 255.255.255.255 ISM0/0
!
ip sla 1
icmp-echo 192.168.168.89 source-ip 172.31.2.214
threshold 2000
ip sla schedule 1 life forever start-time now
!
!
!
!
!
!
control-plane
!
!
!
voice-port 0/1/0
connection plar opx 4300
caller-id enable
!
voice-port 0/1/1
connection plar opx 4300
caller-id enable
!
voice-port 0/1/2
connection plar opx 4300
caller-id enable
!
voice-port 0/1/3
connection plar opx 4300
caller-id enable
!
voice-port 0/2/0
connection plar opx 4300
caller-id enable
!
voice-port 0/2/1
connection plar opx 4300
caller-id enable
!
voice-port 0/2/2
!
voice-port 0/2/3
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
!
!
!
dial-peer cor custom
name Local
name Mobile
name National
name International
!
!
dial-peer cor list Local
member Local
!
dial-peer cor list Mobile
member Local
member Mobile
!
dial-peer cor list National
member Local
member Mobile
member National
!
dial-peer cor list International
member Local
member Mobile
member National
member International
!
!
dial-peer voice 10 pots
destination-pattern 9[26]......
port 0/1/0
forward-digits 7
!
dial-peer voice 11 pots
preference 1
destination-pattern 9[26]......
port 0/1/1
forward-digits 7
!
dial-peer voice 12 pots
preference 2
destination-pattern 9[26]......
port 0/1/2
forward-digits 7
!
dial-peer voice 13 pots
preference 3
destination-pattern 9[26]......
port 0/1/3
forward-digits 7
!
dial-peer voice 14 pots
preference 4
destination-pattern 9[26]......
port 0/2/0
forward-digits 7
!
dial-peer voice 15 pots
preference 5
destination-pattern 9[26]......
port 0/2/1
forward-digits 7
!
dial-peer voice 22 pots
destination-pattern 905........
port 0/1/0
forward-digits 10
!
dial-peer voice 23 pots
preference 1
destination-pattern 905........
port 0/1/1
forward-digits 10
!
dial-peer voice 24 pots
preference 2
destination-pattern 905........
port 0/1/2
forward-digits 10
!
dial-peer voice 25 pots
preference 3
destination-pattern 905........
port 0/1/3
forward-digits 10
!
dial-peer voice 26 pots
preference 4
destination-pattern 905........
port 0/2/0
forward-digits 10
!
dial-peer voice 27 pots
preference 5
destination-pattern 905........
port 0/2/1
forward-digits 10
!
dial-peer voice 34 pots
destination-pattern 90[^05].......
port 0/1/0
forward-digits 9
!
dial-peer voice 35 pots
preference 1
destination-pattern 90[^05].......
port 0/1/1
forward-digits 9
!
dial-peer voice 36 pots
preference 2
destination-pattern 90[^05].......
port 0/1/2
forward-digits 9
!
dial-peer voice 37 pots
preference 3
destination-pattern 90[^05].......
port 0/1/3
forward-digits 9
!
dial-peer voice 38 pots
preference 4
destination-pattern 90[^05].......
port 0/2/0
forward-digits 9
!
dial-peer voice 39 pots
preference 5
destination-pattern 90[^05].......
port 0/2/1
forward-digits 9
!
dial-peer voice 46 pots
destination-pattern 99[^2].
port 0/1/0
forward-digits 3
!
dial-peer voice 47 pots
preference 1
destination-pattern 99[^2].
port 0/1/1
forward-digits 3
!
dial-peer voice 48 pots
preference 2
destination-pattern 99[^2].
port 0/1/2
forward-digits 3
!
dial-peer voice 49 pots
preference 3
destination-pattern 99[^2].
port 0/1/3
forward-digits 3
!
dial-peer voice 50 pots
preference 4
destination-pattern 99[^2].
port 0/2/0
forward-digits 3
!
dial-peer voice 51 pots
preference 5
destination-pattern 99[^2].
port 0/2/1
forward-digits 3
!
dial-peer voice 58 pots
destination-pattern 99200.....
port 0/1/0
forward-digits 9
!
dial-peer voice 59 pots
preference 1
destination-pattern 99200.....
port 0/1/1
forward-digits 9
!
dial-peer voice 60 pots
preference 2
destination-pattern 99200.....
port 0/1/2
forward-digits 9
!
dial-peer voice 61 pots
preference 3
destination-pattern 99200.....
port 0/1/3
forward-digits 9
!
dial-peer voice 62 pots
preference 4
destination-pattern 99200.....
port 0/2/0
forward-digits 9
!
dial-peer voice 63 pots
preference 5
destination-pattern 99200.....
port 0/2/1
forward-digits 9
!
dial-peer voice 70 pots
destination-pattern 9800.......
port 0/1/0
forward-digits 10
!
dial-peer voice 71 pots
preference 1
destination-pattern 9800.......
port 0/1/1
forward-digits 10
!
dial-peer voice 72 pots
preference 2
destination-pattern 9800.......
port 0/1/2
forward-digits 10
!
dial-peer voice 73 pots
preference 3
destination-pattern 9800.......
port 0/1/3
forward-digits 10
!
dial-peer voice 74 pots
preference 4
destination-pattern 9800.......
port 0/2/0
forward-digits 10
!
dial-peer voice 75 pots
preference 5
destination-pattern 9800.......
port 0/2/1
forward-digits 10
!
dial-peer voice 82 pots
destination-pattern 900T
port 0/1/0
forward-digits all
!
dial-peer voice 83 pots
preference 1
destination-pattern 900T
port 0/1/1
forward-digits all
!
dial-peer voice 84 pots
preference 2
destination-pattern 900T
port 0/1/2
forward-digits all
!
dial-peer voice 85 pots
preference 3
destination-pattern 900T
port 0/1/3
forward-digits all
!
dial-peer voice 86 pots
preference 4
destination-pattern 900T
port 0/2/0
forward-digits all
!
dial-peer voice 87 pots
preference 5
destination-pattern 900T
port 0/2/1
forward-digits all
!
dial-peer voice 200 voip
destination-pattern 4...
session protocol sipv2
session target ipv4:10.150.153.101
dtmf-relay sip-notify
codec g711ulaw
no vad

2 - After creating a user mailbox and password in cue I left a message to the user but MWI is not functioning, here is the configuration,

telephony-service
no auto-reg-ephone
max-ephones 50
max-dn 50
ip source-address 10.150.153.100 port 2000
voicemail 4700
max-conferences 8 gain -6
web admin system name ncb password ncb
dn-webedit
time-webedit
transfer-system full-consult
create cnf-files version-stamp 7960 Jul 31 2010 13:02:25
!
!
ephone-template  1
conference admin
softkeys hold  Newcall Resume Select
softkeys idle  Redial Newcall Pickup ConfList RmLstC Cfwdall Login
softkeys seized  Redial Endcall Meetme Pickup Callback Cfwdall
softkeys alerting  Callback Endcall
softkeys connected  Hold Endcall Trnsfer Park Select Confrn ConfList RmLstC
softkeys ringing  Answer Dnd
!
!
ephone-template  2
conference admin
softkeys hold  Newcall Resume Select
softkeys idle  Redial Newcall Pickup ConfList RmLstC Cfwdall Login
softkeys seized  Redial Endcall Meetme Pickup Callback Cfwdall
softkeys alerting  Callback Endcall
softkeys connected  Hold Endcall Trnsfer Park Select Confrn ConfList RmLstC
softkeys ringing  Answer Dnd
type 7942
!
!
ephone-template  3
conference admin
softkeys hold  Newcall Resume Select
softkeys idle  Redial Newcall Pickup ConfList RmLstC Cfwdall Login
softkeys seized  Redial Endcall Meetme Pickup Callback Cfwdall
softkeys alerting  Callback Endcall
softkeys connected  Hold Endcall Trnsfer Park Select Confrn ConfList RmLstC
softkeys ringing  Answer Dnd
type 7945
!
!
ephone-dn  1  dual-line
number 4500
call-forward busy 4700
call-forward noan 4700 timeout 10
!
!
ephone-dn  2  dual-line
number 4501
!
!
ephone-dn  3  dual-line
number 4502
!
!
ephone-dn  4
number 4503
!
!
ephone-dn  5
number 4504
!
!
ephone-dn  6  dual-line
number 4505
!
!
ephone-dn  7  dual-line
number 4506
!
!
ephone-dn  8  dual-line
number 4507
!
!
ephone-dn  9  dual-line
number 4508
!
!
ephone-dn  10  dual-line
number 4509
!
!
ephone-dn  11  dual-line
number 4510
!
!
ephone-dn  12  dual-line
number 4511
!
!
ephone-dn  13  dual-line
number 4512
!
!
ephone-dn  30  dual-line
!
!
ephone-dn  49
number 8000....
mwi on
!
!
ephone-dn  50
number 8001....
mwi off
!
!
ephone  1
device-security-mode none
mac-address ACA0.16FD.2E05
ephone-template 2
type 7942
button  1:1
!
!
!
ephone  2
device-security-mode none
mac-address ACA0.16FD.2E3F
ephone-template 2
type 7942
button  1:2
!
!
!
ephone  3
device-security-mode none
mac-address ACA0.16FC.C273
ephone-template 2
type 7942
button  1:3
!
!
!
ephone  4
device-security-mode none
mac-address ACA0.16FD.4227
ephone-template 2
type 7942
button  1:4
!
!
!
ephone  5
device-security-mode none
mac-address ACA0.16FD.2DE8
ephone-template 2
type 7942
button  1:5
!
!
!
ephone  6
device-security-mode none
mac-address 1C17.D341.DBF9
ephone-template 3
type 7945
button  1:6
!
!
!
ephone  7
device-security-mode none
mac-address ACA0.166F.FB6C
ephone-template 2
type 7942
button  1:7
!
!
!
ephone  8
device-security-mode none
mac-address ACA0.16FD.2CF5
ephone-template 2
type 7942
button  1:8
!
!
!
ephone  9
device-security-mode none
mac-address ACA0.16FD.2F6C
ephone-template 2
type 7942
button  1:9
!
!
!
ephone  10
device-security-mode none
mac-address A8B1.D41F.4938
ephone-template 1
button  1:10
!
!
!
ephone  11
device-security-mode none
mac-address A8B1.D41F.053A
ephone-template 1
button  1:11
!
!
!
ephone  12
device-security-mode none
mac-address ACA0.16FD.AF38
button  1:12
!
!
!
ephone  13
device-security-mode none
mac-address A016.FDAF.3801
button  1:13
!
!
!
ephone  49
device-security-mode none
!
!
!
line con 0
line aux 0
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line 131
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
flowcontrol software
line vty 0 4
password ncb
login
!
scheduler allocate 20000 1000
end

Heraa-quickpay-router#serv
Heraa-quickpay-router#service-module is
Heraa-quickpay-router#service-module isM 0/0 sess
Heraa-quickpay-router#service-module isM 0/0 session
Trying 10.150.153.100, 2131 ... Open
se-10-150-153-101#
se-10-150-153-101# show run
Generating configuration:


clock timezone Asia/Riyadh

hostname se-10-150-153-101

line console

system language preferred "en_US"

ntp server 10.150.153.100 prefer

software download server url "ftp://127.0.0.1/ftp" credentials hidden "6u/dKTN/hsEuSAEfw40XlF2eFHnZfyUTSd8ZZNgd+Y9J3xlk2B35j0nfGWTYH
fmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmP"
site name local
site-hostname ncb
web credentials hidden "JIudzDaztgsvla6CC6+ltUnfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9
J3xlk2B35j0nfGWTYHfmP"
end site

license agent max-sessions 9

privilege ViewPrivateList create
privilege vm-imap create
privilege manage-users create
privilege ManagePrompts create
privilege local-broadcast create
privilege ManagePublicList create
privilege broadcast create
privilege manage-passwords create
privilege ViewHistoricalReports create
privilege ViewRealTimeReports create

groupname Broadcasters create

username ncb create
username Mohammed create

privilege ViewPrivateList description "Privilege to view private list"
privilege vm-imap description "Privilege to manage personal voicemail via IMAP client"
privilege manage-users description "Privilege to create, modify, and delete users and groups"
privilege ManagePrompts description "Privilege to create, modify, or delete system prompts"
privilege local-broadcast description "Privilege to send local broadcast messages"
privilege ManagePublicList description "Privilege to manage public lists"
privilege broadcast description "Privilege to send local or remote broadcast messages"
privilege manage-passwords description "Privilege to reset user passwords"
privilege ViewHistoricalReports description "Privilege to view historical reports"
privilege ViewRealTimeReports description "Privilege to view realtime reports"
privilege ViewPrivateList operation voicemail.lists.private.view
privilege vm-imap operation voicemail.imap.user
privilege manage-users operation user.configuration
privilege manage-users operation user.pin
privilege manage-users operation user.notification
privilege manage-users operation system.debug
privilege manage-users operation user.remote
privilege manage-users operation group.configuration
privilege manage-users operation user.password
privilege manage-users operation user.mailbox
privilege ManagePrompts operation system.debug
privilege ManagePrompts operation prompt.modify
privilege local-broadcast operation system.debug
privilege local-broadcast operation broadcast.local
privilege ManagePublicList operation system.debug
privilege ManagePublicList operation voicemail.lists.public
privilege broadcast operation system.debug
privilege broadcast operation broadcast.local
privilege broadcast operation broadcast.remote
privilege manage-passwords operation user.pin
privilege manage-passwords operation system.debug
privilege manage-passwords operation user.password
privilege ViewHistoricalReports operation report.historical.view
privilege ViewRealTimeReports operation report.realtime

groupname Administrators member ncb
groupname Broadcasters privilege broadcast

username Mohammed phonenumber "4500"

restriction msg-notification create
restriction msg-notification min-digits 1
restriction msg-notification max-digits 30
restriction msg-notification dial-string preference 1 pattern * allowed

backup server url "ftp://127.0.0.1/ftp" credentials hidden "EWlTygcMhYmjazXhE/VNXHCkplVV4KjescbDaLa4fl4WLSPFvv1rWUnfGWTYHfmPSd8ZZNgd
+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmP"

calendar biz-schedule systemschedule
open day 1 from 00:00 to 24:00
open day 2 from 00:00 to 24:00
open day 3 from 00:00 to 24:00
open day 4 from 00:00 to 24:00
open day 5 from 00:00 to 24:00
open day 6 from 00:00 to 24:00
open day 7 from 00:00 to 24:00
end schedule

ccn application autoattendant aa
description "autoattendant"
enabled
maxsessions 10
script "aa_sample1.aef"
parameter "operExtn" ""
parameter "welcomePrompt" "AAWelcome.wav"
parameter "MaxRetry" "3"
end application

ccn application autoattendent aa
description "autoattendent"
enabled
maxsessions 10
script "aa.aef"
parameter "dialByExtnAnytime" "true"
parameter "busOpenPrompt" "AABusinessOpen.wav"
parameter "dialByExtnAnytimeInputLength" "4"
parameter "operExtn" ""
parameter "welcomePrompt" "AAWelcome.wav"
parameter "disconnectAfterMenu" "false"
parameter "dialByFirstName" "false"
parameter "busClosedPrompt" "AABusinessClosed.wav"
parameter "allowExternalTransfers" "true"
parameter "holidayPrompt" "AAHolidayPrompt.wav"
parameter "businessSchedule" "systemschedule"
parameter "MaxRetry" "3"
end application

ccn application ciscomwiapplication aa
description "ciscomwiapplication"
enabled
maxsessions 10
script "setmwi.aef"
parameter "CallControlGroupID" "0"
parameter "strMWI_OFF_DN" "8001"
parameter "strMWI_ON_DN" "8000"
end application

ccn application msgnotification aa
description "msgnotification"
enabled
maxsessions 10
script "msgnotify.aef"
parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
parameter "DelayBeforeSendDTMF" "1"
end application

ccn application promptmgmt aa
description "promptmgmt"
enabled
maxsessions 10
script "promptmgmt.aef"
parameter "appManagementScript" ""
end application

ccn application voicemail aa
description "voicemail"
enabled
maxsessions 10
script "voicebrowser.aef"
parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
end application

ccn engine
end engine

ccn reporting historical
database local
description "se-10-150-153-101"
end reporting

ccn subsystem sip
mwi sip outcall sub-notify
mwi envelope-info
end subsystem

ccn trigger http urlname msgnotifytrg
application "msgnotification"
enabled
maxsessions 2
end trigger

ccn trigger http urlname mwiapp
application "ciscomwiapplication"
enabled
maxsessions 1
end trigger

ccn trigger sip phonenumber 4300
application "autoattendant"
enabled
maxsessions 10
end trigger

ccn trigger sip phonenumber 4700
application "voicemail"
enabled
maxsessions 1
end trigger

service phone-authentication
end phone-authentication

service voiceview
enable
end voiceview

voicemail broadcast recording time 300
voicemail default messagesize 240
voicemail notification restriction msg-notification
voicemail mailbox owner "Mohammed" size 43200
end mailbox

end
se-10-150-153-101# exit

Session closed

Please advise.

thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
hemurray Tue, 08/10/2010 - 03:43

Here is a few links to help you understand and troubleshoot or at least FXO disconnect issue:

Understanding FXO Disconnect Problem

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a00800ae2d1.shtml

Also, there is an excellent troubleshooing section in the CiscoPress book "Troubleshooting Cisco IP Telephony" under section "

Understanding the FXO Disconnect Problem".

Actions

This Discussion