Issue with TenGig interfaces

Unanswered Question
Aug 10th, 2010

Hello!

Two 3560Es connected.

There was a 6 sec outage of TenGig interface 0/1 on switchA, while no error messages and interface outage were fixed on switchB.

What are the possible reasons for that outage (perhaps fiber/optical connectors raw movement) ? Why in that situation switchB interface didn't went

in down/down state ?

switchA:

switchA#sh run int tenGigabitEthernet 0/1
!
interface TenGigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 343
switchport mode trunk
spanning-tree portfast trunk

switchA#sh idprom int tenGigabitEthernet 0/1 | i ven
Transceiver vendor name :CISCO-FINISAR
Part number provided by transceiver vendor       :PT-X2-10GB-LR
Revision level of part number provided by vendor :02

switchA#sh interfaces tenGigabitEthernet 0/1
TenGigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Ten Gigabit Ethernet, address is 001f.6dcd.8620 (bia 001f.6dcd.8620)
  MTU 9000 bytes, BW 10000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 79/255, rxload 109/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 10Gb/s, link type is auto, media type is 10GBase-LR
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:13, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 4288525000 bits/sec, 848979 packets/sec
  5 minute output rate 3133796000 bits/sec, 1203852 packets/sec
     319611138039 packets input, 207925329171426 bytes, 0 no buffer
     Received 15933471 broadcasts (1861935 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 1861935 multicast, 0 pause input
     0 input packets with dribble condition detected
     456533612914 packets output, 150721245191996 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

switchA#sh logging

Aug 10 11:06:42 spb-bm18-ts1.rascom.ru 41997: Aug 10 11:06:41.568 MSD: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/8, changed state to down
Aug 10 11:06:43 spb-bm18-ts1.rascom.ru 41999: Aug 10 11:06:42.575 MSD: %LINK-3-UPDOWN: Interface GigabitEthernet0/8, changed state to down
Aug 10 11:06:47 spb-bm18-ts1.rascom.ru 42002: Aug 10 11:06:46.962 MSD: %LINK-3-UPDOWN: Interface GigabitEthernet0/8, changed state to up
Aug 10 11:06:48 spb-bm18-ts1.rascom.ru 42004: Aug 10 11:06:47.969 MSD: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/8, changed state to up

switchB:

switchB#sh run int tenGigabitEthernet 0/2
!
interface TenGigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 343
switchport mode trunk
flowcontrol receive desired
spanning-tree portfast trunk

switchB#sh idprom int tenGigabitEthernet 0/2 | i ven
Transceiver vendor name :CISCO-FINISAR
Part number provided by transceiver vendor       :PT-X2-10GB-LR
Revision level of part number provided by vendor :02

switchB#sh int tenGigabitEthernet 0/2
TenGigabitEthernet0/2 is up, line protocol is up (connected)
  Hardware is Ten Gigabit Ethernet, address is 001f.6dce.571f (bia 001f.6dce.571f)
  MTU 9198 bytes, BW 10000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 109/255, rxload 79/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 10Gb/s, link type is auto, media type is 10GBase-LR
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:01, output 00:00:11, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 4453
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 3130664000 bits/sec, 1201335 packets/sec
  5 minute output rate 4283825000 bits/sec, 847495 packets/sec
     3535049629875 packets input, 1128548748159123 bytes, 0 no buffer
     Received 1828722 broadcasts (1594811 multicasts)
     0 runts, 0 giants, 0 throttles
     1183807 input errors, 1079049 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 1594811 multicast, 0 pause input
     0 input packets with dribble condition detected
     2553310230181 packets output, 1625377446612813 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Thanks!

Alex.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
resteban Tue, 08/10/2010 - 06:26

I'd say its a unidirectional problem on the fiber jumper between the transponder and SwitchA.  Possibly a fiber bump only affecting the Tx towards switchA therefore not affecting the client Tx on the transponder facing SwitchB.  If the problem recurs, you could try rolling the fiber jumper between transponder and SwitchA so that the loss would change and be seen on SwitchB side.

Alexander Demin Tue, 08/10/2010 - 23:46

resteban wrote:

I'd say its a unidirectional problem on the fiber jumper between the transponder and SwitchA.  Possibly a fiber bump only affecting the Tx towards switchA therefore not affecting the client Tx on the transponder facing SwitchB.  If the problem recurs, you could try rolling the fiber jumper between transponder and SwitchA so that the loss would change and be seen on SwitchB side.

Perhaps  I misunderstood you, but the transponder is an X2 module directly inserted in 3560E, no fiber jumper cables used.

Tom Randstrom Wed, 08/11/2010 - 05:52

Is the fiber interconnecting the two 3650 switches owned by your company or leased from a telecommunications company? Do you have patch panels in the telecommunications room within the  buildings or is the fiber entering the building directly connectorized  and plugged in the X2 modules?  Are there any connectors in the fiber which are located at intermediate points (splice points) between the buildings.

Alexander Demin Wed, 08/11/2010 - 23:03

baileyshbr wrote:

Is the fiber interconnecting the two 3650 switches owned by your company or leased from a telecommunications company?

Owned by company.

baileyshbr wrote:

Do you have patch panels in the telecommunications room within the  buildings or is the fiber entering the building directly connectorized  and plugged in the X2 modules?

There are patch panels.

baileyshbr wrote:

Are there any connectors in the fiber which are located at intermediate points (splice points) between the buildings.

There are several intermediate splices between buildings.

Actions

This Discussion