2924 and 7206 (non VXR) Upgrade and Bandwidth Throttling

Unanswered Question
Aug 10th, 2010

I have a client who has a series of 2924 switches and a 7206 supporting a dedicated network for a condo community.  As the property has shared, (but dedicated) bandwidth, they'd like to throttle bandwidth to the UDP ports supporting streaming video.  The property has 20Mbps EoC circuit, and since it's shared, they do not want residents streaming video unless they pay extra (above and beyond the fixed bulk rate).  They do not want to restrict all access to streaming video, but rather control it, by throttling the bandwidth so the site will open but it will be extremely slow for users who do not upgrade their service.  Additionally, they want to be able to allow access to these ports for approved users.

  Is this possible using 2924 switches and a 7206?  They are more than willing to upgrade the IOS on the devices and flash if need be, we just need a recommendation as to how to proceed.  File attached with Show Ver info for 7206.

Thank you!!


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rtjensen4 Tue, 08/10/2010 - 10:46

Depending on the streaming protocol, you could use NBAR on the 7206 to identify streaming video traffic and use the QoS framework to throttle it back using a police command. Here's an example of what I do on my 4507, I don't use NBAR, but the idea is the same, limit bandwidth from a particular server to a branch.

class-map match-all SPOclass
match access-group name SPO

policy-map ratelimit-bobcast
class SPOclass
    police 772 kbps 56 kbyte conform-action transmit exceed-action drop

Interface GigabitEthernet4/47
description xxxx
switchport access vlan 503
switchport mode access
switchport port-security maximum 3
switchport port-security
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security aging type inactivity
bandwidth 55000
load-interval 60
speed 100
duplex full
spanning-tree portfast
spanning-tree bpduguard enable
service-policy output ratelimit-bobcast


This Discussion